1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

imovie 09 transitions not working

Discussion in 'Digital Video' started by CRSmoak, May 31, 2009.

  1. macrumors newbie

    #1
    Recently got imovie 09 and noticed that I can't add transitions between clips. I will click on one of the transition effect icons and drag them between the clips but nothing happens? Removed with Appcleaner and tried reinstalling but that didn't do anything. Repair disk permissions also didn't help. Any ideas would be appreciated.

    Thanks,
     
  2. Guest

    spinnerlys

    #2
    Are those clips in the timeline the full length?

    Have you trimmed them a little bit, so that there is enough for the transition to transition?
     
  3. macrumors newbie

    #3
    The first clip is 2:32 long, second one is 12:52 long.
    Under project properties it says transition duration is 0.5s.

    I a complete newb at video editing, so to make sure I'm not doing something else wrong here's what I do.

    1. Import video
    2. Highlight video section, right click, reject selection
    3. File, move rejected clips to trash, resulting in two clips
    4. drag transition between clip but nothing happens :confused:
     
  4. macrumors newbie

    #4
    Moved the clips over from event area (bottom) to editing area (top left) and everything works perfect now.

    I'll definitely be looking at some tutorials to make sure I don't make anymore stupid mistakes, haha.

    Thanks anyway, :)
     

Share This Page