imovie HD, moved all clips to trash!

Discussion in 'Mac Apps and Mac App Store' started by nimr0d, Mar 6, 2006.

  1. nimr0d macrumors member

    Jan 31, 2006
    I imported a movie, and then all of the sudden right when the video was finished i hit stop, imovie then closed unexpectedly, so i reopened it, and now all my clips are in the trash! how do i get them back into where the clips should be located?
  2. menziep macrumors 6502a

    Jan 21, 2006
    Im a Windows User But Cant u Just Use Restore in trash
  3. nimr0d thread starter macrumors member

    Jan 31, 2006
    nope its not in the regular trash, its in like "imovie trash", and the apple website says i should just be able to drag it back into the section for the clips to get it to work, but thats not working at all, i cant even drag them anywhere.:mad:
  4. yoda13 macrumors 65816


    Sep 26, 2003
    Could be a glitch. Might be best to trash the project, check for updates, and then re-import your footage.:eek:
  5. nimr0d thread starter macrumors member

    Jan 31, 2006
    yeaaa re-importing now.
  6. tdhurst macrumors 68040


    Dec 27, 2003
    Portland, OR

    Couldn't you have just dragged the clip icons back into the clips pane?
  7. nimr0d thread starter macrumors member

    Jan 31, 2006
    anyway, i re-imported and everythings going good. Except, anyone want to tell me why when i add transistion effects between clips, it doesnt play the audio?
  8. seaissalty macrumors newbie

    Jan 23, 2007
    Similar problem.

    I had the same problem with clips that were recorded using the built-in iSight feature, so I can't re-import them as they were never imported in the first place. Likewise, I am unable to drag them anywhere to restore them. Have I lost them forever?

Share This Page