InDesign redraw issues

Discussion in 'Mac Apps and Mac App Store' started by ShopJockey, Jun 21, 2005.

  1. ShopJockey macrumors newbie

    Joined:
    Jun 21, 2005
    #1
    I did some reading and a search before posting so hopefully this hasn't been addressed previously.

    The problem I'm having more and more frequently concerns sporadic redraw problems while using Indesign CS. While scrolling around using the grabber OR scrollbars, little artifacts get chopped up and left in window making the whole page a mess until refreshing with either a zoom or fit to window. Of course the next time I move the page around inside the window the same thing happens.
    What also happens is that clicking in a box containing text or a graphic (ANY box on the page) displays the frame border offset down and to the right. So when trying to highlight text, I have to guess where it's going to fall in it's newly offset box so that I highlight the correct text. While I'm typing, the whole story of copy moves to the offset box and when I deselect drops back to where it should be. Most frustrating! I thought the crappy redraw of Quark days were long gone with this new Dual 2Ghz G5 w/2.5Mb of RAM.
    To 'fix' this problem there are a few ways, but nothing that works as consistently as copying everything to a new document. Until I save everything looks correct, but sometimes after I save and reopen the problem reoccurs. Sometimes restarting the machine or InDesign will put things right, but not always.
    I've tinkered with the Auto Activate in Suitcase X 1 (v11.0.4) leaving it on or off, same with the InDesign's Suitcase plugin, but nothing ever seems to fix it for long.

    Anyone experienced this?
     
  2. deanbo macrumors regular

    Joined:
    May 6, 2003
    #2
    Indesign CS Redraw

    Yes, and quite frequently.
     
  3. 7on macrumors 601

    7on

    Joined:
    Nov 9, 2003
    Location:
    Dress Rosa
    #3
    indeed. Accidentally deleted two text boxes and printed thinking they were still there :\
     
  4. tobefirst macrumors 68040

    tobefirst

    Joined:
    Jan 24, 2005
    Location:
    St. Louis, MO
    #4
    I've had the same problem a few times, although not recently (THANK GOD!!!). I have no idea what the cause of this is, as deleting the preferences and repairing permissions doesn't seem to help. You're spot on as far as I can tell when the best "solution" is just to copy everything over to a new document. That seems to be the only way to reliably fix this issue. I hope that CS2 has taken care of this problem.
     
  5. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #5
    Try

    Redraw screen: Shift+F5
    Optimize screen redraw: Command+. [period]
     
  6. ShopJockey thread starter macrumors newbie

    Joined:
    Jun 21, 2005
    #6
    Thanks Blue Velvet, I didn't spot the shift-F5 shortcut but have accidentally Command+.'ed my display into grey boxes plenty of times.
    Unfortunately, while cleaning up the screen, this doesn't fix the offset problem. I'm thinking it may be something to do with Quartz, but I wouldn't know where to start there. Roll on CS2 I guess.
     
  7. ShopJockey thread starter macrumors newbie

    Joined:
    Jun 21, 2005
    #7
    Alright, I'm answering my own question in the event that any of you that posted here check back. There's 2 solutions:

    Solution 1: Hide or show rulers.
    To temporarily resolve the problem, press Command+R to Hide Rulers or Show Rulers.

    Solution 2: Open your document in a new window.
    1. Choose Window > Arrange > New Window from the Window menu.
    2. Close the old window.

    Background information

    This problem may occur if you remove system dfonts, and install large
    numbers of fonts using either Extensis Suitcase or Extensis Font Reserve.
    Replacing the system dfonts doesn't appear to resolve the issue.
     

Share This Page