Inputting Japanese in vBulletin with OS X — Not Possible??

Discussion in 'Mac Apps and Mac App Store' started by SuparShadow, Nov 8, 2003.

  1. SuparShadow macrumors member

    SuparShadow

    Joined:
    Jun 19, 2003
    Location:
    New York, NY
    #1
    Hi.

    I'm trying to figure out why I don't seem to be able to input Japanese characters in a message board (specifically, vBulletin) without having a ? show up instead!

    Does anyone know what I need to do to fix this?
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    Re: Inputting Japanese in vBulletin with OS X — Not Possible??

    Can't say for certan, but my guess would be that the page expressly states a different font encoding, and so the dialogue box specifically tries to display text in that font.

    Your best bet, providing you haven't already tried this, is to manually set the font encoding to Japanese (not sure which version--they all might work, but I'd start trying with shift-JIS). You might also just try a different browser, but if you're using Camino or Safari, it's already Unicode equipped, so that probably won't help. Can't hurt to take a shot, though.

    If neither of those things work, something's funky, but there's nothing magical about a text input box so there should be some way to make it work...
     
  3. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #3
    I've done it here in the past, but only katakana.

    What about this?

    日本語かいいですか?
     
  4. yamabushi macrumors 65816

    yamabushi

    Joined:
    Oct 6, 2003
    #4
    That shows up fine for me, bousozoku.

    Strange, I can't get it to work.
     
  5. irmongoose macrumors 68030

    irmongoose

    Joined:
    Dec 3, 2001
    Location:
    Sometimes Tokyo, sometimes California
    #5
    Did you change the Text Encoding under View to Japanese?



    irmongoose
     
  6. yamabushi macrumors 65816

    yamabushi

    Joined:
    Oct 6, 2003
    #6
    I am using Japanese Win98 at the moment, so Japanese is the default text encoding.

    ‚±‚ê‚ð“Ç‚ß‚éH

    Okay that worked. It must be a problem with Opera since it works in IE.
     
  7. irmongoose macrumors 68030

    irmongoose

    Joined:
    Dec 3, 2001
    Location:
    Sometimes Tokyo, sometimes California
  8. mmmdreg macrumors 65816

    mmmdreg

    Joined:
    Apr 14, 2002
    Location:
    Sydney, Australia
    #8
    umm.. bousozouku's displays but yamabushi and the irmongoose's don't. So yeah.

    ok I eat my words. The first one works under Safari's "default" text encoding. All three work under the Japanese (Shift-JIS) setting.

    ‚¨‚ê‚Í‚ª‚¢‚¶‚ñ‚Å‚·B
     
  9. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #9
    None of the rest of yours are showing up as Japanese for me and Mozilla v1.5.

    [EDIT] Okay, I changed to Shift JIS and they're all fine. [/EDIT]
     
  10. mmmdreg macrumors 65816

    mmmdreg

    Joined:
    Apr 14, 2002
    Location:
    Sydney, Australia
    #10
    Yeah umm why is that? How are you doing it bousozoku?
     
  11. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #11
    The difference between Bousozoku's post and yours is that his went in as unicode characters, so any browser aware of how to display them will show them properly, regardless of text encoding, while yours went in in raw Shift-JIS encoding; since MacRumors is set with Western text encoding, unless you override that and set it to Shift-JIS it won't display your text.

    ‚±‚ê‚Í‚Ç‚¤H

    The text above, I belive, should work, since I'm using Camino, which should send text not in the current page's character set in Unicode, as opposed to most non-cocoa browsers, which will send text in the default encoding (meaning that for a page being displayed in roman, you'll get raw encoded Japanese text with nothing marking it as such). It's the same effect you get if you type Japanese text into the English Google (set with a latin character set) versus the Japanese one.
     
  12. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #12
    No, I take that back. Both Camino and Safari seem to use whatever font encoding you're currently using, and Camino (or vBulletin) chokes entirely if you set it to Unicode.

    That said, what mode were you using, bousozoku? Ending up with properly escaped Unicode is the best of both worlds for a multilingual forum, and that's what your text ended up as...

    (By the way, has anybody else noticed a terminally annoying bug in Camino that causes the browser to go back a page sometimes when you hit "delete" while typing Japanese text?)
     
  13. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #13
    Whoops, seems like I wasn't fast enough...

    No matter what text encoding I try, Makosuke's characters show up as question marks. I know this because I looked at the HTML source code for this thread. I am having the exact same problem, BTW (I'm using Safari v1.1 (V100), which came with Panther).

    <edit>It looks like the problem is fixed. But I still can't get Unicode characters to display correctly.</edit>
     
  14. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #14
    Re: Whoops, seems like I wasn't fast enough...

    Sorry, I was futzing around repeatedly editing the text with different browsers and text encodings; those question marks were out of Safari without the text encoding messed with.
     
  15. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #15
    I'm not doing anything special. I'm just set up for Unicode as a default page type.

    Below are my language settings in Mozilla. I'm not using Camino for now, but I suspect that it was working under similar assumptions.

    [EDIT]
    Panther has defaulted to romaji input despite my insistence to use U.S. English. It apparently knows that I need to get back to using Japanese more often.
    [/EDIT]
     

    Attached Files:

Share This Page