Installing MacPorts & Fink Under Snow Leopard (10.6)

Discussion in 'OS X' started by thinkingman, Jun 14, 2009.

  1. macrumors newbie

    Joined:
    Mar 23, 2009
    #1
    For those of us who need these packages, here are some tips for installing both under 10.6:

    For fink, a great set of instructions exists here:
    http://sage.ucsc.edu/~wgscott/xtal/wiki/index.php/64-bit_Fink_for_10.5
    1. Open up the Terminal
    2. Follow all the instructions on the page http://sage.ucsc.edu/~wgscott/xtal/wiki/index.php/64-bit_Fink_for_10.5
    3. I chose the default options, for those of you 64-bit purists who don't want any 32-bit software on their system, you might want to choose the “64-bit Only” option when prompted by Fink
    4. Also, since I'm not concerned about running a 32-bit version of Fink alongside my 64-bit Fink, I altered the /sw64 wherever it appeared in the instructions to /sw

    For MacPorts, the process was even simpler (although it does look more complicated in these instructions, really it is simpler):
    1. Open up the Terminal
    2. svn co http://svn.macports.org/repository/macports/trunk/base/
    3. Wait for it to finish checking out files
    4. cd base
    5. ./configure
    6. make
    7. sudo make install
    8. sudo /opt/local/bin/port -v selfupdate

    Now, to get the binary paths configured properly for all users of the Mac, I edited /etc/profile with the following:
    1. sudo nano /etc/profile
    2. Add the following lines after the end of this file:
      PATH=$PATH:/opt/local/bin
      source /sw/bin/init.sh

    3. If you didn't change Fink's directory from /sw64 to /sw above like I did, then that last line should instead read:
      source /sw64/bin/init.sh
    4. Then save (if using nano as I did above, ^X then Return)

    Then, close your Terminal window and reopen a new one in order to use the fink and port commands. (In case you don't know, closing/reopening the window in Terminal is the easiest way to test that your installations and path configurations work properly and that your bash sessions can find the paths as you configured them... but if you're following along up to this point, you probably know that already!)
     
  2. macrumors newbie

    Joined:
    May 9, 2005
    #2
    Thank you!

    This is helpful to know. I don't have access to Snow Leopard yet. Is there any confirmation that packages will be updated from Leopard versions?
     
  3. macrumors regular

    dilbert4life

    Joined:
    Jun 23, 2008
    Location:
    Bolivia, according to my flag :P
    #3
    Thanks. This is helpful. I am having a problem though - when I ./configure, it is saying that I have no c compiler, even though I have developer tools installed and was using macports on leopard. What can I do short of trying to reinstall the developer tools?:apple:
     
  4. macrumors newbie

    Joined:
    Jul 13, 2008
    #4
    thanks!

    With ports working I am moving completely to Snow Leopard...
    Thanks again.
     
  5. macrumors newbie

    Joined:
    Jan 27, 2008
    #5
    I have the same problem, I've added the XCode binary location to my PATH (added the line 'PATH=$PATH:/XCode3.1.3/usr/bin' to /etc/profile) but while it can now find gcc, it claims gcc cannot create executables.

    Any ideas? (I'm only installing macports here, not fink)

    -- update --

    You need to use the Xcode installer that comes with Snow Leopard! I foolishly tried using the download of Xcode 3.1.3!
     
  6. macrumors newbie

    Joined:
    Aug 11, 2009
    #6
    Path Issues

    I initially had difficulty getting this to work and started investigating some fairly nasty issues related to threading when I realized that I had a /opt directory already from a previous old install of MacPorts. I renamed it /opt.old (in case I needed to refer to it later) and all went smoothly.

    While probably not even related, but just to be sure, I also renamed my /sw directory (from an old fink install).

    I migrated both directories to my new machine a while back and the architecture was even different, so the binaries in there were most likely pretty useless.

    Hope this helps.

    -Troy
     
  7. macrumors member

    Joined:
    Mar 24, 2008
    Location:
    Munich
    #7
    Fink installation migration

    I have the same problem. I updated from Leopard to Snow Leopard and now in any of my projects that rely on Linux libraries I get linker complaints about wrong architecture libraries.

    I did a fink dist-upgrade right after my :apple: Snow Leopard migration, but that seems not to have updated the packages to 64 bit.

    I looked at the above mentioned guide, and I am tempted to move my existing /sw directory to a backup (/sw_bak) and do a clean fink ./bootstrap onto /sw. But as far as I understand that of course means I'll have to install packages by hand, don't I?

    I did create a list of installed fink packages two months ago, it is still a bit of a hassle, but I most definitely need the libraries for software development.

    Is there an easier way to migrate? Otherwise I'll just bite the bullet, move the directory and go through my package list with fink install <package> (I still could write a bash script maybe). :(

    Thanks.
     
  8. macrumors newbie

    Joined:
    Nov 12, 2009
    #8
    Macports ./Configure Error during MacPorts compilation

    Hello
    i came across this error when i run ./configure during MacPorts compilation

    checking for Tcl package directory... /sw64/lib/tcl8.5
    checking whether tclsh was compiled with threads... no
    configure: error: tcl wasn't compiled with threads enabled

    is there any tip for resolving this problem as i tried different stuff

    thanks in advance

    Bye
     
  9. dyn
    macrumors 68000

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #9
    Regarding MacPorts: download their Snow Leopard installer package, it will automatically install MacPorts without going through all the hassle in the first post.

    @alisajjad007: either recompile tcl with thread support or try the official installer from MacPorts.
     
  10. thread starter macrumors newbie

    Joined:
    Mar 23, 2009
    #10
    I'll second that…

    …I will second that, here, now that 10.6 is officially out (actually 10.6.2), you can quite easily install the official Snow Leopard release and avoid messages like the above. Despite what I've read recommended in other places, I had quite a bit of luck just installing the official package over the previous installation.

    Mahalo,
    Thinkingman
     
  11. macrumors 65816

    macrem

    Joined:
    Mar 11, 2008
    Location:
    Amsterdam
    #11
    Do you mean during Fink compilation? /sw64 looks like a Fink path. MacPorts uses /opt
     
  12. macrumors newbie

    Joined:
    Mar 2, 2010
    #12
    I am also interested in this package for Leopard versions, if anybody know more about this, please let me know. Thanks in Advance.
     
  13. macrumors newbie

    Joined:
    Apr 6, 2010
    #13
    interesting and catchy post there………………….. interesting read should be a sticky lol

    (\_/)
    (o_O)
    (> <)
    /_|_\
     
  14. macrumors newbie

    Joined:
    May 29, 2010
    #14
    That is real quick..
    How you people able to find the answers...?
     
  15. macrumors newbie

    Joined:
    Nov 9, 2009
    Location:
    SW Suburban Chicago
    #15
    Installing macports

    Here's what I get (did I misunderstand?):

    Macintosh-2:~ jackuretsky$ svn co http://svn. macports.org/repository/macports/trunk/base/
    svn: OPTIONS of 'http://svn.': Could not resolve hostname `svn.': Host not found (http://svn.)
    Macintosh-2:~ jackuretsky$ svn co http://svn. macports.org/repository/macports/trunk/base/
     
  16. macrumors regular

    dilbert4life

    Joined:
    Jun 23, 2008
    Location:
    Bolivia, according to my flag :P
    #16
    No, you got it right (almost) you just need to remove the space after svn. - right now you have it as svn. macports.org instead of svn.macports.org.

    That should solve the problem.

    Enjoy!
     
  17. macrumors newbie

    Joined:
    Mar 18, 2011
    #17
    I'm really sorry for the stupid question, but am I the only one who gets:

    " -bash: make: command not found "

    o_O
     
  18. dyn
    macrumors 68000

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #18
    Install Xcode and use the binary installer to install Macports. That way everything will be setup properly and very easily. When it screams it can not find make that might be because you don't have Xcode installed.
     
  19. macrumors newbie

    PenguinApple

    Joined:
    Apr 8, 2011
    #19
    How can I get binaries of Macports?

    I installed Macports on my Macbook Pro 2011 (running SnowLeopard 10.6.6) successfully in order to use KDEnlive.

    Then I ran
    Code:
    sudo port install kdenlive
    
    according to the instructions. But rather than fetching binaries it fetchjes sources and started to compile all souces (even of the whole KDE library) which lasted for HOURS and processor load 100% most times. So I canceled it after an hour.

    Is there a way to get the binaries just lile the "sudo apt-get install kdenlive" in Ubuntu 10.10 ?
    (I have Ubuntu 10.10 in a VMware on my Macbook).
     
  20. wasoomro, Oct 18, 2011
    Last edited: Apr 26, 2012

    macrumors newbie

    Joined:
    Sep 4, 2011
    #20
    Useful Discussion. Thanks.
     
  21. DaveTheMaster, Feb 28, 2012
    Last edited: Feb 29, 2012

    macrumors newbie

    Joined:
    Feb 28, 2012
    #21
    ARGH I get this too! - Has there been a solution to this yet?
     
  22. Mal
    macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #22
    First, you're replying to a thread that was created in 2009 to a post from last year. Second, a few seconds in Google likely could have found the answer (or the next post after the one you quoted):

    Install Xcode (formerly just known as the Developer Tools). make is part of that package.

    jW
     
  23. macrumors newbie

    Joined:
    Jan 1, 2015
    Location:
    PK
    #23
    I feel strongly about it and love learning more on this topic. Thanks for posting such informative content. It is extremely helpful for me.
     

Share This Page