intel G5 imac sleep display brightens up instead off

Discussion in 'PowerPC Macs' started by eternal905, Nov 20, 2009.

  1. macrumors newbie

    Joined:
    Jul 18, 2007
    #1
    I've been having weird this issue and i just reformatted my computer. The sleep light is pulsating but display just brightens and freezes until i move/touch it goes back to normal. And when i put the computer to sleep i hear the hd and fan coming back on but screen does not turn on.

    I Googled everywhere i didn't find anyone else with this issue.
    I have had this problem before i reformatted but it some how fixed itself, i'm not even sure what i did. I tried resetting the PRAM and SMC.... no luck there.

    Any suggestions?
     
  2. macrumors member

    Joined:
    Nov 9, 2009
    #2
    Can you provide any more information? Which version of OS X are you running? Do you have any peripherals attached when you are trying to sleep your machine?

    I was having the exact same problem with my G5 iMac after upgrading to Leopard. Turned out I had a Lacie FW400 HD attached that needed a firmware upgrade to fix the problem. The HD had no issues with Tiger, but my iMac would exhibit the same symptoms you are describing when I upgraded to Leopard. Once I upgraded the HD's firmware, everything was fine.

    Not sure if that helps, but off the top of my head, that's the best I can do without more information.
     
  3. thread starter macrumors newbie

    Joined:
    Jul 18, 2007
    #3
    Sorry, I'm using snow leopard 10.6.2 happened before in 10.5 as well.

    I have 3 western digital hard disks attached to it. I tried to SMC again and left the computer off, woke up and it worked. I did a restart to see if really worked and it gave me the same symptoms.

    i was thinking it was a HD too. I'll see if i can update the drivers.
     
  4. macrumors 6502

    Joined:
    Nov 20, 2009
    Location:
    Calgary, Canada
    #4
    Hi eternal,
    you can't have Snow Leopard installed if your iMac is G5...:confused:
     
  5. macrumors 6502

    Joined:
    Jun 20, 2009
    Location:
    Midwest, USA
    #5
    There seems to be a lot of confusion with the G5 iMacs and Snow Leopard. I wonder why. :confused:
     
  6. thread starter macrumors newbie

    Joined:
    Jul 18, 2007
    #6
    I have the White plastic Intel Core 2 Duo imac, it was still considered a G5 i think.

    But anyways, I think it seems to be a external hard drive problem. I restarted the computer without any usb connections and it worked. I plugged them back in after computer booted up completely so far so good.

    I tried looking for firmware or driver updates but the only thing i found is the Turbo Drivers for WD. Is there a work around for this?
     
  7. macrumors 6502

    Joined:
    Nov 20, 2009
    Location:
    Calgary, Canada
    #7
    Hi nicroma,
    Snow Leopard can't be installed on older Apple chips, only Intel.
    Actually even the 10.5.8 can't read or open most of the Apps. installed on 10.6.
    Snow L. uses a new compression system with-in which is not compatible with anything previous.
    (I have 10.5.8 installed as my main HD and 10.6.2 on my second HD, so I can see the difference I'm talking about).
     
  8. macrumors 6502

    Joined:
    Jun 20, 2009
    Location:
    Midwest, USA
    #8
    I know this. I've just noticed multiple threads with people thinking they have G5 iMacs when they actually have Intel iMacs. Oh well, sorry for diverting the topic.
     
  9. thread starter macrumors newbie

    Joined:
    Jul 18, 2007
    #9
    It seems like any usb external hdd plugged in while booting up is interfering with my sleep screen while its supposed sleeping but the screen brightens and sleeping light is on. The only way to fix this is unplug all my hd disk before restarting. But thats seems to be hassle.


    I cant seem to know the reason why its doing this, is there a system pref thats interfering with this?

    Upadate: The problem still occurs even when i unplug the external hdd unless I reset my PRAM.
     
  10. macrumors member

    Joined:
    Nov 9, 2009
    #10
    Did you try checking for a firmware update for the external HDDs?

    Regarding the G5/intel confusion, I think some refer to the form factor of the white polycarbonate all-in-one form factor as the "G5." However, the G5 refers specifically to an IBM PowerPC processor. I've noticed this error on several posts on macrumors, but anyway...

    One other question, does this only happen with the USB HDDs plugged in? What if you left an iPod or iPhone (if you have one) charging via USB and tried to sleep your machine? Would it reproduce the problem?
     
  11. thread starter macrumors newbie

    Joined:
    Jul 18, 2007
    #11
    The only drivers i can find for both my WD HDD are the Turbo Drivers
    http://support.wdc.com/product/download.asp?groupid=116&sid=108&lang=en

    I have found out that restarting the computer without any USB HDD or anything plug the issues still occur unless i PRAM reset. But it does not seem to work at all now. Tried the SMC reset again still nothing.

    I also get the blank screen from awake computer after forcing it sleep. I would hear the computer coming back to life but no screen.

    I was going to do another clean install. But i realized while it was install the OS the screen does not sleep but sleep light is active.

    Starting to think this is a hardware issue.
     
  12. thread starter macrumors newbie

    Joined:
    Jul 18, 2007
    #12
    ok.... WOW.. it just fixed itself again.

    I just restarted my computer with all USB ports plugged and sleep screen works now. Strange indeed.
     

Share This Page