Intel Mac Mini: Verbose Booting all the time

Discussion in 'Mac Pro' started by skp574, Mar 27, 2006.

  1. skp574 macrumors 6502

    Joined:
    Jan 16, 2005
    Location:
    greenwich.london.uk
    #1
    I got myself a refreshed Intel Mac Mini the other day.

    When I hooked it up to my LCD TV (DVI -> HDMI cable), I noticed that everytime the Mini boots up it does not display the grey screen with Apple logo. Instead I get it booting in verbose mode all the time. Even when I log off or restart is seems to drop out to a black screen and display some messages very quickly.

    If there a way I can get rid of this and return to the good ol' grey screen?
     
  2. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #2
    Good question.

    On PowerPC Macs you use the nvram command to set the boot-args variable to force verbose mode on or off.

    As the Intel Macs don't have Open Firmware I don't know what the equivalent command is for EFI.

    Try resetting NVRAM maybe first - at boot hold down Option-Command-P-R until you hear two beeps (from http://docs.info.apple.com/article.html?artnum=303124).
     
  3. spencecb macrumors 6502a

    spencecb

    Joined:
    Nov 20, 2003
    #3
    Do not try resetting anything yet. All you need to do is SHUT DOWN the Mac. If you keep restarting or logging off, the verbose setting stays intact. You must completely shut down the computer for it to return to normal startup procedures.
     
  4. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #4
    Reread his post. He's tried that.
    You're talking about holding down Command-V at boot.
    Setting verbose mode in nvram is a persistent setting - I think that's what has happened here. He says it's a "refreshed" Mac - perhaps the previous owner had a little hack around with it? ;)
     
  5. skp574 thread starter macrumors 6502

    Joined:
    Jan 16, 2005
    Location:
    greenwich.london.uk
    #5
    Quite probably so.

    I'll try resetting the PRAM and NVRAM. Gotta get hold of a USB keyboard through as I've only got a BT one at the moment. Arr!
     
  6. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #6
    Try typing this in the Terminal:

    sudo nvram boot-args=""

    Hit enter and it should ask for your password. Try rebooting now.

    This is how to disable forced verbose boot on PowerPC Macs. It should work on your Intel Mac too, but I've not tried it myself so this comes with a disclaimer ;)
     
  7. skp574 thread starter macrumors 6502

    Joined:
    Jan 16, 2005
    Location:
    greenwich.london.uk
    #7
    Thanks for the tip. I'll give it a go when I get a chance.
     
  8. skp574 thread starter macrumors 6502

    Joined:
    Jan 16, 2005
    Location:
    greenwich.london.uk
    #8
    Sorted. Typed it into a terminal window and saw that the -v switch was set, so I cleared it. Rebooted and it's now back to normal.

    So I can confirm that this does work on an Intel Mac Mini.
     
  9. drlunanerd macrumors 65816

    drlunanerd

    Joined:
    Feb 14, 2004
    Location:
    UK
    #9
    Excellent! Another satisfied customer :D

    I learnt something too ;)
     

Share This Page