Intermittent Screen Distortion on New Powerbook

Discussion in 'Macintosh Computers' started by mactim, Oct 27, 2005.

  1. macrumors member

    Joined:
    Jul 27, 2005
    #1
    I've just purchased a new Powerbook 15" which I'm very pleased with except for one thing: on rare occasions the screen will distort for a fraction of a second. It's happened to me quite a few times now and I've noticed chatter in other threads of people possibly seeing the same problem. On one occasion the sound also broke up, again for a fraction of a second. Perhaps we have a design flaw or chipset bug in our Powerbooks?
     
  2. macrumors member

    Joined:
    Aug 9, 2005
    #2
    I posted about this in tekmoe's mini-review of his new 17". I'm experiencing it too. My thought is that it's a function of the automatic speed stepping of the CPU/chipset/ATI chip in relation to the usage. The only times I've seen mine do it is when I go from doing something video/processor intensive to idle - like my example was after playing WarCraft III at 1680x1050 for like 4 hours the screen shifted a time or two after quitting back into OS X.
     
  3. macrumors newbie

    Joined:
    Oct 27, 2005
    #3
    I'm not sure the two are related, but I had the same problem and it seems to have stopped since I unchecked "automatically adjust brightness as ambient light changes" on the displays preference pane.
     
  4. macrumors 6502a

    Spectrum

    Joined:
    Mar 23, 2005
    Location:
    UK
    #4
    I've not had this exact problem, but the dispaly certainly goes funky upon waking from sleep - kind of black and white...

    Anyone else see this?
     
  5. macrumors 6502a

    nylon

    Joined:
    Oct 26, 2004
    #5
    I believe Apple had delayed its new Powerbooks from the Paris Expo because it was having some difficulties with the hardware. I don't think those problems have been 100% solved. There was a thread earlier where somone called Applecare and was told that they (Apple) were hoping this problem would not rear its head. I hope most people are not suffering the same problem otherwise I fear more of this issue to crop up.
     
  6. macrumors regular

    fklehman

    Joined:
    Sep 19, 2005
    Location:
    Newark, DE
    #6
    How has WoW performance been for you? I'd heard that the stepdown can happen due to heat buildup, and nothing builds up heat like 6 hours of WoW--I'd hate for the PB to drop to 1/4 speed just as I enter a massive multiplayer instance:eek:
     
  7. macrumors 6502a

    Temujin

    Joined:
    Oct 1, 2005
    Location:
    Copenhagen
    #7
    When an avi is running on top or behind the Dock a half a second of distorted graphics appears where the dock should be. Seen it like 3 times within the last 3 days. When I run fullscreen no distorted graphics appears.

    Do you guys have the "glitch" when not running games or video?
     
  8. macrumors member

    Joined:
    Aug 22, 2005
    Location:
    Vancouver
    #8
    I have only seen it once. When starting a divx after having been just surfing the web and stuff. It looked to me as if the whole screen jumped.
     
  9. thread starter macrumors member

    Joined:
    Jul 27, 2005
    #9
    I've just had an iChat session and seen in twice in about 10 mins. I am thrilled with OSX and all its apps, but this issue is really starting to annoy me.
    Perhaps if we publicise it enough, there might be a firmware/software fix in the future.

     
  10. macrumors newbie

    Joined:
    Dec 4, 2004
    #10
    Yep I have the same thing with a new 15" PB. On mine the bottom half of the screen seems to jump / flicker for a fraction of a second.

    It seems to happen the most when video is playing - it happened five or six times while I had an apple keynote stream open for example. On the other hand I've seen it when just doing regular iTunes / iPhoto stuff, just not as often.

    One other odd thing I've had that seems related - some really crazy loud sound distortion. It's happened a couple of times in iTunes - I've started playing a song and it sounds like it's being played through an ice cream van - far too loud, with loads of echo and reverb. If I stop the music then start again it goes away. I've also had a couple of similar sound glitches while watching videos. Has anyone else had that?
     
  11. macrumors 6502a

    Temujin

    Joined:
    Oct 1, 2005
    Location:
    Copenhagen
    #11
    I've had a sound glitch in iTunes, songs get stuck for 2 - 3 sec.
    It's also on the bottem of the screen on mine the graphics screws up, also divx/xvid movies.
     
  12. macrumors 68000

    BWhaler

    Joined:
    Jan 8, 2003
    #12
    I have the new 17" PowerBook, and I have noticed it too.

    I have used my new Mac for about 15 minutes, and it happened:

    1. When shutting down
    2. When closing System Update

    It seems isolated to the middle right side of the screen.

    After trying my new Mac for 15 minutes, I shut it down. But after about 45 minutes, I botted it again to see if I could see the problem again. It didn't happen.

    This really bums me out since it is intermittent and will take Apple time to acknowledge. I really hope this turns out to be nothing or a software based problem.

    I really really hope I don't have to return this beautiful new Mac.

    Fingers crossed...
     

Share This Page