Internal Ethernet Problem with iBook

Discussion in 'Macintosh Computers' started by kpmeagher, Nov 29, 2004.

  1. kpmeagher macrumors newbie

    Joined:
    Nov 29, 2004
    #1
    Hello,

    I cannot get the internal Ethernet port on my iBook to work. The iBook is running 10.3.6 and the ethernet port appears to be configured correctly but when I plug in a RJ-45 to my router the iBook never recognizes the network connection. I also have a D-Link 122 installed (works great with a driver release from the international group at D-Link, an FYI) but the RJ45 does not work. I know the cable is good because I connect to an XP laptop fine. Does the iBook need a crossover cable?

    Any help or suggestions greatly appreciated. ;)

    PS - This is my cousins iBook and while I am a previous Mac user, I have not used one in a couple of years. :mad:
     
  2. jadam macrumors 6502a

    jadam

    Joined:
    Jan 23, 2002
    #2
    I seem to be having the same problem with my G3 700 ibook. Sometimes what I would have to do is put some slight presssure on the bottom of the ethernet cable, but now, it doesnt work at all anymore and im angry as hell!
     
  3. combatcolin macrumors 68020

    combatcolin

    Joined:
    Oct 24, 2004
    Location:
    Northants, UK
    #3
    try and connect with another ethernet cable, if you havn't got one borrow one from a tech-head - they'll aways have spares
     
  4. jadam macrumors 6502a

    jadam

    Joined:
    Jan 23, 2002
    #4
    My ethernet cables work fine, as they work perfectly fine when I plug them into my pc.
     

Share This Page