Internal Speakers Don't Work

Discussion in 'MacBook Pro' started by joejoejoe, Sep 27, 2007.

  1. macrumors 65816

    Sep 13, 2006
    Hey guys,

    Sound isn't coming out of my internal speakers. When I hook up headphones everything is fine, but when I'm on the computer itself, no sound comes out, a red light is coming from my headphone jack, and the volume controls don't do anything (volume stays at max and there's a white circle with diagonal sign thru it, like a no smoking sign) and I don't get sound.

    Any ideas?

    I tried restarting and all that....

  2. macrumors 6502

    Feb 17, 2007
    NB, Canada
    Try plugging a headphone jack into it, and then remove that... I have heard that it works.
  3. thread starter macrumors 65816

    Sep 13, 2006
  4. macrumors 6502

    Feb 17, 2007
    NB, Canada
    Do some searching on this forum, there are quite a few threads about it, should find a solution there.
  5. macrumors newbie

    Jun 29, 2009
    no sound on internal speakers - mac book pro


    I have the same problem with the speakers not working on my macbook pro. Same red light in the headphone jack, and sound is fine on headphones. Did anyone figure this out?

    Any help would be greatly appreciated,


  6. macrumors newbie

    Nov 2, 2009

    I had the exact same problem. What is happening is that there is something jammed kind of in the head phones jack. System preferences won't give you the option of internal speakers because it thinks the head phones are still plugged in. Gently wiggle the head phones jack around in the plug in and it should recognize that they are out again. As long as the red light is on it thinks there are head phones plugged in.
  7. macrumors 603

    Mar 14, 2008
    Your MBP is trying to send an optical audio signal to an optical cable that isn't there, that's why your speakers don't work. As to how to fix it, beats me, my penryn doesn't do it.
  8. macrumors newbie

    Jul 21, 2008
    I'm having the same problem in Win 7 Boot Camp, on the 27" i7 iMac.

    - No audio from iMac internal speakers.
    - Red light from the headphone jack.
    - Tried updating to the new boot camp drivers Apple released in January. No luck.

    Been looking for solutions for a few weeks now. Would greatly appreciate being pointed in the right direction.
  9. macrumors newbie

    Oct 19, 2007
    I just fixed this issue on my MBP...

    I took my headphone cord and pushed it in, then a few times in a row I pulled the connector out just a few MM, then pushed it back in, then out... a few times.

    When next I pulled the plug all the way out of the jack, it showed my internal speakers just fine.

    Thank heavens it worked. I can't afford a bunch of computer issues right now. :)

Share This Page