Internet Disconnects in Sleep mode

Discussion in 'MacBook' started by zerolol, Jan 9, 2009.

  1. macrumors newbie

    Joined:
    Aug 13, 2008
    #1
    Ok this is really annoying now everytime my macbook is in sleep mode the internet disconnects (msn messenger shuts down, download stops etc...). I am not talking about closing the lid sleep mode because i am in desktop mode with an external display. Once I woke up my macbook it reconnects. Does anyone know how to stop this because i think it happened after 10.5.6.
     
  2. macrumors newbie

    Joined:
    Jan 9, 2009
    #2
    A Few Things to Try

    Hello,

    So I've got a few things you can try.. first make sure all of your software is up to date. Then go into your system preferences > energy saver > and uncheck the option "put hard disks to sleep when possible". Have you tried a SMC and a PRAM reset? Let me know.
     
  3. LTX
    macrumors regular

    LTX

    Joined:
    Dec 25, 2008
    Location:
    Vancouver, BC, Canada
    #3
    If I understand you correctly, then you're saying your Mac disconnects when you place it in sleep mode. This is normal, because you are essentially shutting it off. I'm not sure what you mean about the external display, though.
     
  4. thread starter macrumors newbie

    Joined:
    Aug 13, 2008
    #4
    I did put uncheck the hard disk to sleep didnt work. I realise that it disconnect few min after sleep. How do you smc and pram reset?
     
  5. LTX
    macrumors regular

    LTX

    Joined:
    Dec 25, 2008
    Location:
    Vancouver, BC, Canada
    #5
    Like I said, disconnecting during sleep is normal. Would you rather just walk away from the machine when you're not using it and have it turn on the screen saver? You can disable auto sleep by going to System Preferences --> Energy Saver and changing the "Put the computer to sleep when it is inactive for" slider to Never. Then, don't sleep it at all.
     
  6. macrumors 68040

    NewMacbookPlz

    Joined:
    Sep 28, 2008
    #6
    Regardless of what monitor you're using, sleep shuts down the hard drive of the computer.

    As stated above, you need to switch it to Sleep "Never" in the correct power profile.
     

Share This Page