Internet Sharing won't work, greyed out... but not on! Suggestions?

Discussion in 'Mac OS X Lion (10.7)' started by chazzmoney, Aug 22, 2012.

  1. macrumors newbie

    Joined:
    Aug 22, 2012
    #1
    I'm trying to start internet sharing on my MacBookPro (13-inch, Mid 2012).

    I'm running Mac OS X Lion 10.7.4 (11E2617).

    Ethernet is on and connected. Wifi is on and connected to a created network (which I created to share out my internet).

    Why are the options to turn it on greyed out? Any suggestions appreciated, as I'm tearing my hair out here.

    Thanks.
     

    Attached Files:

  2. macrumors demi-god

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Left hand side tick the box
     
  3. chazzmoney, Aug 22, 2012
    Last edited: Aug 22, 2012

    thread starter macrumors newbie

    Joined:
    Aug 22, 2012
    #3
    I cannot. The box is greyed out. (a non greyed out box appears as fully white when selected in the list.)
     

    Attached Files:

  4. macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #4
    Can you first check Wifi on the right in order to select the port then check Internet Sharing on the left?
     
  5. thread starter macrumors newbie

    Joined:
    Aug 22, 2012
    #5
    The control to select Wifi on the right is greyed out, as per the screenshot.

    I want to check that box, but cannot.

    ----------

    Does anyone know where these settings are read from?

    Maybe I can edit one of those files and trick the system into thinking that internet sharing is already on. Or set the wifi so that the port is selected.
     
  6. macrumors 6502a

    Joined:
    Jul 1, 2010
    Location:
    Texas
    #6
    How do you actually connect to the internet? Wifi or ethernet?

    I just tried it on my Air and it worked via WiFi. I don't have ethernet to try it.

    Also, you are connected to a router, correct? I remember when I was trying it out a long time ago that a switch wouldn't work.
     
  7. killerrobot, Aug 22, 2012
    Last edited: Aug 22, 2012

    macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #7
    I'd try turning off wifi, and restarting the machine only connected to the ethernet to see if it would let you select a port on the right then.

    EDIT: I just went through all the possible connections on my MBP/ Lion. It didn't matter if I was connected to both or not. The only thing that grayed out those possibilities was when I hadn't authenticated. I'd click on the lock to lock the settings, then unlock it again and see if that works.
    Other than that I'd reboot and hope that fixes it.
    One last thing - is there another computer called My Computer on the network? Try changing the computer name to see if that helps.
     
  8. thread starter macrumors newbie

    Joined:
    Aug 22, 2012
    #8
    I have both ethernet and wifi connections available. Switching which is connected to the internet and which is connected to the system that wants to share the connection makes no difference in the capability to change settings.

    Weird that a switch wouldn't work. I am connected to a router.

    Thanks for the ideas! I'll conquer this with suggestions like these at some point.

    ----------

    Tried the restart without wifi to no avail.

    Clicking and unclicking the lock also doesn't seem to work. I'll reboot again and see if it makes a difference.
     
  9. macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #9
  10. macrumors newbie

    Joined:
    Feb 20, 2015
    #10
    Had to fix Network Preferences First

    I had Network Preferences set to Automatic, which let me connect to internet through automatically detected WiFi. But in Sharing Preferences, Internet Sharing was unchecked, grayed out / greyed out, and there were no options under WiFi which was also grayed out / greyed out.

    When I changed Network Preferences to Wifi, and it showed Wifi and Ethernet both unconnected. After Wifi connected and got an IP address, I was able to go to Sharing Preferences and place a checkmark next to Internet Sharing, and also Ethernet was available under Wifi and checked.

    Hope this helps someone.

    Kindest regards,

    Don
     

Share This Page