Invisible Shield application...

Discussion in 'iPod' started by boiee, Apr 3, 2007.

  1. boiee macrumors member

    Joined:
    Oct 22, 2005
    #1
    I just re-installed my Invisible Shield and I made a mistake..

    After the application, I noticed that I got some water on the bottom left part of the screen :(

    I was just wondering has anyone had this same problem and have the water dry up after the 24-48hr ? What did you do to get rid of the water? Maybe let it dry on its side? I'm really worried that it might not get out..this sucks

    Any success stories and/or help and suggestions would be appreciated..this is going to be a scary 24-48hrs for my new ipod :(
     
  2. boiee thread starter macrumors member

    Joined:
    Oct 22, 2005
    #2
    heres a pic :(
     

    Attached Files:

  3. J.B.Horns macrumors newbie

    Joined:
    Jan 31, 2006
    #3
    Is the water inside the iPod itself, or is it trapped between the film and the surface of the ipod?

    If it's just under the film, there's a chance it'll go away. I helped my brother in law install his Protech, and there was pretty big bubble in one of the corners, about the size of two pencil erasers side by side, and it went away in a couple days.

    If it's inside the iPod, leave the iPod off for at least a few days. My 4-year old gave my PSP a bath once, and he fried it when he turned it on. When it happened, I did a google search for PSP water damage, and I found someone who dropped his PSP in the toilet. He dried it out by putting it in a pillowcase and swinging around as fast as he could. The centrifugal force got a lot of the water out. You might try this. My friend's Nano took a ride in the washing machine and it lived. It was a week or so before it worked right.

    Sorry for the long post. The good news is, there's hope either way.

    J.
     

Share This Page