iOS 3/4 Compatibility

Discussion in 'iPhone/iPad Programming' started by Locker, Aug 1, 2010.

  1. macrumors 6502

    Joined:
    Aug 22, 2007
    Location:
    Staffordshire, UK
    #1
    I've got an app which I'm building for iOS4 (so that it automatically supports Fast App Switching), but I've got the 'iPhoneOSDeploymentTarget' set to 'iPhone OS 3.0' so that it works on 3.0 onwards.

    When setting the 'iPhoneOSDeploymentTarget' it warns:

    How would I go about doing the above? Reason being that I'm trying to implement the MFMessageComposeViewController for sending in-app SMS and whilst it works fine on an iOS4 device it falls over with my 3G running iPhone OS 3. This is the error it's retuning:

    Any help would be greatly appreciated :)
     
  2. Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #2
    Did you weak-link the MessageUI framework?
     
  3. macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #3
    I recommend that unless you have a strong reason for doing so and some experience doing so that you not try to support any OS older than 3.2 for new code.

    It's a free upgrade from OS 3.0 to 4.0. Any user that won't upgrade also won't buy your app.

    It's a lot of extra effort during development and testing to support older OSes as well.

    If you really really want to support something older than 3.2 then make it 3.1.3. Supporting more than that for a new app doesn't make any sense to me.
     
  4. macrumors 6502a

    Joined:
    Nov 9, 2007
    #4
    Normally I would agree but with iOS4 running like a dog in an iPhone 3G there is a perfectly valid reason why many people will not be upgrading any time soon. Dropping 3.x support is not as much of a no brainer as dripping 2.x support was.
     
  5. thread starter macrumors 6502

    Joined:
    Aug 22, 2007
    Location:
    Staffordshire, UK
    #5
    Aha, the framework wasn't weak linked - that solved it! Thanks :)
     
  6. tod
    macrumors regular

    Joined:
    Oct 3, 2009
    Location:
    Ohio
    #6
    I'll just throw in that I still have many 3.x users of my 4.0 compatible, universal apps. Plus, I have yet to write something that actually needs 4.0 to run. So why not support 3.x for awhile, for the poor people who have devices that can't run 4.0? Pretty soon they will have no apps to choose from unless they buy a new device.
     
  7. macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #7
    There's a difference between keeping support in an app that was developed on 3.x and adding support for 3.x in an app that's being written using the 4.0 SDK.

    Up to each developer to decide of course.

    At any rate the topic of how to do this has been discussed quite a bit on this forum and ad infinitum on the Apple iPhone forum so anyone should be able to find all the info they need.
     

Share This Page