iPhone iOS 7 beta 4 screen goes black after update

Discussion in 'iOS 7' started by hodor123, Jul 30, 2013.

  1. macrumors newbie

    Joined:
    Jul 30, 2013
    #1
    I have been using iOS 7 betas without any issues. However, yesterday after the OTA, my iPhone 4 booted up with the Apple logo and then went black. iTunes is able to detect it and even when I tried calling on my number from another phone, the call went through but I didn't see anything on my iPhone.

    I tried restoring it by downloading the ipsw. I got the setup screen and after completing the setup, the iPhone again booted and went black.

    I then restored to 6.1.3, which worked fine. I tried to restore it again to beta 4, and same issue again.

    I doubt its a hardware issue, since I get the setup screen and it works. Any suggestions?
     
  2. macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #2
    Hold the home and power buttons until you see the Apple logo. This is a hard reset, and has fixed this issue for others.
     
  3. thread starter macrumors newbie

    Joined:
    Jul 30, 2013
    #3
    Hi,

    Thanks. I have tried that, doesn't work. It boots up, the Apple logo shows up, and again goes blank.
     
  4. macrumors member

    Joined:
    Sep 18, 2012
    Location:
    CT
    #4
    If you continue having this issue but are able to get to the homescreen, you may have some app data/settings causing the problem.

    Try resetting all settings by going to Settings > General > Reset.
    If you still have problems... you may need to restore and then start as a new iPhone.

    Hope this helps.
     
  5. macrumors 68020

    bbfc

    Joined:
    Oct 22, 2011
    Location:
    Gosforth, England
    #5
    I would set up as a new phone.

    Restore to iOS 6 and set up as new and then update to the beta.
     
  6. thread starter macrumors newbie

    Joined:
    Jul 30, 2013
    #6
    I can't get to the homescreen. It goes blank right after the Apple logo.
     
  7. macrumors member

    Joined:
    Sep 18, 2012
    Location:
    CT
    #7
    One last thing i'd try before restoring and setting up as a new phone:

    Restore to the latest OS you can successfully run, with all your data.
    Reset all settings.
    Goto Settings > iCloud and disable Find My iPhone (this helped in previous betas...)
    Update to iOSb4 from iTunes.

    If it works, make sure to re-enable Find My iPhone. If it doesn't, it looks like your only other option is to start as a new phone :(
     
  8. macrumors newbie

    Joined:
    Nov 12, 2010
    #8
    the same thing has happened to me. i can't access through iTunes because it is awaiting for me to press the "i trust this computer" on my iPhone - but obviously i can't do that because the screen is black

    if i call it, the call goes through but the iPhone doesn't ring or vibrate or anything
     
  9. macrumors newbie

    Joined:
    Nov 12, 2010
    #9
    i had to put it in DFU mode and trying to restore to 6.1.3. it tried to restore to iOS 7 beta 3 but an error occurred
     

Share This Page