1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

iOS 7 iMessages and Facetime won't activate!

Discussion in 'iOS 7' started by ts599, Jun 11, 2013.

  1. macrumors newbie

    I've just upgraded to iOS 7 and when I try to activate iMessages the settings app just quits. When I try to sign into Facetime it says to check the connection. I'm connected to my home wifi network that has a 10 mbps download and 1 mbps upload speed. Any ideas on how to fix this? Also I'm running iOS 7 on and iPhone 4s.
  2. macrumors 68030


    There have been a lot of other threads on this topic. I am not sure what the remedy is, but you might want to check them out to see if other users have solved it.
  3. macrumors G4


    Apple probably aren't activating any iOS 7 stuff like that at this stage.
  4. macrumors 68030


    It is working for some, so that isn't the answer.
  5. macrumors 6502a


    And I have tried everything suggested in the other threads to no avail. Google, too. Airplane mode, wifi, reset network settings, reinstall iOS 7, set up as new...


  6. macrumors newbie

    I tried the method where you first restore your phone with the beta, downgrade to 6.1.3, set up phone as new, THEN update back to the beta iMessage and Facetime turn on. But When I tried to restore to my last back-up, iMessage went back to not working as before.
  7. macrumors 6502a

    Backup and try to restore from iCloud.
  8. macrumors 6502a


    Maybe if someone else confirms this works. I've restored and reinstalled at least 6 or 7 times today. I am so not ready to try it all again.
  9. macrumors G4


    Oh right? Huh - well that makes it a bit tougher. Cheers for the info.

    Early beta etc etc - I guess there's some caveats there. I wouldn't install it on my daily driver iPhone.
  10. macrumors 6502a


    I downgraded back to 6.1.3, setting up as new, and I can't get iMessage to activate on 6.1.3 either now. Sigh.
  11. macrumors regular

    A couple of friends go that issue, all we had to do was to proper setup the date and time (we even went to Privacy-Location Services-System services-Turning ON Setting Time Zone). That should fix the issues. Good luck.
  12. macrumors 6502a


    Doesn't work. I have tried everything I can think of or found on Google. I've even tried downgrading - and now nothing activates on 6.1.3 either.
  13. macrumors newbie

    So. just set it up as a new iPhone and you should be fine!! No joke before I restored from the back up everything worked.
  14. macrumors 6502a


    Tried that as well.

    Here is a list of everything (that I can remember) that I've done:

    - Putting phone into airplane mode, then enabling Wi-Fi
    - Changing DNS of Wi-Fi connection to something like etc
    - Logging out of my Apple ID
    - Making sure my mobile number is correct for my Apple ID
    - Making sure my payment information is up to date on Apple ID
    - Changing my mobile number in Phone > My Number and then changing it back
    - Turning iMessage/FaceTime on and off, rebooting phone (multiple times)
    - Changing Date & Time to "set automatically"
    - Reset Network Settings
    - Reset all settings
    - Erase all content / settings from phone and starting over
    - Creating myself as a contact and adding my Apple ID email address & telephone number
    - Restoring phone to multiple iOS versions
    - Setting up phone as new on multiple iOS versions

    Literally nothing I can do will activate iMessage again. And Apple has no idea how to fix it. :\
  15. macrumors newbie

    I can't even turn on my iMessages
  16. macrumors newbie

    I called Apple about this because my phone is doing the same thing. Tech support said that it is because so many people are currently on Apple's server trying to download iOS 7 and activate their own iMessage. he said it is just a waiting game and you'll have to keep trying until it works. it sucks but it happens.
  17. macrumors 65816

    Allow account changes..
  18. macrumors newbie

    Mine has been stuck on Activating for about 10 hours now. Very annoying.

Share This Page