iOS 7 stuck messages badge icon

Discussion in 'iOS 7' started by ilpadrino6, Jun 24, 2013.

  1. macrumors member

    Joined:
    Jul 23, 2008
    #1
    This happened to me in beta 1, my messages app says 2 unread messages even though I cleared it. I updated to beta 2 and it is still there. I have tried everything to clear it. Any suggestions?
     
  2. macrumors newbie

    Joined:
    Jun 24, 2013
    #2
    Yeah I've had the same problem since beta 1 as well, does anyone know how to clear native app cache without a jailbreak?
     
  3. thread starter macrumors member

    Joined:
    Jul 23, 2008
    #3
    Glad I'm not the only one, Ive only seen jailbreak options but I really do not want to start the phone from scratch
     
  4. macrumors newbie

    Joined:
    Jun 25, 2013
    #4
    This is happening to me as well - I even tried turning off badges for a while and turned them back on. No luck.

    #firstworldproblem

    But seriously this is really annoying
     
  5. macrumors regular

    danielceleste

    Joined:
    Jun 16, 2012
    Location:
    Canada
    #5
    It appears to be a glitch where a message is received but does not show up in the conversation in Messages.app. It shows up in Notification Center, but tapping on it from there simply opens up the window to compose a new message to a new contact. So I deleted all of my conversations (eek) and cleared it from Notification Center. the (1) is still there. So now, I have an unread message stuck in empty space of iOS where I will never be able to officially "read" it. That's why the badge won't go away.

    In beta 1, I was able to go to Settings > General > Usage > Messages and then delete all of the "Messages (Saved)" from there. Over the span of a few minutes, they cleared and the badge was gone. But now the delete option is not there. I have to hope Apple re-introduces it in beta 3, (or any of the future betas), or else this unread message will forever haunt me through my backups.
     
  6. macrumors member

    Joined:
    Dec 18, 2010
    #6
    If you have iMessage running on another device. (iPad or Mac) check and see if the message show up there. This seems to be a problem with the iMessage service rather than iOS7 as I have had this happen to me before whilst using iOS6. The message did eventually come through on my phone.
     
  7. macrumors newbie

    Joined:
    Jul 1, 2013
    #7
    same problem with the badge

    got also the 1 as badge on my messages badge. using ios7 beta 2 on my i5 and also on my ipad mini. so ive got 3 imessage devices (macbook, ipad, iphone). dont know why the badge is only on my iphone. i deleted my conversations on ipad and iphone. no solution. i think, it was an image. it appeared on my iphone, but on my mac und ipad.
     
  8. macrumors 65816

    Joined:
    Nov 18, 2007
    #8
    Does anyone know of a solution to remove the 1 count on the badge?
     
  9. macrumors newbie

    Joined:
    Jul 1, 2013
  10. macrumors newbie

    Joined:
    May 30, 2008
    #10
    Same problem, ios 7 beta 3. Still have "1" unread badge notification on my messages app, drives me nuts. Logged into my MacBook for iMessage (using my email) & it didn't fix a thing. I think the problem is, is that you can't be logged in iMessage as your phone number on Mac, only on iPhone. I've read a few times to send a message to yourself & it'll clear also. No luck at all. My iPhone 5 better not do this forever.
     
  11. macrumors 68020

    iapplelove

    Joined:
    Nov 22, 2011
    Location:
    East Coast USA
  12. macrumors newbie

    Joined:
    Apr 25, 2013
    #12
    Also have the same problem on my iPhone 5. Cleared all the archived messages on my macbook, iPad mini, and iPhone, but to no avail. I restored from a backup I have on my macbook from May and the Badge didn't show up and then tried to restore from my latest backup and it showed up again. so if it comes down to it I guess I could use my old backup and redo all my new settings, apps, etc. But I was hoping as well that beta 3 would fix it or that I could find a solution on here. I am glad, however, that I am not the only one that has this same problem.
     
  13. macrumors newbie

    Joined:
    May 30, 2008
  14. macrumors 6502

    Joined:
    Dec 22, 2006
    #14
    I had the issue in beta 1, upgraded to beta 2 and tried everything I could to get rid of it. I finally just bit the bullet and started from scratch. Haven't had the issue since.
     
  15. macrumors regular

    Joined:
    Feb 26, 2009
    #15
    Yep. I experienced this issue when updating from beta 2 to 3, I think because i got a text during the update process. Tried downgrading to 6.1.4 and then upgrading to beta 3, problem came back once I restored from a backup. Ended up just have to do a clean install of beta 3.
     
  16. macrumors newbie

    Joined:
    May 30, 2008
    #16
    So you restarted fresh? As in, lose all info on the phone, address book, pictures, etc? In other words. You chose not to restore from backup?
     
  17. kinzoduh, Jul 10, 2013
    Last edited: Jul 10, 2013

    macrumors newbie

    Joined:
    Jul 10, 2013
    #17
    The 1 is gone

    I was in the same boat till few minutes ago. Tried almost all the things mentioned in this thread. I use iMessage on iPhone and iPad as well as on MacBook with my Apple ID. Just logged out of iMessage on my iPad and the 1 disappeared from iPhone within a minute or so. Perhaps it's just a coincidence...

    Never mind. It's back and this time not going away.
     
  18. macrumors 603

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #18
    This.
     
  19. macrumors 68040

    VSMacOne

    Joined:
    Oct 18, 2008
    #19
    Have you guys tried hard quitting the app? Ope the app, hold down Power button until red Power Off slide appears, and then hold the home button until the app quits. That has helped me in the past.
     
  20. macrumors regular

    Arn0

    Joined:
    May 9, 2012
    #20
    I tried everything. Logged out of iMessage on iPhone, Mac, but 1 is still there.
    I did a reset all settings, springboard, hard quitting app, iPhone, restarted, but 1 still there too.
     
  21. macrumors 65816

    Joined:
    Nov 18, 2007
    #21
    Will pay $100 to whoever has a fix for this without deleting all my message history.
     
  22. macrumors newbie

    Joined:
    May 30, 2008
  23. macrumors member

    Joined:
    Sep 12, 2008
    Location:
    Tampa, FL
    #23
    11 unread texts is my new 0
     
  24. macrumors regular

    Joined:
    Feb 26, 2009
    #24
    Yep. I mean a lot of stuff is stored in iCloud (phone numbers, etc.), and I don't really care about saving old texts.
     
  25. macrumors newbie

    Joined:
    Jul 16, 2013
    #25
    Deleted a thread of 5 messages and the badge icon showing "5" remained on the home page.

    Went into the Trash mailbox, restored the entire string of 5 messages to the Inbox, clicked on every individual message in the thread and the badge icon disappeared.

    I think this bug comes up when you delete an unread message. Make sure to read all messages and the badge icon should work properly.
     

Share This Page