IP Address Conflict?

Discussion in 'Mac Basics and Help' started by nl2134, Jul 27, 2007.

  1. macrumors member

    Joined:
    Feb 15, 2006
    #1
    I have two laptops on the same network. When one of them is on, the other cannont get on because of this IP conflict, and vice versa.

    How do I change one of the IP addresses so I can get both laptops on the network at the same time? I'm looking to transfer music between two laptops and because they both can't connect to the network at the same time (Mac and PC), I can't transfer the files.

    Thanks!
     
  2. Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    Sounds like your laptops are not allowing DHCP to assign them an address. On OS X, you fix this by Sys Prefs -> Network -> (whatever interface is involved) -> TCP/IP -> Configure IPv4 Using DHCP. Do the equivalent on the other PC also.
     
  3. macrumors newbie

    Joined:
    Jan 25, 2010
    #3
    IP conflict with mac

    I am having the same issue with my mac - every day when I turn on my mac I get an IP conflict message. How do I fix this? We have a windows dhcp server allocating addresses to the mac. I take my mac home every night and when I turn it on, I get this message.
     
  4. macrumors newbie

    Joined:
    Feb 8, 2011
    #4
    I have the exact same problem. I was so frustrated that I actually just reinstalled os x and that fixed the problem. Sadly, it popped up again and I would like to avoid reinstalling my operating system every week. Thanks for your help.

    Part of me thinks this is a problem with the OS so I wonder if I install linux if it will fix the problem.

    If anyone can give me ANY help it would be greatly appreciated. Thank you for your time.
     
  5. macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #5
    This is rarely a host problem because hosts don't assign IP addresses. You should probably reboot whatever you're using to hand out IP addresses- probably your home router.
     
  6. macrumors newbie

    Joined:
    Mar 23, 2011
    #6
    First how big your DHCP pool?

    Got 10 devices then set it to 25 to be safe.

    Next open up the terminal and use the command

    sudo ipconfig set en1 DHCP

    As a rule of thumb the first 20 IP addresses don't use.

    Example 192.168.1.1 thru 192.168.1.21 are used for static IP addresses for network devices such as a Blu Ray player, Xbox, wireless print server or any computer you need to get to remotely

    I usually set the gateway(router LAN interface) to 192.168.1.1.

    Then set the DHCP pool in the router to start using 192.168.1.100 and allow 25 leases. 25 sound like a bunch? Not really, these days with wifi enabled devices you can use them up quickly. I had a party for my son and there were 20+ kids. I looked at the Local Network and I had maxed out the leases of 15.....kids these day:)
     
  7. macrumors 603

    Tomorrow

    Joined:
    Mar 2, 2008
    Location:
    Always a day away
    #7
    Regardless of whether your router/server is set to assign IP addresses via DHCP, you can manually set your IP addresses, even if you do it for some devices and not others. That should fix the problem.
     
  8. macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #8
    I've experienced this before. In businesses where I had previously set up a network eventually one of the devices on their network will take over the IP address that my Mac used during setup. When connected to those networks weeks or months later I'll get the same message and the only work around is to switch to manual IP, change the networks IP address pool say from 192.168.0.x to 192.168.1.x or change the SSID.

    I would consider this a flaw in Mac OS X. As the Macbook will receive an IP address automatically when connecting to a new network and the problem networks will assign new IP addresses to new devices. Windows computers will also just take a new IP address when their old one is taken. Mac OS X on the other hand will stubbornly refuse to get a new address. If I apply a new address manually that is within the pool and unused if I switch back to DHCP it will keep trying for the old used address.
     
  9. macrumors regular

    macmikey2

    Joined:
    Jul 6, 2008
    Location:
    West Chester, PA
    #9
    You could use the Locations to fix this as well. Especially the poster who gets this error when traveling from work to home.

    One, shut down the Mac when leaving work. Don't sleep. That preserves the network settings and they will be used the first time it wakes up - at your house with the wrong address.

    Two, setup locations for each place you use the Mac. One for work, one for home, etc... the simply switch BEFORE you go to the new location.

    Third, you can try to get DHCP to renew its lease when having this issue. Just click on Renew Lease in Network Prefs - Advanced - TCP (for the port; ethernet or wireless). If that does not clear it up do a restart and then it should grab another address that is free.

    This usually only crops up when assigned addresses are used and they overlap. I try to block my addresses like another poster above: my game systems in one small block, network printers in another, servers in another and all computers/phones, whatever, get their addresses via DHCP from about .100 and above.

    Mikey
     
  10. macrumors newbie

    Joined:
    Oct 19, 2007
    #10
    Turn off IPv6

    Turn off IPv6 (switch to Link-local only) to resolve this conflict
     
  11. macrumors newbie

    Joined:
    Jan 4, 2012
    #11
    Have your network admin assign a static address to your DHCP server for your machine. That way everytime you go on, the server will automatically assign you a unique address, and nobody else.
     

Share This Page