iPad Youtube Buffering...

Discussion in 'iPad' started by Cyroceon, Apr 20, 2010.

  1. macrumors 6502


    Feb 9, 2008
    Is it me or are you guys also noticing how UNGODLY slow it is to load a video on Youtube? It feels like FOREVER to load a video on youtube, and it seems to be on the iPad only. However, I was able to replicate the problem ONCE on my MacBook, but the internet in general is blazingly fast. Could it be Youtube?
  2. macrumors 68000


    Aug 6, 2008
    San Antonio, TX
    YouTube loads slower on my iPhone than on my other computers. Do you see it in just the YouTube app or on the YouTube site as well?
  3. macrumors 68040


    Mar 11, 2009
    Some people, including myself have this issue. I'm not sure what it is, but it also happens on my iPhone on WiFi. You'll find a lot of posts I think if you searched for YouTube WiFi problems or something.
  4. macrumors 6502


    Jun 15, 2009
    Y E S... And it drives me crazy. It is related to the iPad for me. Mac and iPhone are ok. My guess is that the YouTube iPad app defaults to the highest quality video.
  5. macrumors 68000


    Jan 19, 2010
    North Hollywood, CA
    I have that too, but only on hi Rez videos. The crappy quality ones load quick. But I have the same effect on my iPod.

    I think you're right.
  6. macrumors 6502

    Nov 23, 2007
    Happens to me all the time, I wonder if it si something to do with HTML 5 because when it's happening on my iPad I can load the same videos up on my net book or desktop (only they are the flash versions) and everything works fine everything else being the same. I use to think it was lack of ram but it seems to do it even after a full reboot so I doubt it.
  7. macrumors 6502


    Jul 9, 2009
    My Youtube app is slow, but the site loads videos just fine. It's annoying.
  8. macrumors 6502

    Jun 4, 2009
    Las Vegas
    I have been testing the HTML5 beta YouTube on my MBP and it is really slow. Not a huge fan of it and have been trying to disable it for now.

    Edit: After comparing the HTML5 and non HTML5 versions on my comp the speed difference is actually pretty negligble.
  9. macrumors 6502

    Mar 21, 2010
    Yup, it's definitely slow, even on a very fast wifi network.

    The same videos load fine on my other computers on the network.
  10. macrumors newbie


    Apr 15, 2010
    have you guys known how to convert youbube video to MKV? or directly find MKV from youtube?:confused:
  11. macrumors newbie

    Apr 13, 2010
    Same problem here. Websites load fast and everything is great. Only Youtube vids both on the Youtube app and youtube through safari are extremely slow. :mad:
  12. macrumors newbie

    Mar 17, 2010
    Well, this morning on my Windows PC, youtube was a pain. Very slow to load and the search feature was unavailable.
    So, based on that, my guess is it's a youtube problem and not an ipad problem.
    Someday soon I'll get to try it on MY ipad...if I can get my hands on one ha!
  13. macrumors newbie

    Apr 20, 2010
    I played around with this for an hour tonight and i believe this is a software issue in the ipad. Specifically having to do with the way the ipad is buffering the streams from youtube and itunes.

    I tested this watching three different versions of the avatar trailer on youtube. Of all of them satlled after about ten seconds of video. Peering further, i noticed that the activity light on the access point in my living room was blinking as in heavy nonstop activity. It kept blinking even while the video was stalled out. This particular access point repeats to the access point in the office via wds. All of my home access points are running ddwrt on the linksys wrt 54g platform.

    I looked at the router in the office which is the head end, and the activity light was going non stop as well, and a look at the activity on the status page indicated that indeed the data was coming in like a rocket.

    I had the same result using youtube and also trying to view the trailer on itunes.

    Now contrast this behavior to the behavior of the ipad while running the abc player app. I started the latest episode of lost in abcplayer. This runs flawlessly. The video starts after about 6 seconds, and does not stutter or stall, ever.

    While the video was playing, i noticed that the activity light on the access point would only blink activity in bursts. This bursts would last 2-4 seconds and in between for 2-4 seconds there would be no acitivity. I confirmed this on the status page on the internet connected ap, the data transfer was coming in small bursts rather than constant non stop.

    While i am disappointed in the performance of the ipad, it leaves me hope that it is simply a software fix and not a hardware problem or worse simply not enough ram and a major design flaw.

    I hope apple gets it fixed soon. The youtube thing and especially itunes is really annoying.
  14. macrumors 6502


    Jun 15, 2009
    I am running html5 beta on YouTube via the Mac, and it is very slightly faster for me. I think it might be the app itself now as well. Should be very fixable.
  15. macrumors 68000


    Jul 27, 2003
    YouTube is always ungodly slow for me - Mac, PC, iPhone, iPad. Whatever internet connection.

    I blame YouTube.
  16. macrumors regular

    Mar 27, 2008
    yes i notice it buffers a lot too. pretty annoying :mad:
  17. macrumors regular

    Mar 27, 2008
    sorry for double post. mod: please remove this
  18. macrumors 603

    Nov 25, 2009
    So you are saying that YouTube is terrible on all computers and all internet connections. I am not sure many people will agree with you.
  19. macrumors 6502

    Sep 7, 2003
    That's my guess too.
  20. macrumors newbie

    May 3, 2010
    West Hollywood
    Just wanted to let you know that I tried with 2 different provider and router. It worked great with one and very bad/slow with the other one. I Madeleine a little video on youtube so you can how it is when it doesn't work for me...

  21. macrumors newbie

    May 3, 2010
    Registered just to complain about this!

    I love the iPad...I really do! YouTube videos are obscenely slow, though. I even visited the Genius Bar today. Of course, on Speedtest, my home connection was 1.26 Mbps, and YouTube is just as everyone describes..slow, freezes, never able to play more than 10sec @ a time. At the apple store, YouTube acted perfectly (slight freeze once, but the apple guy just shrugged it off as a buffering hiccup). Speedtest there showed 8+ Mbps, of course. So the guy chalked it up to my slow Internet speed. Sigh.

    The problem though, is that with the SAME home connection, I have no prob. Watching Youtube on my Mac mini OR my old pc laptop. I really hope they fix it soon....if anyone has a temporary fix, I'd love to hear it!
  22. macrumors newbie

    May 3, 2010
    West Hollywood
    At home, I havé optimal fibre and n wifi. So like at The Apple store, I have 8+ mbps.... But it freeze! But it works fine with my old unbundled ADSL that I still have for a few days...
    I beleive it is a question of router.
    I also hope that Apple will come with an update...
  23. thread starter macrumors 6502


    Feb 9, 2008
    I think YouTube knows about this. The problem that iPads are having is that they attempt to load HD video, unlike iPhones, and the YouTube app is not set up to buffer well with certain connections. I know that I still receive this problem sometimes, but for the most part they fixed something. Just hang in there, they should be fixing this stuff soon.
  24. macrumors newbie

    May 3, 2010
    West Hollywood
    Hi guys,
    I may have found a solution. I changed my provider DNS by statics DNS from opendns.com
    Don't need to pay. Just register for a free account. I am not even sure you need an account...
    Here are the DNS : and

    Tell me if it works for you!!!
  25. macrumors member

    Jun 15, 2006
    Blackpool, England
    Yep, just to confirm the above post changing the DNS settings worked for me!

    YouTube vids now load fine :)

Share This Page