iPhone 3G does not charge but seemingly recognizes plug-in cord

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TOTC, Jun 21, 2011.

  1. macrumors newbie

    Jun 21, 2011
    Hi, all. Apologies if this has been covered elsewhere, but I dug through the back threads and didn't see a similar problem.

    OK, so I replaced the battery in my 3G. Phone works great -- but when I plug in the USB cord, it doesn't seem to want to charge.

    I turn the phone off, take the cord out, then wait a few seconds. When I plug the cord back in, the phone turns back on (i.e., silver Apple logo).

    Any thoughts as to what is going on here?
  2. macrumors newbie

    Jun 21, 2011
    im having the same problem and i know its not the power cord for usb or wall outlet or car charger cause i have another iphone and it picks up as soon as i plug it in so im stumped just like you. i want to fix this since this iphone is one that i jailbroke
  3. thread starter macrumors newbie

    Jun 21, 2011
    Did you replace the battery recently?
  4. macrumors newbie

    Jun 26, 2011
    Same Issue

    I am faced with the same issue. It happened before i replaced the battery, the phone stopped taking a charge and eventually it completely died. I live on an island and there are no apple stores near me so I decided to do a battery replace. Everything went great, phone booted up with 40% power. Nothing I try can get it to charge, but when the phone is off and i plug in the cable the phone does "Wake-up". Any suggestions?

Share This Page