iphone 3G GPS not working?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by philgilder, Jul 11, 2008.

  1. macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK
    #1
    is gps working for people?
    mine isnt... and its not just gps, triangulation isnt working either, even though its on in settings

    i have a (otherwise) fully working iphone 3g on o2

    EDIT: im gonna use this thread
    please close/delete
     
  2. macrumors newbie

    Joined:
    Jul 12, 2008
    #2
    Did you find a solution? Mine isnt working either.. though my partners works just fine.. he got the 8GB and I got the 16GB.. Im searching now and found a reset might fix this? Though mixed results..
     
  3. macrumors newbie

    Joined:
    Jul 12, 2008
    #3
  4. macrumors 6502

    nimda0

    Joined:
    Jul 17, 2008
    Location:
    D-town!
    #4
    Doesn't work, you were apparently a special case.

    Here's how you fix it:

    - Go to settings, general, auto-lock, change it from 1 Minute to NEVER
    - Go to settings, general, reset, reset network settings (THIS WILL REBOOT YOUR IPHONE)
    - Go outside, in a clear place with NO tree's, buildings, or anything blocking your view of the sky
    - Open "MAPS", click NO on all that wi-fi crap, then click the little gps icon, and let it sync up with the satellites (this could take a few minutes)

    It will work.... unless you don't do something right. You do not need to sync up with itunes or restore in itunes first.

    Let me know if it works or not, i just tried it on my girlfriends phone and it worked great after that. Also, a few other people with the same issue reported success as well.

    SEND ME A PM if you have questions though, as I may or may not be checking this thread.
     
  5. macrumors newbie

    Joined:
    Feb 5, 2009
    #5
    Your a legend man, worked perfectly I taught I messed up my phone but it works now and found my location very accurately.

    So cheers man
     
  6. macrumors newbie

    Joined:
    Apr 25, 2009
    #6
    Thanks: works like a gem!

    Q: Would resetting the auto lock bring the problem back at some point?

    Troubles
     
  7. macrumors member

    Joined:
    Jul 12, 2008
    Location:
    Fairfax, VA
    #7
    This worked for me too. Thanks so much for posting this!

    Tom
     
  8. macrumors newbie

    Joined:
    Jun 20, 2009
    #8
    Thank You!

    I just have to say thanks again! Now the GPS is darn near exact!
     
  9. macrumors 6502

    nimda0

    Joined:
    Jul 17, 2008
    Location:
    D-town!
    #9
    You're all welcome, i'm glad i could help. ;)
     
  10. macrumors regular

    Joined:
    Jun 3, 2007
    #10
    Anybody have an answer to this question?
     
  11. macrumors regular

    Joined:
    Jul 9, 2007
    #11
    Seems to be fine if you reset auto lock. Not sure why it needed to be set to never to begin with ....
     
  12. macrumors member

    Joined:
    Jul 12, 2008
    Location:
    Fairfax, VA
    #12
    Well, it only ended up working again for about 10 minutes. After that it stopped and performing the same steps didn't fix it. I've tried periodically since then and I have managed to get it to come on for 5 -10 minutes at a time before going out again. When it goes out, it won't come back on again for some time.

    I'm assuming that my GPS chip is susceptible to overheating and am going to try to get it replaced under warranty.

    I am curious, though, if anyone has any idea what the network settings have to do with the GPS and why resetting them fixes some GPS issues.

    Tom
     
  13. macrumors newbie

    Joined:
    Jul 19, 2009
    #13
    My GPS usually starts out incorrect then "finds" itself within a few minutes. I tried the fix but did not work for me. Any other ideas besides throwing it against a wall?
     
  14. macrumors member

    Joined:
    Jul 12, 2008
    Location:
    Fairfax, VA
    #14
    If it's still under warranty, they'll replace it. I got a replacement under warranty for this problem.

    Tom
     
  15. macrumors newbie

    Joined:
    Aug 5, 2009
    #15
    I got my iphone just before July 4th, GPS was working fine. August 2nd was the last time my GPS worked inside or outside. I use GPS MotionX alot when mountain biking through trails and that app along with anything else that tried to use my location will not work... I may have to get a replacement, or try a restore first. :confused: Annoying
     
  16. macrumors newbie

    Joined:
    Sep 27, 2008
    #16
    For me, it was August 1st, the day after I updated to 3.0.1 !! Since no good GPS on my iPhone 3G and brand new iPhone 3GS. But I noticed something: if I'm on Edge (2G), GPS works fine, but if I turn on 3G, GPS fails. As I only have one SIM card (the 3GS is an upgrade), the GPS on the iPhone without card works fine, for the applications that don't need a network, like Navigon!

    I called Apple Care today and they told me that they are on the subject since 2 or 3 weeks now and an update will be published soon.
     
  17. macrumors member

    Joined:
    Sep 15, 2007
    #17
    :rolleyes:
    Don't know exactly what has happend, but now GPS became working accurate through 3.0.1 firmware. What I did? Well, I went back to the 3.0.0 and nothing, then came back to the 3.0.1 frustade and not working. I jailbreak as usually, and nothing. Later in the same day I went to a park, had opened the map.app and voilà, worked. Now, back to my apto, where it has not worked, the iphone get perfect accurate position. Don't know what has happebed, but now I'm sure my gps has not break
    :)
    :)
    :)
     
  18. macrumors newbie

    Joined:
    Aug 7, 2009
    #18
    not workign either

    mine is not working either. from what I can tell, they are not fixing it with 3.1. This leads me to believe that Apple is not addressing this so that people like most of us drop the $400 on an upgrade. This really makes me mad.
     
  19. macrumors member

    Joined:
    Sep 15, 2007
    #19
    Opps, forget it. Not working again...
    :mad::mad::mad:
     
  20. macrumors member

    Joined:
    Jun 4, 2007
    #20
    Add me to the list of users with GPS gone wonky.

    I have a 16G 3GS now. My 3G GPS worked just fine and when a few TBT apps were available, the ones I grabbed were Gokivo and AT&T Nav. Both gave very usable and reliable results and located me in seconds.

    Now on the 3GS, Maps doesn't locate me. AT&T Nav and Gokivo are now a waste of money since they can't grab the signal either. The solution I've found when the 3GS can't get a GPS signal is to restart the phone. That usually works - sometimes it doesn't - but even when it does it's only for a few minutes. Sometimes it's enough to get an initial location but then the app doesn't track me.

    The best failure for me so far was during a quick 100 mile trip to the west. I got off at my exit and had to stop at a light. While I was stopped, AT&T Nav showed that I was continuing to the left and driving down the road. My location on the phone was about a mile ahead of me by the time the light changed and I was actually moving. It never found or updated my true location. Worthless.

    Seeing that some people have exchanged their iPhones and even that did not remedy the problem is a little frustrating. I hope this is a software issue and not a hardware problem that will be fixed next year with the new "iPhone with Extreme GPS".

    Perhaps there is a GPS aware app that isn't releasing all its resources when it shuts off. Since iPhone doesn't include multi-finder :)D) and cannot run more than one app at a time, I guess the only software not releasing would have to be the iPhone OS.

    Why can't we have hardware that just does what it's supposed to do?
     
  21. macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #21
    There's a thread on here about calibrating your GPS. I'm on my iPhone right now so can't search easily to find it, but that might help.
     
  22. macrumors newbie

    Joined:
    Sep 27, 2009
    #22
    CONFIRMED GPS FIX
    (Only confirmed for people whose GPS randomly stopped working, but since it doesn't harm anything it's still worth a try for any other GPS problem. It's just a general cache refresh.)

    Q: So what's the problem?
    A: "locationd", the process that makes GPS work, isn't working correctly.

    Q: Why?
    A: It's Apple so who the hell knows why. One thing that's for sure however is that deleting the cache can fix the problem.

    Q: Tell me more.
    A: No restore required, not even a restart. It's a simple fix, you'll just need a jailbroken iPhone to do it. If you haven't jailbroken yet, you should consider. You'll need to be able to send commands to your iPhone, which can be done through SSH or through Terminal, which is an app that can be installed from Cydia.

    1. Go back to the home screen.
    2. Open Terminal or establish a SSH connection. Note that these commands are case sensitive (capitalization matters). If you're using Terminal, you need to log in as root to run these commands. To log in as root type 'su' and enter the root password 'alpine' when it asks.
    3. Type the following, it will terminate the locationd process (the process will restart next time your iPhone uses the GPS):
    killall -9 locationd
    If the above command says no matching processes found, that just means locationd isn't currently running and you can continue to the next step.
    4. Type the following, it will delete the GPS cache (don't worry about deleting the cache, it'll rebuild itself next time your iPhone uses the GPS):
    rm -rf /var/root/Library/Caches/locationd
    5. Open Maps, your GPS should be working now.

    So to reiterate the commands:

    killall -9 locationd
    rm -rf /var/root/Library/Caches/locationd
     
  23. macrumors 6502

    Joined:
    Oct 6, 2008
    Location:
    Dallas, TX
    #23
    Can anyone confirm this? I'm wearing at typing in a "killall" command into my phone...
     
  24. macrumors newbie

    Joined:
    Sep 27, 2009
    #24
    If you're weary let me set you at ease by giving you the manuals for these standard unix commands (if you don't trust my sources either, just Google the commands).

    http://www.unixprogram.com/cgi-bin/man.cgi?comd=killall
    killall -9
    killall terminates all processes that match the given name (kill is used when you have the ID of the process you want to terminate); the 9 option is a signal that ends the process immediately and cannot be ignored (compared to the default software kill signal which is equivalent to pressing the red button at the top of a window, which doesn't always work immediately and sometimes not at all). There will only ever be one process that matches the string "locationd" so this won't cause any
    problems. It's necessary to terminate the process first so that we can restart it.

    http://www.unixprogram.com/cgi-bin/man.cgi?comd=rm
    rm -rf
    rm deletes files; the r option allows it to delete directory trees too, and the f option keeps it from asking to if you're sure you want to delete the files.


    With root access to the iPhone I was able to precisely trigger and identify the problem (compared to people who try random fixes and have no way of knowing for sure if the problem was solved). After performing these two steps the problem was conclusively solved.

    Please post your results, I would like to know how well this works for everyone's GPS problems overall.
     
  25. macrumors newbie

    Joined:
    Sep 28, 2009
    #25

    Your method works perfectly! :)
    Thank you so much. I've been trying to fix this for so long. Cheers!
     

Share This Page