iphone 3g, no sound from speaker, headphone trick doesn't work.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by matthewlupulio, Oct 20, 2010.

  1. macrumors newbie

    Joined:
    Oct 20, 2010
    #1
    I have an iPhone 3g, running 4.0, jailbroken, unlocked, use on AT&T that I got from a friend. I've had it for about a month.
    The speaker doesn't work anymore, for anything - no sms sounds, ringtones, alarms, clicks, locks.
    The ringers on full volume, no volume limit, no sound check, no equalizer, its not switched to vibrate, none of that. I've tried cleaning out the jack with a qtip, and tried blowing into it, and tried putting headphones in and out of it at least 50 times. Doesn't work.
    The earpiece & headphones still works; the speaker just randomly stopped the other day. It was working all day, the last time i remember it working was when the ringtone went off for a call. Later that day there were no noises. I've restarted it a handful of times, and I just really don't want to restore it and re-do everything.
    Anyone know what's wrong with it?
     
  2. macrumors newbie

    Joined:
    Oct 21, 2010
    #2
    the same just happened to me and i tried all those tricks. finally i opened an app and made sure the sound volume was up, because the app volume is separate from phone volume apparently. after 3 different apps i found that one had volume was turned to the minimum so i increased the volume. then all the apps had sound again. good luck
     
  3. thread starter macrumors newbie

    Joined:
    Oct 20, 2010
  4. macrumors 6502a

    chargit

    Joined:
    Jan 17, 2010
    Location:
    Evansville, In
    #4
    if your talking about the loud speaker then all the tricks you tried will not have any effect. if your talking about the ear speaker then the proximity sensor could be bad. has your iPhone been wet or dropped? does it charge and sync? any reception issues? the loud speaker is connected to the charging port, antenna, and microphone. its called the dock connector. its a fairly easy fix if its bad. just find a local repair shop and they can fix it pretty quick. but you need to check all your settings. I have had people bring them to me alot and it was just turned off in one of the settings.
     
  5. thread starter macrumors newbie

    Joined:
    Oct 20, 2010
    #5
    its the loud speaker. it hasn't been wet or dropped. it charges/syncs/gets perfect reception. everything works fine except the loud speaker, and i've checked all the settings i don't know how many times.
     
  6. macrumors 6502a

    chargit

    Joined:
    Jan 17, 2010
    Location:
    Evansville, In
    #6
    try to take it to a local repair shop. they can double check all the settings for you and replace the dock connector if need be.
     
  7. Jyn
    macrumors newbie

    Joined:
    Dec 24, 2012
    #7
    Ok i got a lot of those idevices araive at my store and i fix it firt of all your device got to b jailbreak 2: download ifile from cydia 3: go to system 4: hit library 5: find lounch daemons 6: luck for com.apple.iapd.plist and delete it 7: go back home and kill all the open apps 8:turn the phone off and turn it back on and walla done
     

Share This Page