iPHONE 3G Screen Flicker Problem

Discussion in 'Jailbreaks and iOS Hacks' started by mobileops, Jul 14, 2008.

  1. macrumors newbie

    Joined:
    Feb 2, 2008
    #1
    Does anyone notice that when they either push the home key or power button that the screen flickers a second before actually turning on? It only happens with the unit has been off for 10-15 seconds. Not immediately after turning it off and then turning it on. It's not actually lighting up when it happens, the backlight is off, but the entire screen sort of flashs without the backlight, and then turns on as usual. My wife's doesn't do it, but we noticed a similiar thing on both units when turning off, there's a little flicker following the backlight turning off, almost like there's some residual electricity in the screen discharging. However, not sure if its normal for my screen to be doing it on power up, that's essentially what I'm getting.

    Thanks,
    JB
     
  2. macrumors member

    Joined:
    Jul 10, 2008
    #2
    haha yep same problem here. i didnt know if it was just how it was made or something wrong. havent bothered to complain about it. but atleast im not the only one thinking about it lol
     
  3. thread starter macrumors newbie

    Joined:
    Feb 2, 2008
    #3
    Do you think this mandates needing an exchange. I don't really care so much as long as it keeps working. Just want to make sure its not an all out defect.

    JB
     
  4. macrumors 68030

    Joined:
    Nov 18, 2006
    #4
    It's the screen cap feature! Search on it.
     
  5. macrumors member

    Joined:
    Jul 10, 2008
    #5
    i dont think ill return it cause of it, it seems to cause no harm, unless i find anohter big problem, ill probably throw that one in there to make it sound like my iphone is dying hah
     
  6. thread starter macrumors newbie

    Joined:
    Feb 2, 2008
    #6
    How do I turn it off so it doesn't happen?
     
  7. macrumors member

    Joined:
    Jul 10, 2008
    #7
    how does the "screen cap feature" affect the turning off of the screen and turning on?
     
  8. thread starter macrumors newbie

    Joined:
    Feb 2, 2008
    #8
    this isn't a screen capture thing. Its a power problem with the screen, or maybe not a problem. There's a screen flicker prior to the screen actually powering on. The screen essentially nonspecifically activates a lot of those pixels, without the backlight on, and then turns off, all prior to the backlight and screen powering on. It only happens for a split second prior to the phone powering on. And it only happens if the phone has been off for 10-15 seconds.

    JB
     
  9. macrumors 68030

    Joined:
    Nov 18, 2006
    #9
    What buttons are you pushing? And at the same time?
     
  10. thread starter macrumors newbie

    Joined:
    Feb 2, 2008
    #10
    Pushing either the home button OR the power button to turn the unit on. Happens with either.

    JB
     
  11. macrumors 6502

    nimda0

    Joined:
    Jul 17, 2008
    Location:
    D-town!
    #11
    I have the exact same issue. If the phone has been off for more than 30 seconds, it will flicker when you turn it back on... no matter how you do it.
     
  12. macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK
    #12
    this thread is NOT about taking screenshots by pressing home + power

    this is about when waking the phone from sleep, the screen appears to flash as you do it, then works fine

    my 2g and 3g both did it, both were fine. leave it, its not a problem
     
  13. macrumors 603

    scaredpoet

    Joined:
    Apr 6, 2007
    #13
    :rolleyes:

    Why would this mandate an exchange? I know of tons of devices whose screens flicker when the LCD first receives power. It's usually just a byproduct of the screen controller re-initializing itself, something it has to do after having been powered off for a while.

    If there are no dead of stuck pixels, and the screen looks fine when it's turned on and isn't flickering when fully booted up, then consider yourself lucky. A flicker on power-up isn't really anything to be concerned about. As it is, I know my iPhone rarely ever gets shut of, so this "defect" should rarely cause you any trouble.
     
  14. macrumors regular

    Joined:
    Oct 29, 2007
    #14
    My first 2G iPhone did this and my 3G also does it. It's pretty harmless.
     
  15. macrumors newbie

    Joined:
    Aug 27, 2009
    #15
    Sorry to bring up an old topic, but I've noticed my phone does this intermittently when it's just sitting on my desk with the screen locked. Every 10 minutes or so it does this "flicker". I've had an issue with my phone freezing before, and the apple guy said it might be an issue with the video card. Is this related? Is this a sign that the video card is getting worse?
     
  16. macrumors newbie

    ickybus

    Joined:
    Jan 23, 2008
    Location:
    Washington, DC
    #16
    Screen Flashes when phone is in standby

    I have noticed this same issue with my 16 GB iphone 3G. It's kind of annoying really. My biggest fear is that the battery will drian faster then normal if this continunes to happen. I have tried "resetting" my phone via the Restore Factory Settings button, but it still happens. Maybe I should get a new one.
     
  17. macrumors newbie

    Joined:
    Aug 27, 2009
    #17
    I had mine replaced under warranty because the screen was freezing (even though the phone kept working). I'm not sure if they would replace it just because of the screen flickering, but it wouldn't hurt to at least have it documented that you'd brought it in before.
     
  18. macrumors 65816

    Maverick1337

    Joined:
    Nov 4, 2008
    #18
    In regards to the screen flicker issue, does your guys' screen flicker a split second before you're about to get a text or a phone call?
     
  19. macrumors newbie

    ickybus

    Joined:
    Jan 23, 2008
    Location:
    Washington, DC
    #19
    It doesn't correspond with getting a call or text. My other theory was that it corresponded with something email related, either fetching or push. But after seeing the flash, I would have no new email. It may still have to do the fetch feature of email, but as it seems to happen every 5-10 minutes and my fetch settin is set to 15 min, I am doubtful that this is the cause. I am still gonna try to see if there is a correlation between the flash and fetching, so I set my fetch to Manual and will see what happens.
     

Share This Page