Iphone 3G thinks Headphones are connected

Discussion in 'iPhone' started by AMcBroom81, Sep 5, 2008.

  1. macrumors regular

    AMcBroom81

    Joined:
    Jul 8, 2008
    Location:
    Mt. Carmel, IL
    #1
    Ok, so for the past week and a half I have noticed that every once in a while when I go to watch something from my movies section, or youtube, or even just get a call. nothing , no sound, so I check to make sure that the volume is up and I see where it says volume but underneath it says (Headphones). Has anyone else had this problem? If so what can we do about it. I have done a complete restore, nothing has worked.

    Now remember this is not all the time, it is speratic. I also try to power cycle the phone, that didnt work. so I plugged in my head phones and pulled it out of the jack and it was fine. sound through the speaker.

    Any thought?:)
     

    Attached Files:

  2. TEG
    macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    You may have to restore the software (and maybe setup as a new iPhone). If that doesn't help, get it replaced.

    TEG
     
  3. macrumors 68020

    Willis

    Joined:
    Apr 23, 2006
    Location:
    What feels like the middle of nowhere
    #3
    this has happened to me once when I was listening to music and took the headphones out. I had to put them in again just to get sound back. I think its a software/firmware bug.
     
  4. thread starter macrumors regular

    AMcBroom81

    Joined:
    Jul 8, 2008
    Location:
    Mt. Carmel, IL
    #4
    I tried that, No go, I may have to make an appointment with the mac genious. I have had no problems and then all the sudden.....BAM in your face... you got an iPhone problem. Love my iphone but dont wanna have to pull out my headphones everytime. thanks for the reply
     
  5. thread starter macrumors regular

    AMcBroom81

    Joined:
    Jul 8, 2008
    Location:
    Mt. Carmel, IL
    #5
    You and I are not the only ones, I have the white 3g 16GB, my cousin has the Black 8GB and it has happened to him to but not as much as me.

    I like your avatar by the way. Love Invader Zim :D
     
  6. macrumors 6502a

    wgr73

    Joined:
    Oct 31, 2005
    Location:
    New Mexico
    #6
    This happened to my 1.1.3 2G. What I did was just plugin...ungplug...plugin...ungplug...plugin...ungplug...til it went away. Sometimes it would take 2-3 minutes before it worked. It has something to do with sensing the impedance of the headphones. I wish one would have the choice to pick headphones or speaker instead of the impedance sensor...but whatever. I hope you fix it. :cool:
     
  7. macrumors 65816

    Joined:
    Jun 17, 2008
    #7
    maybe spray in some air to clean it out and see if it fixes it. could be dirty inside
     
  8. macrumors member

    Joined:
    Jul 8, 2008
    #8
    happened to me too, once I plugged the headphones in again and took them out, problem was fixed
     
  9. macrumors G5

    ucfgrad93

    Joined:
    Aug 17, 2007
    Location:
    Colorado
    #9
    This happened to me too, once. I had to reset my phone in order to fix it.
     
  10. macrumors 6502

    Joined:
    Aug 16, 2007
    Location:
    NY
    #10
    That's the issue. I took my phone to the genius bar cuz my ear speaker wouldn't work, and the phone acted as it headphones were inserted. The problem was that there was dust/dirt in the headphone jack and he sprayed it with air and it fixed the issue.
     
  11. macrumors 65816

    aaquib

    Joined:
    Sep 11, 2007
    Location:
    Toronto, Canada
    #11
    This happened to a friend of mine and he had to restore it, and after that it worked fine. Lemme know what the Genius says. Have you tried cleaning the inside with some rubbing alcohol or air?
     
  12. macrumors 65816

    Joined:
    Jun 17, 2008
    #12
    rubbing alcohol= bad idea, if someone checks the phone if you have a problem itll show up as water damage and you wont get a new one.
     
  13. macrumors newbie

    Joined:
    Jun 30, 2008
    #13
    Happened to me as well
     
  14. thread starter macrumors regular

    AMcBroom81

    Joined:
    Jul 8, 2008
    Location:
    Mt. Carmel, IL
    #14
    yeah I thought the same thing no alcohol, will turn water mark red. I did spray air in the headphone jack for about one minute. Bringing the little straw attached in and out of the jack. Still I get the message. I am going to take it to the apple store and see what they say.

    I will keep you all informed
     
  15. macrumors 6502a

    mlemonds

    Joined:
    Apr 9, 2008
    Location:
    Lexington, KY
    #15
    happened on my last iphone as well as my 3G iphone,

    on the old one all it took was slapping the headphones in and out.

    the 3G wouldnt work until i did a hard reset.
     
  16. macrumors 6502

    senorFunkyPants

    Joined:
    Jan 6, 2008
    Location:
    England
    #16
    Usually its just the little sensor in the headphone jack (that is set when headphone are inserted) getting stuck...it happened a couple of times to me...I put the merest trace of vaseline on the headphone jack and rotated it a few times and its been fine ever since.
     
  17. macrumors 6502

    Joined:
    Nov 19, 2007
    Location:
    Los Angeles, CA
    #17
    Had the problem on my phone, and the genius bar guy just plugged in headphones, made sure it worked, then SLOWLY unplugged them. Worked like a charm.
     
  18. thread starter macrumors regular

    AMcBroom81

    Joined:
    Jul 8, 2008
    Location:
    Mt. Carmel, IL
    #18
    I have tried this and still did not help at the tiime, I had to turn my phone off and leave it off for like 10 min. and then on again and worked just long enough for me to make a 5 min phone call. when I got off the phone I started listening to my music without headphones. then it started again and thought the headphones were attached. I have an appointment with the mac bar on Sat. I will post what they say.
     
  19. macrumors 6502a

    ryanwarsaw

    Joined:
    Apr 7, 2007
    #19
    If it does it again I would take a picture of it showing it with no phones plugged in and the message.Load the pic onto your phone. That way you are backed up if the genius can't duplicate the problem, at least he can't deny it and send you home with nothing.
     
  20. thread starter macrumors regular

    AMcBroom81

    Joined:
    Jul 8, 2008
    Location:
    Mt. Carmel, IL
    #20
    good thinking, I will do this. and I will also post that picture on here as well.
     
  21. macrumors regular

    Joined:
    May 21, 2008
    Location:
    Chicago, IL
    #21
    i used to to get this all the time - there is pocket lint or something in the headphone jack (probably compressed down by the headphones themselves) get some canned air with the little straw and blow it in there to clear it up - that's all the genius is going to do

    edit - I just read another post of yours and it is possibly a software issue - i would still try the canned air
     
  22. macrumors 6502a

    Joined:
    Sep 17, 2007
    Location:
    UK+US
    #22
    This has happened to me several times as well. Very strange. Plug/unplug the headphones - that sorted it out for me.

    Is that a portmanteau of sporadic and erratic?!
     
  23. thread starter macrumors regular

    AMcBroom81

    Joined:
    Jul 8, 2008
    Location:
    Mt. Carmel, IL
    #23
    hahaha I just caught that,

    I know... I suck
     
  24. macrumors 6502a

    Joined:
    Oct 5, 2007
    Location:
    Liverpool, UK
    #24
    Same issue. Did that and was temporarily fixed... made another genius appointment and told them it was a intermittent problem and they replaced it out of good will.
     
  25. thread starter macrumors regular

    AMcBroom81

    Joined:
    Jul 8, 2008
    Location:
    Mt. Carmel, IL
    #25
    ok went to the apple store today. he looked it over, blew air into it, checked for water damage, still had the problem, left with a brand new refurbished phone, so far no problems. it does have slight light leak, wont be a problem unless dust starts getting under my phone screen.
     

Share This Page