iPhone 3GS "Charging is not supported with this accessory" error charging

Discussion in 'iPhone' started by rezanaghibi, Jul 25, 2011.

  1. macrumors newbie

    Jul 25, 2011

    For a few months now I have not been able to charge my iPhone the way I normally could. Instead of simply plugging it in and recharging, nowadays when i plug it in either it charges only partially while displaying an alert that reads "Charging is not supported with this accessory." Other times there is no error message and the phone charges just fine but this is become more and more rare.

    i have tried restoring the phone, deleting apps, holding the lock and home button to restart the phone, and I've tried different types of chargers, different plugs, extension cords, power bars, computers - i even tried plugging the usb into my PS3.

    several of the solutions i've seen after googling this simply help to alleviate the pop up message "Charging is not supported..." and not the charging issue itself.

    you see the phone doesn't charge like it normally would. a full night hooked up to the charger, and then a short hour after and the phone reads "10% remaining."

    I still am using the same charger that came with the phone, the little iphone/ipod/ipad style usb charger.

    a guy at iRepair.ca here in the mall I work at said it could be because I've plugged the charger into a 3rd party car charger while on the road.

    either way, the phone is not charging properly. it either charges fully and doesn't display any message, or displays the message and doesn't charge properly.

  2. macrumors 65816

    Rajani Isa

    Jun 8, 2010
    Even with the Apple cable?

    Anyway, I seem to recall a similar issue with an iPhone-compatible Logitech product being fixed by, while connected, turning the phone off then back on to reset it.

    Could be mistaken though.
  3. macrumors 68000


    Nov 11, 2010
    Carnegie and Ontario
    Sounds like a 30-pin connector problem. I would schedule a Genius appointment at your nearest Apple store.
  4. macrumors 6502

    Feb 8, 2010

    I had to plug it in and out about 5 times before it would start charging, and it was through the apple main adapter and apple cable (all official), but the plastic cover were the cable connected to the 30-pin connector had broken away, so i changed to a new cable and it hasn't happened since :)
  5. macrumors P6


    Jun 19, 2009
    Where bunnies are welcome.
    Sounds like a dock connector issue. Have you got any water damage? Is the port dirty? You might try wiping it with a small brush. Otherwise, it probably needs to be replaced, but that may not be all that is wrong with it.
  6. thread starter macrumors newbie

    Jul 25, 2011
    i've tried different cables with varying results, but mainly the same issue occurs - the error message, and then slow charging that only goes up to about 1/3 charge maybe 1/2 when im lucky... seems to be getting worse as time goes on.

    apple store cant do anything since im passed warranty.

    air dusted before, it helped but wasnt a for-sure thing as it didnt help straight away but only after air dusted and restarted and then restored the phone.

    i restored the phone and it helped for a bit but then it went back on the fritz. the standard cable issued with the iphone is the one i've been using. i have like 3 or 4 different cables, new and old, and they all have the same results. sometimes it works, sometimes it doesnt.

    it used to work when i tried unplugging and replugging a few times; it even used to help when i jiggled the cable, but not anymore.

  7. macrumors 65816

    Jul 12, 2010
    Sounds like you need a new battery, since when you get it to charge it doesnt charge the battery very much. 79 bucks at Apple store.

Share This Page