iPhone Iphone 3gs is getting into soft DFU mode upon Reboot

Discussion in 'Jailbreaks and iOS Hacks' started by nsharma11, May 15, 2013.

  1. macrumors newbie

    Joined:
    May 15, 2013
    #1
    Hi,

    Problem : Iphone is getting into soft DFU mode upon Reboot

    I have restored my iphone 3gs to ios 6.1.2, below are the steps I have followed

    1. Downloaded blobs for ios 6.1.2 from iFaith

    2. Downloaded ios 6.1.2

    3. Created custom firmware using Snowbreeze(iFaith Mode -> ios 6.1.2 + blobs)

    4. Restored iphone succesfully.


    but whenever my iphone gets reboot it stucks into soft DFU mode.

    Please help!!

    I have been struggling from last 2months.. its annoying :(
     
  2. macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #2
    If you downloaded your shsh from cydia than they are broke,they don't have tss server data, that's why you get soft dfu, cause you have I tethered downgrade which means everytime you reboot, you will have to "boot tethered" with redsn0w. You can check your shsh files with ifaith if they are good.
     
  3. thread starter macrumors newbie

    Joined:
    May 15, 2013
    #3
    I had downloaded the blobs for ios 6.1.2 from iFaith only
     
  4. macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #4
    Yes, and ifaith downloaded them from cydia servers. Try to make an ipsw with ifaith and when you select the shsh file, if they are broke, it should shoe a message like " the appticket expired" " or "... is not available" , something like that.
     
  5. macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #5
    Make sure you have the latest version of iFaith
     
  6. thread starter macrumors newbie

    Joined:
    May 15, 2013
    #6
    I have craeted a custom firmware and when I am trying to restore with iTunes getting 1600/1601 error..Please help
     
  7. macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
  8. macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #8
    The blobs must be valid. Assuming they were valid, you need to put the device into pwned dfu mode before you can shift + click restore a custom firmware
     
  9. thread starter macrumors newbie

    Joined:
    May 15, 2013
    #9
    I ahve verfied blobs from redsn0w and they are valid.

    But When I restore it fro iTunes evertime it goes in soft DFU Mode.

    Even I have tried for ios 6.1 also, getting the same issue.
     
  10. macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #10
    You have to use the latest version of ifaith to verify it. Redsn0w hasn't been updated to properly check if the SHSH is complete or not

    Cydia --> TSS center is the other alternative to check if the SHSH is complete or not (you must already be jailbroken to use this method)
     
  11. thread starter macrumors newbie

    Joined:
    May 15, 2013
    #11
    Thanks for your response.

    I have checked in cydia, I can see blobs for 5.1, 5.1.1 and after that only for 6.1.3

    from 6.0 to 6.1.2 blobs are not there in cydia.

    is there any way I can get it, if so then how?
     
  12. macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #12
    There isn't any way to get blobs that isn't being signed. The exception is for A4 devices (3GS/4) but you need to be on that current firmware

    Looks like your options are either untethered jailbreak on 5.1.1 or tethered jailbreak on 6.1.3

    Edit: really unsure whether this method works or not but you can give it a try if you would like: http://forums.macrumors.com/showthread.php?t=1568340
     
  13. thread starter macrumors newbie

    Joined:
    May 15, 2013
    #13
    Thanks for your response.

    I have downgraded my iphone 3GS to 5.1.1 with unthether jailbreak.

    but I am facing an issue in this also, when I connect to my mobile internet my phone gets reboot by itself.

    Do you have any idea about it.
     

Share This Page