iPhone 3GS restore error (-1)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by amalprasad, Nov 29, 2012.

  1. macrumors newbie

    Nov 29, 2012
    My iPhone3gs was working fine with ios 5.1.1. After I upgraded to 6.0.1 it frequently going restore mode.2-3 times I sucessfully restored it but now this time seems no luck with me.I tried with DFU mode and restore with itunes.I will show the progress bar completing to 100%.But after waiting for 30-40 seconds a message pop up with error code (-1).Anybody can help me?I have no shsh blobs with me.How can I make cusom shsh blobs in restore mode.Now battery is also getting empty as red ring screen is always there.Can I make my iphone usable?I am going to be sick with this error code -1.Is there any use with redsnow?
  2. macrumors regular

    Oct 9, 2010
    Moreira - Maia - Porto - Portugal - Europe
    I got that error too, but then I tryed Redsn0w to do the restore and it worked!!!
  3. macrumors regular

    Sep 27, 2012
    If your iphone was jailbroken on 5.1.1 your shsh blobs are saved .. Use tiny umbrella to get the shsh blobs and see YouTube videos on how to downgrade
  4. macrumors regular

    Oct 9, 2010
    Moreira - Maia - Porto - Portugal - Europe
    You can also use Redsn0w to get remote SHSH Blobs with no worries. Don't even have to use TinyUmbrella.
  5. thread starter macrumors newbie

    Nov 29, 2012
    Yes I was able to create a ShSh Blob with redsnow.But no other use with redsnow.In select IPSW option when I select 5.0.1 IPSW (which I downloaded ) a message comes "That IPSW not supported by this version of Redsnow". Restore option also ended up with an error.
    Is there any difference with DFU and pwned DFU?I am confused with this.

    I am not able to use Tiny umbrella in my system because unable to start TSS server error.(Unable to stop PID4)

    I think the battery is empty now because I see red ring on screenalways after charging for sometime it will change to apple logo and usb+itunes screen but only for a little time.Then again to red ring battery screen.

    I am no more like iphone and planning to throw away this and go for an android phone.
  6. macrumors regular

    Oct 9, 2010
    Moreira - Maia - Porto - Portugal - Europe
    Some questions here:

    1. How old is your battery? Because if it is older than 2 years, your description seems to me that it can be a faulty battery... and that's also an issue!

    2. Have you tried to use "Recovery Fix" in RedSn0w? It can also be in a recovery loop! Does TinyUmbrella detect correctly you iPhone (with it's name one the left panel) or just a crazy number?

    3. Have you safely turned off your phone? And do you know how to enter next in DFU mode?

    4. About TinyUmbrella and TSS.... Have you killed the process with that PID? Use windows "task manager" to see what process has that PID and kill it (probably you'll have to show PID column in the process list). Example: you cannot have Teamviewer running when using TSS Server...
  7. thread starter macrumors newbie

    Nov 29, 2012
    Today when I tried a restore with itunes, restore completed successfully.I thought it is done.But iphone not restarting and showing empty battery screen.

    Luis for ur questions:

    1.I think battery is older than 2 years,but it was working fine until last restore.I bought this from ebay may be they give me a crap!

    2. I have to try recovey fix after this.When I tried yesterday it was not working.

    3.Slide to swith off option not coming as it was in recovery mode.I used to enter DFU mode as follows. Redsnow recognizing this as pwnedDFU mode.
    1.Connect your device to your computer.
    2.Make sure iTunes is running and all necessary drivers are installed. During the following process ignore any messages from iTunes. There is no need to click on any messages that might appear.
    3.Do a reset by pressing and holding both home and power buttons for several seconds.
    4.As soon as it resets (screen goes black), immediately release both buttons.
    5.Immediately press and hold the power button again.
    6.Wait until you see the Apple logo plus one second longer.
    7.Now press additionally the home button (still don't let go of the power button).
    8.Wait until the screen disappears (gets black) plus one second longer.
    9.Now release the power button, but keep pressing the home button.
    10.Wait until you hear a "connected" sound from iTunes.
    11.You should now be in DFU mode and your screen should be black. If you see the USB logo instead, try again.

    4 Unable to kill PID4 as it is a system process pls see the attached picture.

    Thank you ver much Luis for your supports.
  8. macrumors regular

    Aug 11, 2010
    Glasgow, Scotland
    Your original fault (-1) indicates a hardware fault. If your still having problems the phone may need serviced.

    Good luck.
  9. thread starter macrumors newbie

    Nov 29, 2012
    Hi Thanks all
    iphone is ok now after 1 weeks of my desparate tries.My umpteenth try to restore with itunes worked.After keeping sometime for charging it automatically restarted and then i did setup it as new iphone.Before when it went to restore mode two times after ios 6.0.1 updation, i took back up from icloud.I had so many application installed on it and I dont want to take the risk of any faulty application cause any malfunction.

    there was a problem with my USB charger.I have to adjust it to a particular position in my laptops USB port then only it is charging.Otherwise it will show "charging is not supported with this accessory".But im sure restore error was not caused by USB cable problem because I also tried with another cable of my friend which is working properly.

    Now my battery is full and green color.What a relief.

    I dont know if apple has done any updation regarding this error -1.
    This time there was a message from itunes that there is a new version available but i didn't update it.I hope iphone will stay like this forever with out any further restore mode.

    Now I will make sure to take a IPSW and shsh blob backup,and I will appreciate if somebody can give me a better advice on that.
  10. macrumors regular

    Oct 9, 2010
    Moreira - Maia - Porto - Portugal - Europe

    I was going to say that you had a faulty battery, a faulty USB cable or a faulty DOCK contector assembly!

    Remember that the batteries bought on eBay are really crap (I am on my 5th battery now!!!!!). They just break from one moment to another!

    About SHSH blobs, just use Tiny Umbrella to save them! It's all automatic.
  11. thread starter macrumors newbie

    Nov 29, 2012
    I even had no time to back up it again lost wifi and cellular connetion and again a message came to restore.What the hell is this?:eek:
  12. macrumors regular

    Oct 9, 2010
    Moreira - Maia - Porto - Portugal - Europe
    It is asking you to restore again?

    Have you installed Cydia yet with redsn0w? (using just the jailbreak option)
  13. thread starter macrumors newbie

    Nov 29, 2012
    not yet jail broken and not installed cydia.Should I try that?

Share This Page