Iphone 3gs won't connect to wifi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cdalephantom, Aug 21, 2012.

  1. macrumors newbie

    Joined:
    Aug 21, 2012
    #1
    I just got a new, faster modem from the cable company. In the process everything I have connects to wifi except the 3gs. I have my lap top, an iphone 4gs and an Ipod touch, which is older than my 3gs and all connect fine with the exception of the 3gs. I have called the cable company and apple support and no one has an answer as to why the 3gs won't connect. I have tried everything and it is very frustrating. Any comments or solutions are appreciated.
     
  2. macrumors 6502a

    RodThePlod

    Joined:
    Sep 7, 2005
    Location:
    London
    #2
    • Does the 3GS actually see your new network if you go into Settings, Wi-Fi?
    • Is the 3GS able to connect to any other Wi-Fi networks? (Starbucks, friend's network, etc.)
    • If you go into Settings, Wi-Fi, Other, what happens when you type in the network name/password exactly as it is in the equivalent screen on your 4S?

    Lastly, remember that the 3GS cannot see the 5GHz wireless band that some of the faster routers come with today, whereas some of your newer kit (such as the 4S) will be able to. If your wireless band is set to 5GHz in the router, you'll need to drop it down to something like 2.4GHz.

    Hope this helps,

    RTP.
     
  3. thread starter macrumors newbie

    Joined:
    Aug 21, 2012
    #3
    The 3gs sees the new network. It can connect to my neighbor's network. i haven't tried going into Other yet. I am trying to attach a photo of my 4gs, 3gs and my ipod. When I go to the IP address page of each device, it appears that they are all connected to the network. The other device that I have connected is my laptop and its IP address is 192.168.0.4. So it appears that the network has recognized them all sequentially. All of the iphones and ipod looks the same except that the 4gs and ipod have a check by them and the 3gs has a revolving circle showing it is trying to connect. Hope I have explained the problem. Thanks, RodThePlod for your tips.
     

    Attached Files:

  4. macrumors 6502a

    RodThePlod

    Joined:
    Sep 7, 2005
    Location:
    London
    #4
    No problem.

    To me the problem sounds like it may be down to the wireless band as I mentioned in my previous post. I had a similar issue when Virgin Media (my ISP here in the UK) supplied me with their new SuperHub earlier in the year.

    The SuperHub has the ability to use the 5GHz band and so I configured it with that option thinking the faster the better - but then my son had the same problem you are describing with his 3GS, while other devices could connect without issue.

    When I dropped the band back to 2.4Ghz in the SuperHub, he was then able to connect and everything was fine and dandy :)

    RTP.
     
  5. thread starter macrumors newbie

    Joined:
    Aug 21, 2012
    #5
    RodThePod, another thought. While the 4gs and Ipod connect the 3gs will not. The Ipod is much older than the 3gs. You would think that the older Ipod should have the same symptoms as the 3gs.
     
  6. thread starter macrumors newbie

    Joined:
    Aug 21, 2012
    #6
    Went into my settings for the modem/router and 2.4ghz was already selected.
     
  7. macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #7
    On the iphone, go into Settings>General>Reset>Reset Network Settings. Reconnect to your wifi.

    It might just be hung up on some old settings if they network name and password wasn't changed when you changed the modem.
     
  8. thread starter macrumors newbie

    Joined:
    Aug 21, 2012
    #8
    Thanks for the feedback, killerrobot. I've tried the reset several times and have had no luck. Still looking for a cure.
     
  9. macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #9
    It's weird it can connect to other networks but not yours...

    Look in the router settings and make sure the MAC address for the iphone 3gs isn't being blocked (it would be extremely odd if it were though...)
    Also check and make sure there isn't a limited number of devices (IP addresses) that can used at the same time.
    Turn off everything (including the modem for longer than 30 seconds). Restart the modem, then turn on the 3gs first and see if it gets assigned another IP and can connect.
     
  10. thread starter macrumors newbie

    Joined:
    Aug 21, 2012
    #10
    Thanks again, killerrobot for suggestions. Tried all that you suggested. No luck. Actually originally the 3GS was the third device I tried to connect. The network assigned an IP address with a last character of 3 to my 4GS phone, a 4 to my laptop, a 5 to my 3GS and a 6 to my Ipod touch.
    What is even stranger, after a minute or so of trying to connect the 3GS to the network, the signal indicator changes from a 3G phone indicator to a wireless indicator. When I go to the details of the connection (IP address,etc), it shows all of the information as if it is connected but when I try to use the internet, it says I am not connected. I posted an earlier photo of all three devices (3GS, 4GS & Ipod) and the information indicates they are all connected but the 3GS is not. Just doesn't make any sense. No help from Apple.
     
  11. macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #11
    Bummer... some other ideas:

    1) Make sure your wireless security is WPA2 with AES encryption
    2) If you can, select all frequencies possible by selecting 802.11b/g/n (2.4GHz and 5GHz)
    3) Make a back up of the 3gs in iTunes (just in case) then go to Settings>General>Reset>Reset All Settings

    If none of those work, then hopefully someone else can throw out some more ideas.
     
  12. thread starter macrumors newbie

    Joined:
    Aug 21, 2012
    #12
    My security is WPA2-PSK with AES encryption. My frequency is 802.11 n (2.4GHz). I then tried the reset again but no luck. Thanks again kellerrobot for your help. I haven't given up yet and will keep looking and trying anything that might work.
     
  13. macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #13
    There's the problem - the 3gs is only b/g compatible. I think all iPods from as far back from 2009 were n compatible so that probably explains why it can connect. See if you can the frequency to b/g/n or just b/g and see if it connects then.
     
  14. thread starter macrumors newbie

    Joined:
    Aug 21, 2012
    #14
    When I go into my "laptop" for the wireless network connections, I can get to the "configure" button for the connection. I then get to the "Property" and "Value" drop downs. I can't seem to make it accept any changes. There are several options for 802.11 n. Under "Property", there are a couple of choices that let me select 802.11 b or g. One is "Ad Hoc Channel" and the other is "Wireless Mode". Under each one of these, I can select a "value" of 802.11 b or g but when I click "OK", the selections do not seem to be accepted. Should I call my cable provider back and see if they can explain how to activate these changes? Thanks again, killerrobot. I don't understand how to make the changes stick for the connection.
     
  15. macrumors 68020

    killerrobot

    Joined:
    Jun 7, 2007
    Location:
    127.0.0.1
    #15
    When you say "laptop" do you mean the system settings for the computer?

    The frequency needs to be changed on the admin side of the router by opening up a browser and going to 192.168.0.1 (try admin or 1234 for the password)

    What brand of router do you have? You might be able to find a walk-through online, and if not then call your cable company again to ask them how to do so.
     
  16. thread starter macrumors newbie

    Joined:
    Aug 21, 2012
    #16
    I'm not sure I understand how to complete the process through the browser. I think I will give my cable company another call and see if they can walk me through it. I have much more information now given your help and suggestions. Thanks again. I'll let you know how it goes.
     
  17. macrumors member

    Joined:
    Mar 22, 2012
    #17
    Reboot your iPhone for one time then try to add network manually…
     
  18. thread starter macrumors newbie

    Joined:
    Aug 21, 2012
    #18
    Well, killerrobot, called the cable company and they say I am connected with 802.11 b/g/n. Their only suggestion was to exchange for a new modem and see if that helps. I will probably do just that. They say they have had other problems reported with the Iphone 3GS. Thanks again for your help.

    ----------

    Thanks for the suggestion, ryanlawrence171. I have tried the manual method a couple times with no luck.
     
  19. macrumors newbie

    Joined:
    Sep 13, 2012
    #19
    Help - Did you solve this...?

    I am experiencing essentially the same issue; just got a new Comcast modem/router "Gateway"; set up was easy (I am an IT professional), all devices work fine...except, the family has three iPhone 3GSs; mine will not get to the internet, although it is pretending to be connected to the WiFi (iPhone displays correct network information, but no internet from the phone, and the router admin page does not show my phone as a connected device...
    Did you find a solution? Any help at all, anything i can do before i have to take to gateway back to Comcast for a new one (assuming that will even help)
     
  20. macrumors newbie

    Joined:
    Sep 13, 2012
    #20
    It might just be hung up on some old settings if they network name and password wasn't changed when you changed the modem.[​IMG]
     
  21. pleasehelp2012, Nov 24, 2012
    Last edited: Nov 25, 2012

    macrumors newbie

    Joined:
    Nov 24, 2012
    #21
    Another Iphone 3 won't connect to wifi

    Hello. My Iphone 3 has also suddenly stopped connecting to my Belkin N router/modem after years of trouble free use. One minute I was talking on Viber and surfing the internet on the Iphone. and the next minute the wifi had stopped. So the wifi doesn't work on the Iphone now.
    An ipad, ipod, mac computer, Iphone 4 and Samsung galaxy phone all successfully connect to the Belkin N.
    I have:
    Turned the Belkin N router/modem off & back on.
    Reset the Belkin N router by sticking a pin in the little hole,
    Rung Belkin to check the router/modem settings, and they advise they are OK. They said it is the phone's fault not the Belkin router fault

    Turned the Iphone off and back on.
    Reset the Iphone.
    Reset the Iphone network settings.
    Restored the Iphone.
    Checked the Belkin N settings suggested in the advice above, and they are
    802.11 b/g/n
    Belkin is set at WEP 64 security, which is what the Belkin customer service guy said to leave it at.
    Reset the MAC address.
    Tried 20mghs and 20/40 mghs (made no difference)

    Any help you could provide would be VERY APPRECIATED. It seems such a waste (and expensive) to have to buy a new phone.
     

Share This Page