iPhone 4 acting really weird...

Discussion in 'iPhone' started by medi.freak, Feb 7, 2012.

  1. macrumors regular

    Joined:
    May 26, 2011
    #1
    Lately my iPhone 4 has been acting strange. When I press the 'on' button (the one at the top;)) the iPhone sometimes does't react, and when I press it again it only flashes the unlock screen and goes back to black. Then, when I press it again everything is normal. Sometimes it doesn't do the black screen, but something else that is unusual is that the flash that comes on the 'unlock' word looks like it is fast forwarded at first and the goes back to being normal (I don't know how to explain this one). Also, when I unlock it (after I typed my pin) it has a black screen only for a short period of time (like half a second) and then it is normal again. That stuff all usually happens when the phone has been in "sleep" mode for a certain period of time. So when it behaved like this it won't do it again unless I let it "sleep" for like 15 or 20 minutes.
    I did do a reset yesterday and it is still exactly the same as it was before. It is already a phone that I got from the Apple Store as an exchange for a phone that had problems with the Home Button. What do you guys think I should do? Go to the Apple Store because of it? I just bought Apple Care for the phone, so it is under warranty.....Do you think it is a software issue? It seems like one to me, but with a software issue you don't get a new phone, as a replacement right? Any other ideas except for resetting it? Thanks for he help!
     
  2. macrumors demi-god

    DerekRod

    Joined:
    Jan 18, 2012
    Location:
    NY
    #2
    If its under warranty go right to a genius PROBLEM solved haha
     
  3. thread starter macrumors regular

    Joined:
    May 26, 2011
    #3
    do you think it is something that will be gone with a new phone. Meaning: Would replacing it actually help, or is it something with the software (Apps, or similar). Because otherwise I'm quite happy with the phone =) (No actually NEED to replace it. There is just that annoyance factor...) What would you do?
     
  4. Guest

    Alaerian

    Joined:
    Jan 6, 2005
    Location:
    A barstool, Innis & Gunn in hand
  5. thread starter macrumors regular

    Joined:
    May 26, 2011
    #5
    I do that sometimes. And need people to tell me exactly that =) Thanks Alaerian :)
     
  6. macrumors 604

    cynics

    Joined:
    Jan 8, 2012
    #6
    Mine 4s has done something similar. I think it lags a little so pressing power you no reaction so you press it again. Now the screen lights up for the first press then back off for the second.

    I've also had the slider not slide yesterday. Like it would start to move but slow down, almost like it was programmed to **** with me. Lol

    Both events have only happened 3-4 times together.
     
  7. Guest

    Alaerian

    Joined:
    Jan 6, 2005
    Location:
    A barstool, Innis & Gunn in hand
    #7
    Just bookmark that post. Then it's there whenever you need it. ;)
     
  8. macrumors regular

    Joined:
    Jul 13, 2010
    Location:
    Texas
    #8
    Mine has done the same thing! When it won't respond as I try to slide it, putting it to sleep & waking it up again fixes it. It's weird and new to iOS 5.
     
  9. macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #9
    Do you have it in a case? The symptoms are similar to when I had an Otterbox silicone case stretch out and interfere with the proximity sensor.
     
  10. macrumors 6502a

    Joined:
    Jun 24, 2010
    #10
    Try pressing the home button instead the "on" button.
     
  11. macrumors regular

    Joined:
    Jul 8, 2010
    #11
    iPhone 4 here and mine does this very frequently and its not in any kind of case, and I use the on/off button to check the time when pulling it out my pocket as its the top of the phone comes out first.

    Sometimes i press the on/off button to wake the screen and it just stays black and does nothing until I press it, i've tested it as it happens frequently and can be 20secs + until i press it again and i get the screen flash on and off then I have to press it again for it to function.

    I've also had the slider not sliding and also the phone not vibrating when toggling the silent switch (that one only fixes itself after the phone is switched on and off).


    All of these issues have been apparent since iOS5.

    It seems like the phone is slowing down with every update too and I have plenty free space, restored the phone, reset the phone, uninstalled apps, reinstalled apps, just seems to be software related.

    Oh and my home button is showing signs of malfunction as it sometimes doesn't function when pressed and I have seen myself having to press it a few times just for it to work, other times it works perfect.
     
  12. Tinhat, Jan 18, 2013
    Last edited: Jan 18, 2013

    macrumors newbie

    Joined:
    Jan 18, 2013
    #12
    Hi - I have this exact problem too with the random wake lag and black screenshot on iPhone 4 16gb, ios 5.0.1. Did anyone work out a fix?
     

Share This Page