iPhone 4: Data network connection not working

Discussion in 'iPhone Tips, Help and Troubleshooting' started by h.s, Sep 10, 2010.

  1. h.s
    macrumors newbie

    Oct 27, 2008
    Hi everybody,

    I'm experiencing a strange problem with my (otherwise lovely) new iPhone 4:

    The connection to my carrier's data network is not working. The phone shows the "E" or the "3G" sign, respectively, but if I open e.g. Safari, the "Cannot open page, no connection to the internet" window pops up. Same with Maps, Cydia etc.

    The carrier's service team confirmed to me that the data plan is correctly booked and they can even see that I connect to the network. The guy said, however, that each connection produces only tiny traffic, obviously no "real" connection. He said that he saw this for the first time and strongly suspects that the problem is on my side.

    APN, user name and password are definitely correct; SBSettings confirms that I got an IP address to the data network. WiFi, phone, GPS etc. work all fine.

    This is very, very strange. Anybody got an idea? I am officially flabbergasted and out of ideas.

    My setup:
    • iPhone 4 16 GB factory unlocked from UK
    • Using it in Germany, carrier Simyo
    • iOS 4.0.1, jailbroken

    It's almost as if my traffic is pointing to a dead proxy or something. If somebody could direct me which setting and/or logging files to check via SSH, that might a big help!

    Right now I have neither access to a different iPhone or an adaptor tray to check my SIM card with a different phone (no different Micro SIM at hands, either).

    Thanks for your help... iPhone without data connection is only half the fun :-/

Share This Page