*Iphone 4 led flash not working*

Discussion in 'iPhone Tips, Help and Troubleshooting' started by hotnts, Jun 24, 2010.

  1. macrumors member

    Joined:
    Mar 26, 2009
    #1
    I started my day at the palisades center apple store at around 6:30. I was about the 200th person in line and probably the last person to buy the iphone 4 before they ran out. Now to the meat, I was checking out my phone noticing how snappy it was from my old 3g(VERY FAST BTW). I popped up the camera and used it a sec and popped the flash on and it worked wonderfully. I get home and begin the backup process of my 3g one last time then and while i am waiting i decide i will take some videos, well i start without flash then i go to switch it on and no flash. I called apple about this and they told me to restore as a new phone then restore from backup; I guess my question is has anybody else had this happen to them? I don't have any yellow or signal droppage BTW:confused:
     
  2. thread starter macrumors member

    Joined:
    Mar 26, 2009
    #2
    I called applecare last night and they decided it is a hardware issue. Apple is overnighting me a new phone and should get it today or monday at the latest. He wanted to charge me the $29 fee but i told him that is not really fair and he agreed, so it was waived. FYI it was not dropped, left in the sun, dropped in the toilet or get rain on it for that matter.:D
     
  3. thread starter macrumors member

    Joined:
    Mar 26, 2009
  4. macrumors newbie

    Joined:
    Jun 25, 2010
    #4
    Yes I am having this problem too. Am about to restore and see if it solves the problem.

    Aggrivating
     
  5. macrumors 6502a

    Joined:
    May 9, 2010
    Location:
    Amsterdam, NL
    #5
    My iPhone 4 has not got a working camera at all.

    The animation of the shutter just won't open. . I freakin' hate this.
     
  6. macrumors newbie

    Joined:
    Jun 24, 2010
    #6
    did that work? I'm having the same problem...LED flash won't work :(
     

Share This Page