iPhone 4 not sending or recieving any cellular data

Discussion in 'iPhone Tips, Help and Troubleshooting' started by guitardave62000, Jul 20, 2010.

  1. macrumors member

    Joined:
    Oct 2, 2008
    #1
    Hi,
    I've been experiencing a problem all morning with my iPhone 4. I am on 4.0.1 software and my phone shows that I have 4 or 5 bars contantly and has 3G service. However it will not let me send or recieve any texts, any calls or check my email. An error message never pops up either for the email it just keeps saying connecting. I have turned my phone off multiple times and I still continue to have this error.

    Could this be a hardware or software issue?

    Any help is greatly appreciated
     
  2. macrumors Nehalem

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Reset your network settings.
    If still nothing then call up AT&T to see if everything is ok on their end and maybe try a restore.
     
  3. thread starter macrumors member

    Joined:
    Oct 2, 2008
    #3
    I've tried reseting the network settings. It worked for about 2 minutes and now its back to the same problem again.

    I set up an appointment with apple but is it just an AT&T problem?
     
  4. macrumors Nehalem

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    You should try a restore and setup as new first before cause it might be a simple solution than wasting time at the Apple store getting it exchanged.
     
  5. macrumors 6502

    Joined:
    Dec 15, 2005
    Location:
    NJ
    #5
    This may not help since you reset your network settings, but yesterday my iPhone 4 was doing the same thing, wouldn't make calls, no texts, no data in or out whatsoever. Resets weren't doing anything.. I took the sim card out and put it back in and everything started working again. If that doesn't work, I have no idea what will hah.
     
  6. thread starter macrumors member

    Joined:
    Oct 2, 2008
    #6
    Well I did do a restore but it still wasn't acting properly so I took it into the apple store. I saved a few pictures to the phone I had taken throughout the day showing my issue. He ran a few tests including the speed test app and it turned out my download speed was over 1000 kb less then his. Because of that they decided that it was hardware and replaced my phone and now it seems great. So if you had this error too you may want to take it in.

    I appreciate your suggestions and help
     
  7. macrumors Nehalem

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Nice, glad it worked out.
     
  8. thread starter macrumors member

    Joined:
    Oct 2, 2008
    #8
    So turns out today I have the SAME exact issue with the new one haha. Leads me to believe it could be the sim card now
     
  9. macrumors 6502

    Joined:
    Dec 15, 2005
    Location:
    NJ
    #9
    Time to go to AT&T and get a new sim card haha
     
  10. thread starter macrumors member

    Joined:
    Oct 2, 2008
    #10
    I got a new SIM card last night. Everything seems to be ok, hopefully it stays this way
     
  11. macrumors regular

    Joined:
    Feb 20, 2010
    #11
    This same problem is happening to my phone and my wife's phone. We are in Rhode Island. I actually got a new sim for my wife's phone. It did not help. Switch to just edge and it works fine. Turn on 3G and no internet access. when at&t opens i'll call them or hopefully it will just be fixed when I wake up.
     
  12. macrumors 65816

    Joined:
    May 13, 2007
    Location:
    Orlando, FL
    #12
    Having similar issues, except I can receive/send texts and make calls.. just no internet.

    wtf...
     
  13. macrumors regular

    Joined:
    Feb 20, 2010
    #13
    UPDATE: so around 11:00 i was still experiencing the problem. Called apple support. Normal run around things to do. While I was on the phone with him I said hold on let me check my email and low and behold it was working, as well as any other internet program. I think my wife's is working also.

    If it stops working again, i will be deleting everything and setting up as a new phone.
     

Share This Page