iPhone 4 pictures in messages not showing

Discussion in 'iPhone Tips, Help and Troubleshooting' started by PYT1986, Oct 27, 2010.

  1. macrumors newbie

    Joined:
    Jul 30, 2010
    #1
    I have just gone through some messages in my iPhone 4 and I have noticed that where there used to be pictures or 'mms' there is now a little blue circle with an arrow on it, I click this and it is a black screen with no picture.

    I can understand if pictures that I have sent in messages from my camera roll might not show up after being deleted, but everything sent to me by other people is now gone as well, it just shows a black screen.

    Any idea what has caused this and how to fix it???
     
  2. thread starter macrumors newbie

    Joined:
    Jul 30, 2010
    #2
    Any ideas??? Still haven't been able to fix this...
     
  3. macrumors Nehalem

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    Was those pics/mms messages there from previous firmware builts that you restore or updated from backup?
    Seems like a bug with itunes or the backup file.
     
  4. macrumors newbie

    Joined:
    Jan 19, 2011
    #4
    Same Problem

    I was just wondering if you ever got help with this. I am having the same issue.
     
  5. macrumors newbie

    Joined:
    Feb 16, 2011
    #5
    Same problem here

    All iphone 4 mms pics from some senders, not all senders, have vanished and all that is left is small icon blue background, white >. Surely some clever person out there can solve this problem!!!
     

    Attached Files:

  6. macrumors 6502

    jozeppy26

    Joined:
    Jul 8, 2008
    Location:
    St. Louis
    #6
    This has happened to me in the past as well. Is your iPhone jailbroken? Did you restore from an iTunes backup or (if you are jailbroken) did you restore the file located at /var/root/Library/SMS/sms.db? From what I gather, this .db file does not contain the images, rather calls the images that are stored in a different location at /private/var/mobile/Library/SMS/Parts/*. The pictures in your sms conversation aren't in the Parts folder for some reason.
     
  7. macrumors newbie

    Joined:
    Feb 16, 2011
    #7
    SMS pictures vanish...

    iphone 4, not jailbroken. This happened with iphone updated with latest from itunes. All on the up and up. All pics from one sender vanished, even those sent up to a couple of weeks ago. Other sender's pics are still there.

    Where are these pics stored? At AT&T???? On my iphone?
     
  8. macrumors member

    Joined:
    Nov 10, 2008
    #8
    They are stored on your iPhone in the location above. You will have to jailbreak it to get them from there.

    This happens to everyone who restores a backup from a jailbroken phone. Setting the entire SMS folders permissions to 777 fixed it for me. I have no idea why it happened to you on a non-jailbroken phone. But the problem is that the SMS.app doesn't have tge permission to read the pics. But they're on there, don't worry.
     
  9. macrumors newbie

    Joined:
    Apr 6, 2011
    #9
    Any update?

    I'm having the same problem. It looks like this is a fairly rare occurrence. There arent many posts online about it. The last 2 images that were sent (from another iPhone, using take photo or video option) to me from a contact have disappeared. They now just show up as a "smushed" blue circle with the white arrow icon. When you click that, it just goes to a black screen. It hasn't happened to any other images from any other contacts.

    I have an iPhone 4, iOS 4.3, not jailbroken.

    Where are these images?
    Can I retrieve these images?
    How?
    What would cause this?

    Thanks
     
  10. macrumors member

    Joined:
    Nov 10, 2008
    #10
    If your phone is not jailbroken and has not been jailbroken and your backups have not been jailbroken, then you should contact Apple.

    If you were jailbroken, I would suggest getting the files from /var/mobile/library/SMS/
     
  11. macrumors newbie

    Joined:
    Apr 6, 2011
    #11
    If I've never jailbroken, can I still retrieve them from that location after I jailbreak?
     
  12. macrumors member

    Joined:
    Nov 10, 2008
    #12
    Yes. You should be able to as long as they haven't been deleted for some reason. And I see no reason why they would be.

    I'm a huge advocate for jailbreaking and think it should be illegal to have a non-jailbroken phone (slight joke) but since you haven't jailbroken and this is happening to you, I really recommend that you contact Apple and complain about it. Perhaps they can fix it in future versions.

    If no one complains, nothing gets fixed ;)
     
  13. macrumors newbie

    Joined:
    Feb 16, 2011
    #13
    Here we go again with this POS

    Disappearing again. NOT JAILBROKE!! Just a POS!:confused:
     

    Attached Files:

    • POS.jpg
      POS.jpg
      File size:
      104.3 KB
      Views:
      117
  14. macrumors newbie

    Joined:
    Apr 24, 2009
    #14
    Any luck figuring this out?
     
  15. 7thDirection, Aug 15, 2011
    Last edited: Aug 15, 2011

    macrumors newbie

    Joined:
    Aug 15, 2011
    #15
    I just had that happen on my phone.

    I have an iphone 4 with the most current build on it. My friend sent me a picture earlier this afternoon and I was able to view it full screen. She sent me another an hour or so later. I opened and viewed the picture in full screen, but I closed the text message 'app' window because I was busy doing something else. When I went to look at the photo again when I had time, I got the squished arrow buttons referenced before and when I click on them, a black, blank screen pops up.

    I tried rebooting my phone and looked at any message settings that might have been accidently switched on that would prevent me from seeing the images, but I can't find anything else that would cause this.

    The only other thing that I did was click on "Load Earlier Messages" for the affected text thread earlier today. I was looking for a previous text from a few days ago and went back too far loaded a picture from a few weeks ago. I didn't try to view that picture in full screen because I had already seen it, but it did display as a preview. Is it possible by loading the previous messages (with the old image), I somehow confused the phone and it corrupted the address of the new images? When I click on the squished blue link, it opens up a folder named after the text thread (my friend's name). It says there are only two images in the folder, but I clearly have seen at least three (the old image, the first image sent today and the second image sent today).

    Really weird.
     
  16. thread starter macrumors newbie

    Joined:
    Jul 30, 2010
    #16
    Well I am still having this problem and it continues to happen, even if the pics are ones I have taken and our stored on my phone. Really frustrating!

    My phone is not jailbroken...

    Perhaps I'll have a talk to the people in the Apple store??
     
  17. macrumors regular

    Joined:
    May 21, 2010
    #17
    I've had this issue with my 3G, 3GS, and 4. I'm currently jail broken on my 4. Where do I got again just to find the pics that are missing only from the text message conversations? And is there something I can do to make those blue arrow show the missing pics again?
     
  18. macrumors newbie

    Joined:
    Jan 13, 2012
    #18
  19. macrumors regular

    Joined:
    May 21, 2010
    #19
    Can I do it just with iphonebrowser alone? Can you do a step by step?
     
  20. macrumors member

    Joined:
    Nov 10, 2008
    #20
    That won't fix your problem. His problem was that he couldnt SEND MMS because it freaked out since it didn't have write permissions to save the photo.

    If your photos are not showing up, look in the subdirectories of /private/var/mobile/library/SMS. If they're not there, sorry, they're gone (as far as I know).

    If they're there, setting permissions to 777 recursively and the owner to mobile MAY make them show up in SMS.app.

    To do this, use WinSCP on Windows, CyberDuck on Mac or iFile on iPhone. Browse to that location and it's fairly easy to see how to change permissions by going to the properties of a file or folder.
     
  21. macrumors newbie

    Joined:
    Apr 1, 2012
    #21
    My problem is I can see the preview before the blue arrow, but when I try to see pic I get a BLACK SCREEN. Started to happen about 2 weeks ago. Every contact in my SMS that has media (pic or video) comes up BLACK SCREEN. On videos I can hear audio but I only get the BIG Q screen. I am totally lost here. I change the permissions in /private/var/mobile/library/SMS but that didn't change a thing. I really don't want to do a restore :eek:
     
  22. macrumors 6502a

    HickDead

    Joined:
    Dec 2, 2011
    Location:
    RESPECT MY AUTHORITAH
    #22
    http://forums.macrumors.com/showthread.php?t=1349328
     
  23. MiStArEdX, Apr 1, 2012
    Last edited: Apr 1, 2012

    macrumors newbie

    Joined:
    Apr 1, 2012
    #23
    Thanks for the quick response....will try what was stated in the thread :eek:
     
  24. macrumors newbie

    Joined:
    Sep 25, 2011
    #24
    Did anyone solve this? Anyone got any words på Apple about it?
    I've had this problem for some years now it sux. Tried google about it, posted threads etc. but still nothing.

    Did anyone try jailbreak and see if he or she could retreive the pics?
     
  25. macrumors newbie

    wattabing

    Joined:
    Mar 13, 2009
    Location:
    New Jersey
    #25
    So you seem to know what you are talking about, i just restored my iphone 6 with a iTunes backup of a jailbroken ios 8.1 from iphone 5s and restored it to iPhone 6+, but now my thumbnails in the photos app are not showing up, well they are just blank image holders, and when i click on them the pictures are there.. I also had this problem with the text messages and also camera pictures not saving, but i resolved those two issues by changing permissions on a few different folders, does anybody have any idea what folders the photos are stored in the ios firmware.. I have the icloud photo library (beta) on and upload to my photostream also on and i cloud photo sharing... But none of photos show the thumbnails EXCEPT for photos taken with the camera... THANKS oh fyi, i was ablke to see photos in my text messages again after following directions from this thread, it was a permissions problem... So i'm assuming this is too, just dont know where the folders are... I did change permissions on a few folders so far and it didnt work, i think they were called like photostreamdata, photodata, etc...


     

Share This Page