iPhone 4, Verizon, "Could not activate Cellular Data Network"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by iF34R, Aug 19, 2012.

  1. macrumors 6502a

    iF34R

    Joined:
    Jul 13, 2011
    Location:
    South Carolina
    #1
    Ugh..

    I had to switch back over to my iphone 4, on Verizon. So, I didn't have a wifi connection yet, so going to the app store, it pops up that there isn't any cellular data connection. Says, "Could not activate cellular data network". It shows the 3G icon at the top. I went to Settings > Network and Cellular Data is ON. I've never had that before.

    I've turned it on airplane mode for a few mins, then turned that off, still no go. I rebooted the phone, no go. I'm lost.
     
  2. macrumors 68040

    bruinsrme

    Joined:
    Oct 26, 2008
    #2
    I have this happen on my ipad with verizon service.
    I know the bars have nothing to do with the data signal however I will have 4 or 5 bars and still get that same message.
    perhaps it is timing issue of when the i device is expecting an authentication signal and its not receiving it within that window
     
  3. thread starter macrumors 6502a

    iF34R

    Joined:
    Jul 13, 2011
    Location:
    South Carolina
    #3
    Ended up going through a decent amount of troubleshooting.

    I turned on/off airplane mode.
    Turned off data service, turned back on.
    Reset Network settings
    Soft reset
    hard reset

    at the end, I did a complete wipe. Ok, so I have the phone JB, and forgot to NOT erase all settings and content.

    Well, so the phone turns off, goes into restart, and the circular "busy" icon turns and turns for about ten minutes. I went ahead and held power + home button until the phone restarts. Apple logo comes on screen, and within a few mins the phone has restarted. All icons, etc., are there like there wasn't any content erased. Also, it gave me the activation message. A couple mins later, everything is working 100% again.
     

Share This Page