iPhone 4 youtube too slow on wifi at home

Discussion in 'iPhone Tips, Help and Troubleshooting' started by bluer101, Jul 6, 2010.

  1. macrumors regular

    Jun 22, 2010
    I have a weird problem with my wifes and my iPhone 4's with youtube over wifi. They are really slow to load and always pauses. Now my son's iTouch 2g and our old iPhones 2g work fine over wifi, starts after a few second and plays all the way through. I have no clue whats going on. Now surfing in safari and videos from apps like flixer and news apps the videos are very fast, scary fast. A
  2. macrumors newbie

    Jul 6, 2010
    Me too...

    I'm having the same issue on my iP4.
  3. macrumors newbie

    Jul 6, 2010
    I'm having the same issue on my iPhone 4 and on my iPad 3g... I do not have the issue on my older gen iPhones (3G, 3GS) or my 2nd Gen iPod Touch...

    I believe the issue is that in the iPad and iPhone 4 the youtube app is going to youtube and getting the highest quality version of a video available (likely 720p on many videos and 1080p is coming I believe)... the older iPhones and iPod Touches would simply get the lowest version (usually 360p or whatever). I believe the reason the new devices grab the highest quality version is due to the fact that they have super high res displays (1024x768 and 960x640) compared to the low res of the older devices (480x320). I think that the youtube app is not optimized for streaming the full high res "youtube hq" videos as compared to the lower reset normal youtube videos.

    I went to a friends house who has Verizon FIOS and had a lot less of an issue with the streaming than at my house with a 10mbps cable modem (still def fast enough to stream HQ youtube on my iMac, MacBook Pro, etc)... so I think that if you have ridiculous bandwidth you will not see this problem... but unless you are over 20Mbps you will likely see issues. I think that it is an issue with the way the app streams the HQ content and they need to fix that in software because the iPad and iPhone 4 can stream other non-youtube high res stuff fine... and also as I said, my regular computers can stream the high bitrate stuff on my network without a hitch as well.

    Finally I would say that both devices also stream fine on the 3G network (although at reduced quality) because I believe they automatically "downshift" to the lower quality version when they are not on WiFi and "upshift" to the HQ version when they are on WiFi. I think a temp fix would be for Apple to add a switch in the settings of the app to allow the user to choose what quality to stream on WiFi and downgrade it to the 3G level.

    The longterm fix is for them to figure out why the devices cannot handle the HQ level streaming on a network that can clearly handle it and also be able to detect when a WiFi network cannot stream the full HQ version and automatically downshift while still on WiFi to the 3G quality.

    Thats all for now. Hope it helps and let me know if you get any more information on why this is happening and also if there are any known fixes... right now my only solution is to switch to 3G and watch reduced quality there... and then have to deal with AT&Ts 2GB per month cap... really screwing us on that one... now double since thats the only way you can watch YouTube anymore on the devices...
  4. thread starter macrumors regular

    Jun 22, 2010

    I was thinking the same thing with the higher quality settings. I have had mine connected to the apple store in the mall and its loads much faster than at home. I have and 8mb connection here at home.
  5. macrumors newbie

    Jul 6, 2010
    apple def needs to fix this... you shouldnt need a 20+mbps connection to watch youtube videos on a 3.5" screen
  6. thread starter macrumors regular

    Jun 22, 2010
    I just got through finding non HQ videos on my computer then view the same ones on the phone and they are fast like before. So this has to be the problem.
  7. macrumors newbie

    Jul 6, 2010
    thats a good test... i'll have to give it a try on my end as well
  8. macrumors newbie

    Jul 7, 2010
    Slickwatson and bluer101, Who are your ISP if you don't mind sharing?
  9. macrumors 68020


    Jun 29, 2004
    I've had the same issue on every iPhone (and iPad) I've ever owned. Youtube is unusable the majority of the time- loading often takes twice the play time.

    Gave up looking for a fix a while back after no one could solve it.
  10. thread starter macrumors regular

    Jun 22, 2010
    Mines AT&T.
  11. macrumors newbie

    Sep 15, 2008
    I also have a hard time watching YouTube videos through the iPhone app while using my iPhone 4. I believe I have always had problems though. The best solution I found was to use YouTube through Safari. Not only did I get it in High Quality through Safari, but it's way faster. The only problem I have is when I click a YouTube link, it always defaults to opening the app. Anyone know how to disable that?
  12. macrumors 601


    Oct 20, 2008
    I don't think you can. Only way is to copy and paste it into the safari address bar.
  13. macrumors 68000


    Jul 6, 2010
    Don't us the apple YouTube app use the mobile YouTube app it's ally quicker to load.


    Paste this link into safari address bar on your phone, once your in you will be prompted to save the page as an icon on your iPhone homescreen.

    Alot quicker and you can select Hq on or off on videos.
  14. macrumors 6502

    Jun 12, 2009
    For me this seems to be a combo of both youtube and my ISP. I have comcast 22mbps service and often time see speeds closer to 30mbps. For the last week however, I've been lucky to see this creep over 10mbps. This is on my laptop over wifi. The iPhone is usually slower over my wifi. With youtube, some HD videos will stream with no problems while others will stall and do nothing. Eventually they will start playing.
  15. macrumors 6502a


    Mar 1, 2007
    Winter Park, Florida
    YouTube is completely unwatchable for me on my iPhone. I tried the Mobile app as well and that did not work any better. 1st Gen iPhone worked flawlessly in this dept.

    I can understand the reasoning behind Apple wanting to grab the HD version of a video but atleast give us an option to select which quality we want to watch on the iPhone.
  16. macrumors newbie

    Jul 28, 2010
    I think I figured out the issue. I tried everything mentioned here and in the a discussion over at the apple discussion groups and nothing helped. What's the one thing everyone has in common? Wireless N. I switched my wireless router from B/G/N to B/G only and the problem went away. Looks like Apple needs to do a little work with the wireless N on these devices.
  17. macrumors member

    Mar 5, 2010
    I had the same problems a couple of days ago. I managed to solve the problem with changing the DNS to Google's.

    Settings> Wifi> Blue arrow on your wifi > Write in the DNS field >,

    And as you all know Google owns Youtube. And voila, faster loading then I've ever had on a iPhone before.

    Hope this fix is working out for you too guys :)
  18. macrumors regular

    Aug 23, 2010
    Hi. I have the same problem on ip4. Any fix on this? I'm sure there's a setting on YouTube to disable high video playing on iPhone.
  19. macrumors newbie

    Mar 26, 2003
    I've tried EVERY "solution" and nothing has worked. Thankfully I found this link which IS the only solution:


    On your iPhone
    Tap Settings
    Tap Wi-Fi on the left-hand side
    Tap the blue arrow next to your current Wi-Fi network
    Tap the “DNS” field and enter the following:,
    Exit Settings"

    I copied and pasted that from the Apple Support forum where I found it. The DNS settings above are from http://www.opendns.com which is a free DNS service that speeds everything up, especially Youtube. It went from unbearably slow, unreliable and intermittent to purring like a kitten and loads instantly every time now. Try it. It works. All the other stuff (changing encryption, changing/rerouting ports, turning off encryption, etc.) is all a waste of time.
  20. macrumors regular

    Aug 23, 2010

    thanks it kinder worked

Share This Page