iPhone 4S battery suddenly drains very fast

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Eddyish, Apr 12, 2012.

  1. macrumors member

    Joined:
    Feb 11, 2012
    Location:
    Hong Kong
    #1
    I noticed this happened on wednesday, my phone was in my pocket and it suddenly felt very hot and when I checked it I was surprised to see that battery life had somehow drained to 15% even though I had hardly used it except fro briefly checking my email and time (besides that it had just been sitting in my pocket). Prior to this, my battery life was pretty good and I usually had around 50%ish after a day of moderate usage. Currently it's been 5 hours after it's last charge and it's already down to 50%. I hardly used it today and it seems to drain incredibly quickly when not in use. Oddly I'm using it now to type this and it doesn't seem to drain as fast.

    I've updated to 5.0.1 and jailbroke it in January and it was fine so I don't think that's the reason why. And usually I don't turn on location services, I set the brightness at around half, don't turn on Bluetooth. I've tried recallibrating the battery to no avail. I did a hard reset once I noticed the phone felt hot and was at 15% on Wednesday but nothing seemed to come of it. The battery still drains very fast when not in use but doesn't get hot.
     
  2. macrumors newbie

    Joined:
    Feb 6, 2012
    #2
    you are moving too fast when you put it in you pocket?
     
  3. macrumors 6502a

    Joined:
    Apr 17, 2009
    Location:
    Norfolk, UK
    #3
    You should update to 5.1; battery life has been improved with the latest version.
     
  4. joegarlick, Apr 24, 2012
    Last edited: Apr 24, 2012

    macrumors newbie

    Joined:
    Apr 24, 2012
    #4
    I also have just started to have the same problem the last two days, it was doing nothing sitting on my desk at work. I came to work with 90% battery, put it on my desk, barely touched it and it was dead and hot when I left at the end of the day. This has happened two days in a row. I have installed nothing in the past two days and made no settings changes. I updated to 5.1 when it came out and no Jailbreakage either. I feel that either there is a severe software error sucking the battery dry or a hardware problem. :(
     
  5. blatopilot, Apr 24, 2012
    Last edited: Apr 24, 2012

    macrumors regular

    Joined:
    Sep 24, 2011
    #5
    Been having the same thing happen strangely. Along with constant AWDD logs concerning "wifiMetricIPV4DHCPlatency" at home. At work, I don't use the wifi so that disappears, but something seems to be trying to establish contact. Maybe there is a mothership overhead.

    I'm to the point where I just want all syncing to go away unless it is with a wire. Just a phone that works as a phone first, and happens to have other features.

    EDIT: I have had success turning off Cell Network Search and Compass Calibration under location services -> System Services. Cell Network being the most likely as it has been accessing my location....
     

Share This Page