iPhone 4s camera shutter won't open

Discussion in 'iPhone' started by mmmtastybusch, Mar 27, 2012.

  1. macrumors regular

    Joined:
    Oct 31, 2011
    #1
    Hey guys, I did a search for this and didn't find anything, I'm hoping someone can help me.

    I have the iPhone 4s on Verizon. I went to use my camera a couple weeks ago when this happened. I clicked the camera swap to use the front facing camera and when it switched, the shutter just stayed closed, and the camera app froze altogether. It wouldn't even let me switch back to the main camera. I tried closing the app manually, doing an Apple reset, and powered it off and on a couple times. Later that day I tried it again and it was suddenly working, however when I tried to swap to the front facing it did the same thing. Now it's been a week and the shutter still won't open either way.

    It will now only let me use the camera if I open the message app and do it as if I'm taking a picture to send to someone. Has anyone heard of this issue or know of a fix? I'm going to try doing a factory data reset tomorrow if no one knows of another way

    EDIT: I don't know if this will matter, but this happened shortly after downloading the Instagram app. I uninstalled it right after this happened last week and that didn't fix the problem.
     
  2. macrumors 68020

    Joined:
    Sep 30, 2003
    Location:
    Boston
    #2
    I think a restore is your best bet here, clearly the camera still works.
     
  3. thread starter macrumors regular

    Joined:
    Oct 31, 2011
    #3
    Well I went ahead and tried doing a restore default settings. The camera started working again, but when I tried the front facing camera it did the same thing. So I went ahead and updated to OS 5.1 (I've been putting it off because my pseudo widget for settings won't work with it) and it did the same thing. So I had to restore default settings again and just not touch the front facing camera button. After all that I'm wondering if wiping all the data will even fix it. I'll probably give it try anyway tomorrow, and if that doesn't work I get to drive an hour and a half to the closest Apple Store. Uggh lol
     
  4. macrumors newbie

    Joined:
    Apr 10, 2012
    #4
    I am having exactly the same problem with my iPhone, my little sister has been messing around with the front camera trying to take pictures of herself and now the camera shutter won't open. I don't know exactly what happened because she is denying all responsibility despite hundreds of pictures of her on my camera roll... anyway I could access the camera through my messages app once the main camera app was broken and use the camera that way until I tried to switch it to the front facing camera then the shutter wouldn't open and the camera has frozen there too. I have tried resetting the phone and nothing has changed, the shutter still doesn't open and the camera app freezes, and the second time I open the app after a restart or reset the screen is black but the app is still frozen. I would be interested to know what you did to fix the problem in the end, or whether you managed to fix it at all. I am very reluctant to go to the apple store and get a refurb to replace my iPhone, as mine is brand new!
     
  5. macrumors 68020

    macingman

    Joined:
    Jan 2, 2011
    #5
    When restoring did you restore from a backup after bringing it factory settings? Or set up as new? If you restore from a backup the problem would just come back on most likely.
     
  6. macrumors 6502a

    Joined:
    Jul 2, 2010
    #6
    hi guys, another shutter-problem here.... I made an appointment for Monday...guys, i dont want to get a refurb, is there anyway to make sure they give me a new one?
     
  7. macrumors member

    Uguubot

    Joined:
    Dec 16, 2010
    Location:
    Minnesota
    #7
    I thought I would chime in and say on occasion the "Shutter" On my iPhone has been stuck closed when launching the app. To solve it, I've had to close the app via the multitasking bar.
     
  8. macrumors 6502a

    Joined:
    Aug 30, 2011
    #8
    +1

    Found a low memory warning in the diagnostics page.

    Closed out all the Apps and the camera started working just fine.
     

Share This Page