iPhone 4S - Sending texts as emails?

Discussion in 'iOS 5 and earlier' started by jnick, Oct 18, 2011.

  1. macrumors member

    Joined:
    Jan 22, 2008
    Location:
    NY
    #1
    So in my adventures of setting up iMessage, I set my Caller ID to my email so it would sync with my iPad. However, now it would appear if I send a text message to someone NOT on iOS 5, they get the text but it sends it as an email, so they also receive an email from Verizon in their inbox.

    Anyone else having this problem? Any way to stop this from happening?
     
  2. macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #2
    Do you have this person's cellphone # in your contacts? I think if there's no phone number in your contacts, it'll send it as email.
     
  3. thread starter macrumors member

    Joined:
    Jan 22, 2008
    Location:
    NY
    #3
    This persons cell phone number was in my contacts labelled as iPhone.

    ----------

    The full fledged process was I sent an iMessage, it failed, so I hit "Send as Text Message" and they got it in their email.
     
  4. macrumors 6502a

    Joined:
    Jul 10, 2008
    Location:
    Italy, near Venice
    #4
    Try to turn off MMS. My guess is that it will solve the issue.
     
  5. thread starter macrumors member

    Joined:
    Jan 22, 2008
    Location:
    NY
    #5
    Why would I do that? Then I can no longer send MMS messages to people...?
     
  6. daftpunkstu, Oct 18, 2011
    Last edited: Oct 18, 2011

    macrumors member

    Joined:
    Oct 17, 2011
    Location:
    Edinburgh
    #6
    just try it to see if that's the issue? mine sent it as emails if i didnt have the contact's phone number [​IMG]. when you type their name in to search, it usually brings up (for me an imessage contact, a phone number and then an email)
     
  7. macrumors 6502a

    Joined:
    Jul 10, 2008
    Location:
    Italy, near Venice
    #7
    I've replied to at least two hundred emails these days for issues of iOS5 with MMS with two of my apps.

    MMS allows to send texts to emails (not sure if this is true in all countries), my guess is that for recipients that are not on iOS5, MMS takes over instead of regular SMS and this causes the issue you had.
     
  8. macrumors regular

    Joined:
    Nov 17, 2010
    #8
    vettori - Exactly the same issue here....

    Senario being:

    I have had iOS 5 for a few days now and been texting other people with iOS5 with no issues (send button blue, continuing our conversations seamlessly since before iOS 5 update)

    My brother downloaded and installed iOS5 last night. I sent him a text today which sent as a text (send button still green, thought nothing of it though) he replied, also showing as an old fashioned text on my phone.

    Then I realised that this shouldnt be happening, both send buttons should be blue?

    Then just now, his send button shows as blue, so he sent a message and it arrived on my phone as from his email address????

    Can anyone explain whats gone wrong here?

    Thanks

    James
     
  9. thread starter macrumors member

    Joined:
    Jan 22, 2008
    Location:
    NY
    #9
    My point is, if I turn off MMS then wouldn't I no longer be able to send picture/video messages?
     
  10. macrumors 6502a

    Joined:
    Jul 10, 2008
    Location:
    Italy, near Venice
    #10
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Yes it's true. But I'm not saying to leave it off, I'm saying just try it for a message to see if it solves the problem.
    I'm sure Apple will look into this problem very soon.
     
  11. macrumors 6502a

    Joined:
    Jul 10, 2008
    Location:
    Italy, near Venice
    #11
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    How did your brother set the iMessage account ? Email or phone number ?
     
  12. macrumors 68040

    tigres

    Joined:
    Aug 31, 2007
    Location:
    Land of the Free-Waiting for Term Limits
    #12
    OP.

    Check that the RECEIVING device w/iOS5 has iMessage ENABLED in settings. ;)
     
  13. macrumors 6502

    los318

    Joined:
    Jun 29, 2010
    Location:
    Belton, TX
    #13
    i had a strange issue today but cleared it up. I tried to text a buddy of mine who has a IP4 and Siri told me she couldn't find any phone to text and offered up his emails. He has iMessages so it worked but trying again gave me the same issue, no phone and offered up his emails.

    Then i went into contacts, pulled up his contact and pressed "Send message", it asked what i wanted to use out of a list, i chose his iphone and it brought up a new text screen. I closed it down and asked Siri to send a text to him again and this time and every time after it loaded right up to his Iphone.
     

Share This Page