Iphone 4s won't connect to WIFI

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Rcflex, Oct 14, 2011.

  1. macrumors member

    Rcflex

    Joined:
    Oct 10, 2011
    Location:
    Palm Springs, CA
    #1
    I see a signal on the phone and shows im connected to the wifi signal, though it won't download anything, just keeps saying loading... I have another iphone 3gs that works fine on it... Any help would be appreciated...

    Thanks
     
  2. macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    First and foremost, make sure the 4S and 3GS are on the same network. If they are, see what IP address you are getting on the 4S. To do so, go to Settings->Wi-Fi, then tap on the blue > symbol to the right of the network name. If the IP starts with 169.254, a.k.a. a self assigned IP, you are not actually joined to the network. Some newer routers may accept incorrect passwords and will show you are on the network when you are not. If you are getting a self-assigned IP, try renewing the lease. You should also try forgetting the network and rejoining. You can follow that up with resetting the network settings, and restarting the iPhone.
     
  3. macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #3
    I had a similar problem with my iPhone 4, out of the blue (pre-iOS 5 update). It was as if the network connection wouldn't "stick." Could select the network in the WiFi panel, showed all bars as a strong signal, but then when I'd try to actually go online, an error popped up saying I needed to connect to a WiFi network.

    Uhhh...yeah....already did that.

    I just noticed there was no wifi icon at the top of the screen either, even though there should have been. When returning to Settings > Wifi, it was turned on, but I to re-select the network again. And again. And again. No joy. Still wouldn't "stick."

    This morning, I did this and it worked:

    1. Settings > Wifi: Turn on like normal
    2. Click blue arrow to right of network name
    3. Click Renew Lease

    That did the trick for me. The wifi icon is back at the top of the screen again, showing full strength. Weird that it occurred, but glad to be back in business again. ;)
     

Share This Page