iPhone 4S won't delete ringtones I've added?

Discussion in 'iOS 5 and earlier' started by jman995x, Nov 2, 2011.

  1. macrumors regular

    Joined:
    Sep 8, 2007
    #1
    I recently converted 249 ringtones from .MP3 into .M4R format.
    I dropped them into iTunes and synched them with my iPhone 4S.
    Now, I want to take some of them off, but iTunes won't let me.
    I've unchecked the "Sync Ringtones" button and synched,...still on the phone.
    I've checked the "Selected Ringtones" box and systematically gone through and selected only some of the ringtones, then synched....still ALL on there.
    I restored the iPhone from backup to the day I got it (about 3 days ago) and that wiped the ringtones off the phone, but when I synched again (after changing some of the names of the ringtones in iTunes), it only synched about 225 (of the 249), and the names were the same as the original names (not the new names).
    I thought I'd try a little experiment...
    When I click on the "Ringtones" section under Library (in iTunes) all of the Ringtones show up there and they can be played.
    When I go under my iPhone (in Devices) and click on the "Ringtones" folder, all of the ringtones are there (with the NEW names?)...but they are all greyed out, cannot be played from there, and have a "refresh" symbol next to them (which doesn't do anything).
    So, I went back under the "Ringtones" tab at the top of iTunes, checked the "Selected Ringtones" box and only checked ONE ringtone,...then I synched....my phone has ALL of the original (old name) ringtones on it...however, when I go back to the "Ringtones" under my iPhone, it only shows the one NEW ringtone (but it is greyed out, unplayable in iTunes, and has the refresh symbol next to it).

    What is going on?

    Anybody have any ideas why iTunes will put ringtones on the iPhone 4S, but then won't let you take ANY of them OFF the iPhone (without doing a Restore)?

    Thanks,

    J.
     
  2. macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #2
    :eek:
     
  3. thread starter macrumors regular

    Joined:
    Sep 8, 2007
    #3
    Only took about 5-7 minutes (using Video Converter Pro)...set it to M4R format and sent it on its way...as each file was converted, it transferred it to iTunes...very little effort on my part.

    But still having problems with the syncing.
    Just realized it's a much bigger problem than just the Ringtones.
    Just unchecked all Music, Videos, Ringtones, etc (Total ~ 30GB)....then hit Sync.
    After the "Sync", iTunes shows nothing on my iPhone and ~57GB of free space.
    However, when you go into my iPhone, ALL of my Music, Videos, etc., etc. is still on there.

    I have no idea what the problem is.
     
  4. macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #4
    What I was :eek: at was the amount of ringtones you loaded onto your phone. And don't get me wrong, to each their own and I respect that, but what, if you would be so kind as to explain, could you possibly do with that many ringtones? Do you have a separate one for each contact in your address book? That would make sense, I suppose.

    Anyway, your issue sounds pretty strange and I don't have a solution to offer. Sorry I can't be of any help.
     
  5. macrumors newbie

    Joined:
    Nov 2, 2011
    #5
    I have the same issue but it's only been with two custom ringtones I added.
     
  6. macrumors 604

    ZBoater

    Joined:
    Jul 2, 2007
    Location:
    Sunny Florida
    #6
    Sounds like it's time for a restore. I assume you've rebooted your iPhone?
     
  7. macrumors member

    Joined:
    Nov 14, 2011
    #7
    I had one custom ringtone that I couldn't delete. Made sure that it was deleted from iTunes and my PC. Then I did a full restore and that fixed it.
     
  8. macrumors 6502a

    Joined:
    Jun 29, 2009
    Location:
    Australia
    #8
    I have about 200 on mine too, a lot of them are used as unique ring tones for people :D

    As for the OP, sorry, I tried here and can delete them no drama from itunes and the phone
     
  9. macrumors newbie

    Joined:
    Dec 15, 2011
    Location:
    Wisconsin
    #9
    You have to go to your iTunes account and delete the ringtones under your library, then you can re sync your phone and it should fix the problem. Worked for me anyways.
     

Share This Page