iPhone 5 and Vodafone India

Discussion in 'iPhone' started by mustu, Oct 8, 2012.

  1. macrumors regular

    Nov 5, 2011
    Hi I have been using my iPhone with my Vodafone in the UK but I have come to Bombay ,India and have put a local sim card in the phone.

    I have noticed that when I turn the phone on I get ...searching....... then it goes to like No service for a like 3 to 5 seconds and then I get the vodafone signal.

    People who are using a iPhone 5 in India on vodafone please can you check the same and let me know if you are getting a similar thing with the network.

  2. macrumors 65816


    Dec 29, 2007
    Does it work though?!
  3. thread starter macrumors regular

    Nov 5, 2011
    Yes it does very well!

    Can someone please try this and let me!

  4. macrumors newbie

    Jan 5, 2013
    I do face the same thing on my iPhone. Not sure if it is a problem from vodafone side and or if the phone itself.

    Moreover, my signal goes off randomly and then No Service and then back again.. it happens like within 7-8 seconds..
  5. macrumors 604


    Mar 26, 2008
    isnt this pretty normal when u turn it back on?
  6. macrumors 6502

    Oct 18, 2012
    It happens for me as well on AT&T in the US. Turn phone on, it searches, then goes to no service, then after a few seconds it shows the AT&T signal. I think it normal for the phone to do this upon powering on or coming from airplane mode.
  7. macrumors regular

    Aug 6, 2012

    My iPhone 5 (originally on Vodafone UK) never use to do it.

    Then got it unlocked and now using on o2 UK. It now does that "searching, no service" story every time when loading up. Only shows no service for a second before switching to the o2 sign
  8. macrumors 65816


    Dec 29, 2007
    Mine does that. It's normal.
  9. macrumors 6502

    Jul 24, 2011
    Happens the same for Airtel as well; Its normal.
  10. macrumors member

    Feb 23, 2012
    I am also using iPhone 5 16gb black and vodafone as my carrier(from delhi).. I also face the same thing and its normal:)
  11. macrumors regular

    Apr 15, 2012
    Yes the same thing on AT&T in the US as well. I think it is briefly for just 2 seconds and not that bad.

    A question for those on Airtel and iPhone 5.
    What do you see on your phone - is it 4G or 3G. What's the speed on a normal day? I know it won't latch to LTE.

    Here for reference on AT&T, it goes to as high as 45Mbps when on LTE, about 15 Mbps when on 4G. I haven't seen it drop to 3G yet so can't say.

    Can some one write about the speeds we get on airtel and Vodafone. I wanted to make a choice which one to use.
  12. macrumors 65816

    Jul 22, 2011
    it's normal as it can get i always get searching then no service and then 3-4 secs signal when i switch carriers like you
  13. macrumors 65816


    Apr 10, 2007
    I was hoping for some assistance from some nice Indians :)

    I'm visiting Mumbai and Goa next week from the USA and I am bringing my unlocked iPhone 5. Someone has arranged for me to have a Rs 250 prepaid nano-SIM from airtel when I arrive.
    I have a couple of questions, if you don't mind.

    1) Is it as easy as inserting the new Airtel SIM and all works well? Or are some setting changes needed in the iPhone?

    2) I visited the Airtel website, but I cannot figure out how to pick a specific prepaid plan. The page doesn't explain how many SMS/minutes/data is included in various plans, or how to select the plan I want. Can someone explain how I do this? What plans are available prepaid? I am traveling for 2 weeks in India.

  14. macrumors newbie

    May 16, 2012
    my answer

    Go to prepaidweb.airtelworld.in have an account there for your airtel mobile number , using that you can subscribe to and know various Airtel plans.
    Also you can know the detail at airtel.in just choose the respective circle( state of your visit and get various details ) for any more query you can contact me at isaket@me.com, I am a happy airtel user and an apple fan from India.
    Have a nice day and feel free to ask.
  15. macrumors newbie

    Feb 21, 2013
    New SIM activation

    I got an iphone from UK which i was using there with O2. Its an unlocked phone.
    In India i got a new sim from Vodafone. Now even though they say the number has been activated, the phone still shows No Service. Is there anything that needs to be done in the phone to make this work ?

  16. macrumors newbie

    Jan 10, 2012
    I am Airtel's Hyderabad network and it does not happen to me! May be you have a faulty SIM.
  17. macrumors member

    Jul 7, 2010
    All over the WWW...
    Searching -> No Signal and then getting the signal is not a problem with the phone or the SIM. It happens to me whenever I turn on my phone.

    Even my friend who has the iPhone 5 has the same outcome.

    I don't think there is any problem with it. Might just take time to connect to the network.

Share This Page