iPhone 5 text tone alert not always alerting me

Discussion in 'iPhone' started by Appledreamer, Sep 27, 2012.

  1. macrumors member

    Joined:
    Jun 16, 2011
    Location:
    Belfast
    #1
    Hi. I got my iPhone 5 last Friday but I have noticed that it does not alert me everytime I get a text message. I offend lift my phone up and have a few messages on it with out a text tone alert.

    Does anyone have any idea what I could do
     
  2. macrumors newbie

    Joined:
    Sep 27, 2012
    #2
    Same Here

    Hi there,

    I had the same problem, my phone would only vibrate and not make any sound on things like typing a message, and when I got a call or a text.

    The strange thing is that is I switched the phone off then on again it would all work ok, I noticed this on Friday and over the weekend, I called Apple Support who did not have a clue about what to do, strange that it has been fine yesterday and today.

    Its not just you, if you look at other forums on both here and the apple communities pages others are having the same issue.

    Hope that helps.
     
  3. macrumors newbie

    Joined:
    Oct 24, 2012
    #3
    Turn off Bluetooth and they will work again. Hope they fix this
     
  4. macrumors 68020

    Joined:
    Nov 15, 2011
    #4
    I think this happened to me...

    I got a txt from my wife that said "I'm just going to call and bla bla bla cause I need to know now". I look at the thread and there were two other messages before it. I got no notification of these messages. No vibrate/tone/whatever.

    I restarted my phone and tested a few more times and it seems to be working.

    JasonBrown, how do you know it has to do with bluetooth? My wife leaves b/t on all the time (4s) and has no problem. I turn it off on my 5 but sometimes leave it on by accident.
     
  5. macrumors newbie

    Joined:
    Oct 24, 2012
    #5
    Either you need to restart your device, or do a complete restore without applying the back up. If its a software issue, always assume that a restore can fix the bug first...;)
     
  6. macrumors 68040

    dontwalkhand

    Joined:
    Jul 5, 2007
    Location:
    Phoenix, AZ
    #6
    I don't know why Apple advises against reapplying the backup, without it, you'll lose all of your stuff.
     
  7. macrumors newbie

    Joined:
    Oct 24, 2012
    #7
    I use to be an FRS at an Apple retail location. We don't want you to apply your old back-up because, most of the time there is bad software within that backup, thats causing the issue every time you erase and restore back up. You wont lose important things such as your contacts because they can be constantly synced to icloud, and are not within the actually icloud backup :D
     
  8. macrumors newbie

    Joined:
    Nov 21, 2012
    #8
    I have the same problem with 2 iPhone 5. Apple was the pain the ass. They told me its the software issue. There is no or lowest ring tone on text, email. It's very annoying. It happened the first day I bought them. What to do???????
     
  9. macrumors newbie

    Joined:
    Nov 21, 2012
    #9
    I don't know what to do. It sucks to pay for new device and it does not work. I have to restart my phone every single day such as now. What to do? ???? Help
     
  10. macrumors 6502a

    chrislaw

    Joined:
    Apr 11, 2009
    Location:
    central ohio
    #10
    Mine does it as well but it only seems to do it on an active text thread. Well, I mean if i text my wife and turn the display off and she texts me within the next few minutes I do not receive an alert... That seems to be what is happening but it's really just an observation. Also my bluetooth is always off.
     
  11. macrumors member

    Joined:
    Feb 11, 2007
    #11
    Solution for me is restart the phone
     
  12. macrumors 6502a

    chrislaw

    Joined:
    Apr 11, 2009
    Location:
    central ohio
    #12

    This is happening to me all the time now. I text someone and turn off my display. If that person texts me within the next few minutes, I receive no alert.

    Is this normal?
     
  13. macrumors 6502

    Joined:
    Sep 4, 2011
    Location:
    Salt Lake City, Utah
    #13
    Yeah this happens to me, too. A restart fixed it.
     
  14. macrumors newbie

    Joined:
    Mar 23, 2006
    Location:
    Northeast USA
    #14
    Restarting the phone is only a temporary fix, the problem keeps returning:mad:
     
  15. macrumors newbie

    Joined:
    Jan 19, 2012
    #15
    welcome to the club!

    Christ, this is simply ridiculous. I had this same problem with my iPhone 4 and now with my 5. No official solution, no word from Apple, just same old crappy problems.
     
  16. macrumors newbie

    Joined:
    Feb 20, 2013
    #16
    No Text Alerts When Messages Is Open For Over A Year Now

    Come on...there has to be someone out there who knows how to fix this. I receive no alert when a text message is received if the Message app is open. I have an iPhone 4S with only stock alerts and tones, my girlfriend has an iPhone 5 with only stock alerts and tones. We are both on Verizon. Neither of us will receive an alert with the Message app open.

    I've gotten in the habit of pressing the Home button immediately after I send a text so that I will know when I've gotten a response, but this is so lame. The problem is consistent. We don't use Bluetooth or headphones if that matters. It doesn't matter if the message is an iMessage or otherwise.

    I keep hoping with every iOS update that it will be fixed. But nope. With such a capable device, this is frustrating.

    Any help would be greatly appreciated.
     
  17. macrumors 6502

    Joined:
    Nov 4, 2012
    #17
    I thought this was just the way alerts work in the Messages app? It always plays a different (very quiet by default) tone if the message thread is open and you receive a new message. Even if the phone is locked, the app and thread are still running.

    I don't think this is a bug so much as it's the way the tones in the app are designed to work.
     
  18. macrumors newbie

    Joined:
    Mar 10, 2013
    #18
    I have had my iPhone 5 for about a month now and just started having this exact same issue. I've looked everywhere and there is no solution I've seen as of yet. It appears as though Apple is going to need enough complaints from us to include it in the next iOS update? Annoying. :-/ I missed like 10 texts from my mommy.

    ----------

    I don't think so because I never had this problem with my iPhone 4, and I doubt the set up for alerts is any different.
     
  19. msaga408, Mar 13, 2013
    Last edited: Mar 13, 2013

    macrumors newbie

    Joined:
    Mar 13, 2013
    #19
    No good

    What I found out is that you need to go into settings then to notification and then under messages make sure your alert style highlighted under banner or alert. This fixed it for me for a while and it is acting up on me again today. Fixed it again
     
  20. macrumors newbie

    Joined:
    Mar 31, 2013
    #20
    Escalation to Apple .... maybe

    Well I've just spent 45 minutes on the phone to Apple trying to get to the bottom of this - and surprisingly (or maybe not) they don't seem to have any record of this issue or any work-arounds in their knowledgebase.

    Suggested I take a backup & reset my iPhone5 (on iOS 613) back to default settings, and then if the problem persists then restore from backup, and then if the problem presists they'll raise the issue back to the plant.

    I really can't believe they don't know about this issue. In the meantime I'm going to try closing down the msg app after I send each TXT to see if that makes a difference. I suspect (as another person above also suggested) its something to do with leaving the msg thread open and/or leaving the msg app open and/or the speed of the next txt arriving.
     
  21. macrumors newbie

    Joined:
    Mar 31, 2013
    #21
    giving up

    gave up on Apple even believing this was an issue - using Viber now instead & its great.
     
  22. macrumors newbie

    Joined:
    Apr 27, 2013
    #22
    I am experiencing the same problem. I am not receiving notifications for texts when my screen is in locked mode/ black/ sleep. I can be in the middle of a back and forth conversation and if it takes the person a few minutes to respond and the screen goes dark then I do not get any type of notification that they've responded to me. I have to keep hitting the home button to check for a response. Often times I will not hear anything for a while and I will happen to check my phone and see I have missed numerous texts from people and no alerts ever went off. I do keep the volume off at work most of the time but I have it set to vibrate and for a banner to pop up... Nothing. I tried switching it to the full on message to pop up and that did not help either. It doesn't matter whether my sound is on or off, I do not receive notification if my screen is dark. If I am reading an email or playing a game or surfing the web then I receive a notification... So basically I have to constantly keep my phone in use with the screen lit to receive notifications or I have to be one of those people who just checks their phone all the time. Neither is a good option. For as expensive of a product as these phones are they should not have glitches like this. I have discussed this issue with Apple support and their answer for most things is to do a restore. Well I do not want to lose everything and build my phone from scratch again. If they cannot successfully create software updates that do not create glitches with their existing software then they need better geniuses in their think tank. I almost feel like I cannot do anymore updates because each time I do something else goes wrong with this phone. I am supposed to go meet with the "geniuses" in the morning to resolve this issue. I will post any earth shattering resolutions if any are discovered.
    Oh yeah, another thing I find odd, while on with support they asked me to do a reset and when I tried to a screen asking me to enter my passcode came up I entered the pass code I use everytime I use my phone and it said 7 failed attempts. I tried it once and it was the correct code. Apparently there is a separate reset code and not even apple can tell me what mine is or how to bypass or reset this. I never created any other code and I have always used the same passcode for my phone. Bizarre. They really need to get on top of things and work out all the glitches.
     
  23. macrumors 68000

    Joined:
    Aug 11, 2009
    #23
    It also helps if you exit the messages app. Otherwise you are not alerted for new messages if it is active. I do wonder if this is what most people here experience without realizing it. Sure a reboot fixes the problem because it closes the messages app.
     
  24. kippesaurus, Apr 29, 2013
    Last edited: May 19, 2013

    macrumors newbie

    Joined:
    Apr 29, 2013
    #24
    /

    /
     
  25. macrumors newbie

    Joined:
    May 9, 2013
    #25
    Wow, Kippesaurus figured it out. I don't think anybody here tried the silent toggle switch on the side of our iPhones since the Gen1, or to read the manuals. Thank you so much for your genius insight on this matter.
     

Share This Page