iPhone and iPad not showing up in iTunes with synch via wifi on new MBA

Discussion in 'iOS 5 and earlier' started by zen, Jan 28, 2012.

  1. zen
    macrumors 65816

    Joined:
    Jun 26, 2003
    #1
    I've just switched from an iMac to a MBA with external monitor. I've shifted my iTunes library and have authorised the new computer in iTunes, etc.

    Both my iPhone and iPad have the "synch via wifi" option selected. Both are on the same wifi network as the MBA (just like the iMac was).

    However, neither device shows up in iTunes if I unplug the cable. With the cable plugged in, everything works as normal and I can synch. When I unplug the cable, the device disappears and iTunes can't see it.

    With my iMac, both the iPad and iPhone were listed under devices, no matter where they were in the house, so long as they were on the wifi network.

    I think I've been through every iTunes setting (the "prevent ... from auto-synching" is NOT ticked).

    Running iTunes 10.5.3, Lion 10.7.2, and iOS 5.0.1. The MBA is in clamshell mode with the external monitor connected, and is on the wifi network without any problem.

    Any ideas? Am I missing a step somewhere?
     
  2. macrumors 68000

    Joined:
    Aug 8, 2002
    #2
    Just out of curiosity have you tried with the MBA open as opposed to clamshell? Maybe something weird about that interaction.

    In not, try de-selecting wifi sync. Quit/reopen itunes and hard reset your ipad while doing so. Connect wired. Sync. Reset your iPad, again quit/reopen iTunes. Reconnect wired, and now select wifi sync. See if that doesn't do the trick.
     
  3. zen
    thread starter macrumors 65816

    Joined:
    Jun 26, 2003
  4. macrumors 68000

    Joined:
    Aug 8, 2002
    #4

    You're welcome and glad it worked! I have found that many pairing type errors can be remedied with a handful of quit/reopen/reset type activities.

    I have problems with the Remote app and iTunes on my iMac sometimes not playing nicely. Haven't been able to solve it permanently but this type of thing usually helps for a time.

    I actually saw the solution above posted in another forum some time ago. Anyway, glad it worked!
     
  5. macrumors 6502

    Joined:
    Nov 14, 2007
    #5
    Worked for me too! Strange, I wonder exactly which of the steps it is that actually solves it. Sounds strange that you have to do the restart of the iOS device twice, no?
     
  6. macrumors 6502

    Joined:
    Nov 14, 2007

Share This Page