iPhone and No sound!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by EricBrian, Oct 28, 2007.

  1. macrumors 6502a


    Jul 30, 2005
    So, after I access my iPhone after it hasn't been used for a while, there is no sound... I can't hear people on the phone, I can't hear anything that I play under music/video/etc.... Sometimes, it even happens while I use the phone... I can not hear the person I am talking to.

    I restored the software. I rebooted the device. Doesn't help. It happens again and again.

    Happen to anybody else? What have you done to stop this?
  2. macrumors 68030


    Oct 7, 2007
    DFW, TX
    that sounds pretty serious (pun!)..

    I know this is the answer youre trying to avoid, but I would take it into an apple store to get a new one...
  3. macrumors 6502a


    Oct 19, 2003
    Have you been listening to headphones? If so, plug them in and back out again. Should have sound now.
  4. macrumors 68000


    Oct 6, 2005
    My advice too. Play with the headphones until it works.

    This is very annoying when it happens and I almost flipped the first time it did until I miraculously figured it out.

    I don't understand why this is such a problem and happens to so many of us so frequently. Unfortunately its most likely a hardware defect and cant be fixed with a software update :mad:

    I still love my :apple:iPhone though:D
  5. macrumors regular

    Aug 15, 2007

    its so funny that i came across this thread, the exact same thing happened to me yesterday and I flipped out. I have an audiojack wired directly to my car stereo as well as a charging dock with remote in my car so it holds my phone, charges it, controls remotely with a remote that has tactile feedback and it plays music and phonecalls seemlessly through my car speakers. When I took my phone out of my dock yesterday, I had no sound. The speakers wouldnt play music and the earpeice didnt work either. I started to freak, but when I plugged the audio chord back into the headphone jack, It fixed the problem. Strange!!!!
  6. thread starter macrumors 6502a


    Jul 30, 2005
    Thanks everybody for the input! I really appreciate it.

    It is odd... Today, I had no problems at all. So, no help from the Genius Bar. I hope it was a one time 'odd' behaviour. I doubt that though since it continued to happen even after I ran a restore.
  7. macrumors member

    Apr 27, 2005
    I've recently had the issue where I couldn't hear through the ear piece. Speaker phone would work but then when I would switch to ear piece I would get nothing. I blew into the headphone jack and that seemed to fix it. Maybe a piece of lint got in there from my pocket or something
  8. macrumors newbie

    Jun 30, 2007
    Excellent tip, EricBrian! i blew into the headphone jack. it still didn't work, but i stuck the headphone in and pulled it out. and now i have sound again!!! something probably just got in there and the phone thinks the headset is connected.
  9. macrumors regular

    Jul 3, 2005
    Burton michigan
    I'm still having problems even after throwing the jack in and out for a few hours!

    argh I've had to use the earbuds (and the left one broke) so its been a pain in the ass with that and speaker phone
  10. macrumors newbie

    Dec 1, 2007

    This worked for ME! Thanks for giving me hope and coming through...
  11. macrumors member

    Sep 21, 2006
    strange, I have this problem today where I can't hear anything out of the phone but when I put it on speaker it works fine.
  12. macrumors newbie

    Jan 2, 2008
    Thank You!!

    I was in a hurry to call a friend to see if I should stop by on my way home but when I touched her name i saw calling.... but I heard no sound. I connected my Bluetooth to temporarily solve the problem. But as the day went on i noticed I couldn't hear any calls through my iPhone. So i looked and saw i wasn't the only one having this issue, and i thank you SOO MUCH!! for helping me solve this. I plugged my headphones in IMMEDIATLY and the problem was solved. Much appreciation and thanks again.
  13. macrumors newbie

    Jan 11, 2008
    I’ve had this issue about once a fortnight now, since I got my UK iPhone on November 9th, and none of the so-called ‘fixes’ work for me (although that could be because they’re very much ‘try this till it works’, and not particularly scientific).

    One thing I noticed, though, is that I seem to have found a rather odd fix that works for me:
    1. Plug in the earphones.
    2. Play something in the iPod. Anything.
    3. Turn off the phone.
    4. Unplug the earphones
    5. Turn the phone back on.
    6. Rejoice at the sound working once again.

    Granted, I’ve also had it fix itself rather mysteriously on other occasions, but this seems to reliably fix it. Hopefully, I’ll have it exhibit the problem again next week (and I’ll know what steps to avoid) and I can get the Genius Bar to have a look at it.

    <edit>It’s also worth noting that, when I lose sound on mine, the only sounds that work without headphones/bluetooth/speakerphone are ringtones and alarm tones. UI sounds do nothing (no key clicks, no lock/unlock noise, etc.).</edit>
  14. macrumors newbie

    Jan 11, 2008
    Stockholm, SWEDEN
    I have the speaker problem... and this is my story:

    The first time my speaker sound disappeared was when i was talking on the phone with the earbuds (headset) plugged in. When I ended the call with the squeeze remote, the ipod mysteriously started playing the first song in my music library on the iPhone. I disconnected the earbuds (without turning off the music) and the sound disappeared! :confused:

    I did a restore on the phone... and "voila!" the speaker sound returned. :D

    A couple of minutes later I was browsing the content on the phone (AFPd from Installer) while listening to music on the speaker. I closed the server connection... and the speaker died AGAIN!!! :eek:

    Frustrated I started to fiddle with all the buttons. When I dubbel-tapped the power/mute button on top of the phone, the speaker activated again!? Nervous as hell I pressed the power button again to make sure the speaker sound should stay on this time... but no, it disappeared. This time for good! :mad:

    To this moment I have tried:
    * to clean the female end of the plug from dust with a cotton swab
    * reset
    * restore
    * virginize
    * oneSim (some had problems with sound disappearing when using anySim)
    * update to 1.1.2

    ...still NO speaker sound! :(
  15. macrumors member


    Jan 4, 2006
    London, UK
    I'm having the n sound problem, with me it's all stopped... it doesn't work through the ear buds, no ring tones, when I try to play a song it doesn't start to play (as in it doesn't even play silently), when I try to call people it trys to put me on speakaphone (sometimes but not others) but I get no sounds at all? it was working fine a few hours ago, I spoke on the hands free, listened to tunes. Now nothing?

    I damaged the left ear bud the other day & that had stopped working, and I restored it yesterday after it froze and wouldn't re-boot... is this all connected?

    it's a 1.1.2 otb running 1.1.4, jailbroken & unlocked???

    Any ideas?
  16. macrumors member

    Mar 29, 2008
    Well i finally decided i was going to jailbreak my phone last night. I do so, and i guess at somepoint the audio stopped working, no key clicks, ringtones etc etc.

    i tried the headphone trick to no avail, im now going to refurbish the phone with Ziphone, and restore it via itunes. id rather have a fully functioning regular iphone than a jail "broken" one. ill let you knwo how it goes
  17. macrumors newbie

    Apr 26, 2008

    Fieldy, you are a legend. I had tried turning the phone off and back on 100 times, i'd tried doing a reset 1000 times, I'd tried putting in and removing the head phones 10,000 times and finally did a full restore of the phone and nothing. I was at the end of my rope and was about to throw it out and buy a new one when I saw Fieldy's post. I urge anyone that is having no luck to do exactly what Fieldy said. Plug in the headphones, start playing a song, turn off the phone. take out the head phones and turn it back on. Your earpiece will now have sound. Very strange considering that one day is randomly stopped working even though i NEVER use my headphones and the phone is brand new, (my second one, the first one ended up in a toilet)
  18. macrumors regular

    Bad Ash

    Feb 20, 2008
    Chicago, IL
    I have a similar issue except I've lost the speakerphone while on phone calls only. I can hear through the headset speaker but not over the speakerphone. All other sounds out of that speaker sound fine. Any ideas? Its a brand new 16gb. Apple is sending out a brand new one for me but I'd still like to figure this out. Thanks guys.
  19. macrumors newbie

    May 4, 2008
    iPhone no sound - Fix

    I was using my iPhone (working perfectly) and decided to change the root password. Some search on the internet and a few seconds later I was making the changes. BUT, the iPhone was not rebooting any more after the "tweak". So only chance I've had to have my iPhone working again was to restore it with iTunes. Once it was restored of course the phone was not accepting my SIM card... So I used ZiPhone and clicked on the "One-Click Actions-Unlock, Jailbreak & Activate). After the phone was working with my SIM, and with SOUND working fine. BUT iTunes could not sync..... So I returned to ZiPhone and clicked on "Jailbreak" button... after iTunes was working, so I could sync my media, but here we are !!! NO SOUND any more... After "again" a few searches on the internet and some jack plug and unplugging, with no results I was under the impression that it was over for my device... After a few hours rest, I got back to my computer, and made a restore again from iTunes... After reboot the sound was back... Once more I used ZiPhone and clicked on "Unlock, Jailbreak & Activate" button... After reboot the sound was always there, AND I could sync with iTunes...

    Sorry but I cannot have a clear view about why and when the problem started... Maybe the first use of ZiPhone did not make all the job correctly and because of that iTunes was not working (sync) ? And my fault if I used the Jailbreak button once more ??

    The fact is that now the iPhone is working fine again and with sound.

    Hope this will help someone!

  20. macrumors newbie

    May 17, 2008
    GAH iPhone sound issues

    Ok so i have a similar issue. Mine is a 16g jailbroken iPhone which came with 1.1.4 firmware. My problemsl started when my iPhone suddenly screwed up and would'nt load past the apple logo screen. I did a full restore and unlocked and jailbroke it again, and it was working FINE. One morning i was playing sound through speakers and earphones, later that day, nothing. No sounds at all. And it wont even start to play in iPod. Exactly like Mr Pineapples.

    The solutions i have tried [taken from various posts including this one]:

    "Try plugging and unplugging in your headphones 5 or 6 times. That often fixes the problem."

    "One thing I noticed was that each time I plugged the earphones back in was that the last thing I was listening to through the player would start back up. So, I switch the phone to listen to something, anything else besides a song. Say, your ringer. Then it works fine."

    "Go to ipod > songs > cover flow orientation
    Notice in the upper left the song/player is PAUSED.
    Unpause the song.
    Exit ipod mode.
    Earbuds work."

    "1.) Plug in headphones.
    2.) Play a song.
    3.) While the song is playing through the headphones, pull the headphone jack out. This will pause the music.
    4.) Press play on screen. The music should resume, now through the iPhone external speakers."

    " 1. Plug in the earphones.
    2. Play something in the iPod. Anything.
    3. Turn off the phone.
    4. Unplug the earphones
    5. Turn the phone back on.
    6. Rejoice at the sound working once again."

    Nothing works. If somebody has any idea whats wrong please help.

    I want my iPhone working again!


    Andrew Lowe
  21. macrumors newbie

    May 17, 2008


    Un freaking believeable. I was browsing for solutions for ages before i actually decided to post a quote myself. A minute later and my sound is working!!!

    Just go to settings, general, RESET ALL SETTINGS.

    And let there be sound.

    Good luck to everyone.
  22. macrumors newbie

    May 31, 2008
    I thought my time had come!

    No sound - nada! Panic until read this thread.

    Reset (under general settings) worked perfectly.

    You saved my life folks. Thought I was going to have to go out and buy a Nokia to last me until the 3G version is out. How horrible would that have been. ;-)

  23. macrumors regular

    Jan 15, 2008
    I too thought I was without a phone till the 3G hits us in a few weeks.

    The turn off while h/p plugged in, unplg phones and turn back on worked for me!

    Thanks all:)

  24. macrumors newbie

    Sep 4, 2008
    Real fix for iphone headset jack problem.

    There´s no sound because you have your headset jack dirty... Here´s the solution:


    I hope that helps.
  25. macrumors newbie

    Oct 13, 2008
    here is the fix

    if your having no sound what so ever, just use ziphone and jail break it again if it is jailbroken, if not do it anyways it some how fixes it. this of course only works with 1.14 version of the iphone. try that it just worked for me and i didnt have to lose any of my apps or do any type of hardware fix. hope this helps.


Share This Page