iphone bluetooth won't connect automatically?

Discussion in 'iPhone' started by twoodcc, Aug 24, 2008.

  1. macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #1
    so i have my iphone paired with my cd player in my truck for hands-free calling, but i have to unpair and repair it everytime i get in b/c they don't see each other on their own, even though they should. can anyone help me with this?
     
  2. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #2
    after looking more into this, do i have to tell the radio to connect to the phone?
     
  3. macrumors 6502a

    Joined:
    Dec 28, 2006
    Location:
    On one of my Macs of course
    #3
    Aloha twoodcc,

    I have a Lexus RX-350 which has a hands-free system. On my center console screen, I select the telephone portion, not the radio, to set up any Bluetooth devices I wish to connect with my vehicle's Bluetooth. I've not heard of pairing a cell phone with a radio system, but I only had to pair my iPhones with my vehicle once each (once for the original iPhone and once for the iPhone 3G).

    :apple:HawaiiMacAddict
     
  4. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #4
    thanks for the reply. so when you get into your car with your iPhone, you just select telephone and it connects?
     
  5. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #5
    well i don't know what's with my iphone, but it still won't connect with my radio without unpairing and then repairing
     
  6. macrumors 68030

    skubish

    Joined:
    Feb 2, 2005
    Location:
    Ann Arbor, Michigan
    #6
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5C1 Safari/525.20)

    probably a setting on the radio to auto pair. Is the Bluetooth turned on on the iPhone? All does it show in the menu that the two devices are paired?
     
  7. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #7
    well, it's possible it's with the radio, but after reading the manual, i'm pretty sure it's setup correctly.

    the bluetooth is turned on on the phone and on the radio. it shows on the iphone that it's paired with the radio, but it won't connect to it, unless i un-pair it and then re-pair it, and then it will work great, until i take it out of the car, and the next time it won't connect
     
  8. macrumors member

    Joined:
    Aug 14, 2008
    Location:
    Sydney, Australia
    #8
    I think its probably your radio too...

    I have a BMW 530i and it has bluetooth and I just leave my bluetooth on on the iphone and they pair up automatically when I get in the car. I don't have to do anything.
     
  9. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #9
    well that is what it's supposed to do. but for some reason it's not doing it. do you have 2.0.2 on your iphone?
     
  10. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #10
    the radio is a Sony MEX-BT2600, i think
     
  11. macrumors member

    Joined:
    Aug 14, 2008
    Location:
    Sydney, Australia
    #11
    Yep I have 2.0.2

    Have you tried pairing the cd player with another phone to see if that works?
     
  12. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #12
    not yet, only cuz i don't have another phone. i will do that this weekend though.

    see, heres the weird thing. when i first paired it up, the first day i got the radio, everything worked fine. but now it doesn't, and it hasn't for at least a week now, if not more
     
  13. macrumors 6502

    Joined:
    Feb 10, 2008
    #13
    Similar problem here with my iPhone 3G except I have three BT devices - my Garmin nuvi and two headsets (a Plantronics and a Jabra) and after awhile of being paired, it refuses to reconnect with any of them.

    It tends to be fine for about a day or so but then afterwards refuses to pair anymore. The only workaround I've found is after pairing the devices, never disable bluetooth on my iPhone and it's fine. It's when I turn off bluetooth and turn it back on when problems occur. I think it's a flaw with my (and your) iPhone, but since it's tough to demonstrate the problem to a genius since the amount of time it takes between pairing and not being able to pair anymore is so erratic and relatively long, I don't know how likely you are to get a replacement.
     
  14. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #14
    thanks for the reply. i guess i need to try to connect my iphone to another device, but i don't think i have one
     
  15. macrumors 6502

    Joined:
    Feb 10, 2008
    #15
    You can try, but if your problem is anything like mine, it's a flaw in the bluetooth radio in your phone, not the devices you're pairing the phone with.
     
  16. thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #16
    well, if that's the case, then maybe i can take my phone to the apple store and get a replacement.
     
  17. macrumors newbie

    Joined:
    Oct 27, 2007
    #17
    Same problem here:

    I just bought an AT&T TL92328 DECT 6.0 Bluetooth cordless phone, and it would not autopair with my iphone: I have to unpair, repair (and enter the pin) in my iphone every time I come back home.

    Any solution?
     
  18. macrumors 603

    Joined:
    Jul 29, 2003
    Location:
    Silicon Valley
    #18
    I have to turn my Jabra off and back on anytime I go out and back in of range of it (I usually leave it in the car), or else it won't pick up calls. I leave the iPhone's BT turned on.


    .
     
  19. macrumors 6502

    Joined:
    Feb 21, 2008
    #19
    i think i've been having this problem since 2.1. i have to re-pair if i turn the BT off and then back on for my devices. it was working fine before 2.1.
     
  20. macrumors newbie

    Joined:
    May 23, 2003
    #20
    I'm having the same problem, I have an ATT TL92278 Dect 6 bluetooth and it constantly needs to be re-paired after I leave the house. The iPhone says it's paired but the home phone no longer has a bluetooth indicator light.

    What's even crazier is that every 3 or 4 times I leave home it re-pairs automatically like it should, but 25% is pretty crappy reliability.

    What a PITA. The problem with third party anything is both sides always blame the other...
     
  21. macrumors newbie

    Joined:
    Mar 4, 2009
    #21
    Plantronics 855 connectivity

    I have a Plantronics 855 headset that shows paired however it doesn't connect automatically. My iPhone is Jail broken and running on firmware 2.2.1. Has anyone been able to solve this issue other than re-pairing the phone and the headset.
     
  22. Guest

    #22
    I have paired my iphone with the bluetooth on my Saab 9-7x (it is a General Motores bluetooth system). Initially, the iphone automatically connected to the bluetooth system every time that i entered the vehicle with the iphone bluetooth turned on. However, the iphone bluetooth no longer automatically connects to the GM bluetooth system. Similar to the initial post in this thread, bluetooth on the iphone shows the "General Motors" system but it won't connect to it, unless I un-pair it and then re-pair it, and then it will works just fine until I turn off the ignition of the car; then, the next time it won't connect unless I un-pair and re-pair again. HELP!
     
  23. macrumors newbie

    Joined:
    Jan 6, 2011
    #23
    hi Guys
    I got the alpine cde-114bti for x-mas and i have been trying to make my iphone 3s connect to the raidio automaticly but i always have to go into the bt menu and pair it again is there any way that they connect once they are in bt ragnge?
     
  24. macrumors newbie

    Joined:
    Jun 25, 2011
    #24
    I have a 2011 Silverado with the same Bluetooth connection problem. I figured out that the car wouldn't recognize the phone whenever I had the 12V charger plugged in. Disconnect the charger and restart the truck and it connects every time. Hope this helps.
     
  25. macrumors newbie

    Joined:
    Aug 15, 2011
    #25
    I just got a brand new iPhone 4 for work and I have a Panasonic in my truck. I am having the same problem. I just changed from a blackberry to this. Anytime I got within ten feet of the truck with the blackberry the radio would "see" the phone and connect automatically. No problem for over a year. Now with the iPhone it wont connect after one or two times. I get the message that the phone is "paired" but it wont connect. When I try to connect the radio says "error". I then have to turn Bluetooth off on the phone and back on and then try to manually connect again. After that it works fine for about a day and then fails again.

    I hate to change back but I may need to go back to blackberry.
     

Share This Page