iphone error 6 - HELP!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by benfilan, Oct 27, 2007.

  1. macrumors 6502

    benfilan

    Joined:
    Dec 21, 2006
    Location:
    Ireland
    #1
    I've been trying to restore my iPhone for DAYS now, everytime it runs it gets about 25% through and then fails, I get: 'an unknown error occured - error (6). does ANYONE know what this might mean, or know of a way to fix it? I're read that it might be a USB problem, but I've tried in in 4 different computers with no change. also tried the restore in Windows with the same result.:mad::(
     
  2. macrumors newbie

    Joined:
    Nov 15, 2007
    #2
  3. macrumors newbie

    Joined:
    Jul 12, 2008
    #3
    iphone error (6) fix

    so, same problem, i wanted the new 2.0 firmware on my iphone, it bricked, really bad, i tryed restoring to everything, 1.1.1 1.1.2 1.1.3 1.1.4 and keept getting everithing from error (6) to (9) to (20) and to 16**, i don`t know if it only worked for me but this is what i did, i took out the sim card, and installed ziphone, docked the iphone and in ziphone ADVANCED FEATURES chose DFU mode, then in itunes i restored it to firmware 1.1.3 the only one that worked only after it installed it sayd refreshig firmware and crashed, error bla bla bal and showed me the usb cable on the iphone, nevermind that, the software is installed u just can't see it, go to ziphone and click on DO IT ALL, after that. happy happy joy joy it worked, i`m now on 1.1.3 firmware, i used to be on 1.1.4, tryed to upgrade to 1.1.4 and bricked the phone again, but did the whole ziphone 1.1.3 and worked, so i did it twice and it worked for me, hope i`t's useful sorry abut the mistakes i`m from romania
     
  4. macrumors newbie

    Joined:
    Jul 14, 2008
    #4
    to boy ro

    iam from romania too
    please help me

    thanks
     
  5. macrumors newbie

    Joined:
    Dec 27, 2008
    #5
    solution unknown error 6, 8, etc

    I had this same problem and all I had to do was update Java. For those still confused go to
    http://support.apple.com/kb/TS1275
    for troubleshooting. Good Luck.
     
  6. macrumors newbie

    Joined:
    Jun 2, 2011
    #6
    After trying different cables, USB ports and removing USB devices etc I finally tried disabling all my firewall and anti-virus software temporarily while the restore/upgrade took place.
    This finally solved the problem.

    Hope some of you find this usefull
     
  7. macrumors newbie

    Joined:
    Jul 19, 2011
    #7
    i had the same problem upgrading to ios 4.3.4 but after disabling zone alarm free it worked like it dream
     

Share This Page