iphone sms "error sending message" help

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cmoralespv, Oct 25, 2007.

  1. macrumors newbie

    Joined:
    Oct 25, 2007
    #1
    I have a 1.1.1 unlocked iphone and have been experiencing problems while sending sms. I have done various tests and have discovered the following.

    I am able to send messages to any contact when I am sending a message to that contact for the first time or whenever that contact has not sent me an sms.

    I am able to receive all messages.

    When a contact sends me an sms, I am no longer able to send that particular contact an sms.

    But if I delete the conversation, I am able to send that contact messages again.

    Does anyone have any clues on what could be happening? Is anyone else experiencing this problem with their unlocked phones? A friend of mine has the same iphone and unlocked it using simfree (as I did) and does not have this problem.

    I appreciate any help that can be provided. Thank you.
     
  2. macrumors newbie

    Joined:
    Oct 3, 2007
    Location:
    510
    #2
    same issue

    i have a phone that has not been unlocked....swapped it out at apple today...and its happening with one contact only....later in the day it started happending to another contact....if you find a fix please let me know!
     
  3. macrumors newbie

    Joined:
    Oct 31, 2007
    #3
    cmoralespv,

    It seems like I have the exactsame problem.

    I jailbreak via (jailbreakme.com)
    I unlocked via anySim
    I am on the Rogers network in Canada.

    Anyone else have this happening and knows of a fix?
     
  4. macrumors newbie

    Joined:
    Oct 31, 2007
    #4
    After further looking into it this seems to only happen to one of the three contacts I have been sms messaging.

    - For a new or cleared conversation I can send text message, until I receive a message, then I get the "Error sending message" problem.
    - The contact is on the same network (Rogers)
    - iPhone is displaying the time of the message received is about 6hr before the first mesage I sent.

    Things that I have done that don't seem to work:
    - rebooting the phone
    - taking out the sim card and putting it back in
    - delete my sms.db file
    - add +1 dial code to the contact

    Does anyone else have other ideas?
     
  5. macrumors newbie

    Joined:
    Nov 14, 2007
    #5
    I had a similar problem not being able to send SMS, though I could receive message no problem. It turned out that the problem was with the SIM card on my unlocked phone. The SIM card had no more space to store SMS messages, so the iPhone couldn't send anymore. I know that doesn't make sense, since the iPhone doesn't actually store messages on the SIM card, but deleting SMS messages from the SIM card fixed the problem. (I had to put the SIM card back in my old phone to do that since I couldn't access the saved SMS messages with the iPhone).

    So, one thing you could try would be to try your iPhone with someone else's SIM card and see if you can send messages to the people you currently can't. If that fixes the problem, it must be your SIM card.
     
  6. macrumors newbie

    Joined:
    Oct 31, 2007
    #6
    "Error sending message" problem update: Still been two weeks and this problem won't go away. It only happens to the same contact (also on rogers). Also I have noticed the timestamp on all incoming txt messages are about 7hrs behind the current time? I live in (GST -700)....
     
  7. thread starter macrumors newbie

    Joined:
    Oct 25, 2007
    #7
    I tried sim cards from all three carriers here (bolivia) and i've discovered that the problem is only present when using a VIVA (my service provider) sim card, when I use TIGO or ENTEL sim cards (the other providers), there is no problem receiving/sending sms....could there any compatibility issues between the iphone and the sms systems of certain operators??

    cheers..
     
  8. macrumors newbie

    Joined:
    Nov 16, 2007
    #8
    VIVA in Bolivia sucks

    Hello cmoralespv,

    I'm in Bolivia (cbba) using iphone with VIVA and yes, I have the exact same problem as you described above with the "error sening message" when replying.

    This mean it's a carrier problem. Have you reported this to VIVA? I think I'm going to change to Entel. Let us know if you find a solution for VIVA.
     
  9. macrumors member

    Joined:
    Feb 14, 2007
    Location:
    sitting down with warm legs
    #9
    i am having this problem with any contact i try to SMS, and my iPhone isn't unlocked.

    my number was ported over today and i can make and receive calls no problem.

    i'm going to go to 02 shop tomorrow, but was hoping someone knew something i could try.... (after reading so far..no)
     
  10. macrumors newbie

    Joined:
    Dec 17, 2003
    Location:
    Leeds, UK
    #10
    Same problem here - my old number was ported over today (due tomorrow) - and although I can make/receive calls and receive messages, I cannot send them. I guess it might be to do with the transfer.
     
  11. macrumors member

    Joined:
    Feb 14, 2007
    Location:
    sitting down with warm legs
    #11
    tbh, i dont know if i can receive them. i did ask mrs herodian to text me but she went out for someones leaving do so i suspect she's forgotten.

    women / number porting... bah.

    i can receive messages but not reply or send new ones.
     
  12. macrumors member

    Joined:
    Feb 14, 2007
    Location:
    sitting down with warm legs
    #12
    it's working now. w00t!
     
  13. macrumors newbie

    Joined:
    Nov 16, 2007
    #13
    sms sending solution

    yeaaaaaaaaaaaaaaaaaaaa

    after hours of research i found a solution for this sms problem


    its the sms message center number u need to put n iphone so u could send sms to everyone

    wat u need to do is this on iphone type this


    *5005*7672*XXXXXXXX# Call were xxxxxxxx is message center number provided by carrier to get this number u need to call customer service of ur carrier :)
     
  14. macrumors newbie

    Joined:
    Nov 21, 2007
    #14
    OK the easiest solution: I had the exact same problems and it has something to do with the sim card...especially if it's coming from a previous cell phone into an iphone. I think there is some info in the sim card that disables sms messages (sending). I went to a Rogers store and purchased a new sim card for $25. You can call Rogers customer service (*611) and tell them you are having problems with your sim card and sending txt messages...chances are they will credit your account $25 to compensate you for purchasing your new sim card at a rogers store. Everything works perfectly again.
    One problem that I am having now is not being notified on my iphone that I have a voice mail message ever since I installed the new sim card. It seems that sim cards can prevent the iphone from certain features especially when it relates to sms or voicemail indicators...I guess I would rather have an inoperable voice message indicator than an inoperable sms messaging. I'm addicted to sms messaging.
    One more note:
    A few weeks ago I was having problems when retrieving my voice mail messages on my iphone I would immediately receive 3 sms messages after retrieving my voice mail "1(23) 1(23) 1(23" one after an another; I called rogers technical support in Toronto and they said they were aware of this and apparently they were working on the problem. The surprising this is is that during this period that I was getting the weird txt messages my "visual voice mail" was working on my iphone! Yes I couldn't believe it! After receiving a voicemail message I would get a sms txt message that I had a voicemail from a caller (caller id and everything). I don't know if it was a fluke or perhaps MAYBE Rogers is working on (testing) a new service (visual voice mail) for HOPEFULLY the upcoming release of iphone or iphone nano here in Canada. I don't know, I can only hope this is true. Ever since I stopped getting the 1(23) messages as well my visual voicemail stopped working. So obviously ROgers is working on some kind of visual voice mail service. Just a couple of days ago Rogers launched a new cellular option called "voicemail to text" I was excited about this and tried it out since I still don't get my message waiting indicator to show up on my phone when I have a voicemail. Unfortunately I couldn't get it to work on my iphone after hours dealing with technical support so I just decided to cancel this new service. I will wait another month and try it out again and hopefully Rogers can trouble shoot the iphone to work with this new feature. In the mean time if anyone knows a solution to get the message waiting indicator to show on the iphone whenever I have a message waiting that would be much appreciated...I tried turning the feature on in my voicemail settings...any other ideas?
     
  15. macrumors newbie

    Joined:
    Dec 3, 2007
    #15
    Hi all!

    I have been suffering for these same symptoms for the last 10 days (since I bought my iPhone -1.0.2), i.e. I am unable to send sms replies to 2-3 contacts on my iPhone. I have run through the following steps as posted on this thread:
    1. Delete all sms's from my sim card - no change
    2. Re-enter sms service centre through phone keypad- no change
    3. Replace sim-card- no change
    However, I have stumbled upon the solution to this (at least for my iPhone!). It appears that the problem is with the phone that sends you an sms which then corrupts your chat history. The solution to this for me was:

    Get the user of the phone number that you have issues with to go through their sms settings and change the following setting as follows:

    Reply via same service center- NO


    Both numbers that were giving me problems are now fully operational!

    Hope this helps.
     
  16. macrumors regular

    Joined:
    Sep 19, 2006
    Location:
    Delft
    #16
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko) Version/3.0 Mobile/3B48b Safari/419.3)

    the only times I've seen that error is when I was out of credit, so maybe it is your sim.
     
  17. macrumors newbie

    Joined:
    Dec 10, 2007
    #17
    I've got the same problem. 1.1.1 Unlocked on Rogers. I can send to all contacts except one. I have to clear msgs, then send I can reply. Anyone find a fix for this?

    What is the rogers txt message gateway #, and how do I change it in the iphone settings i cant find the menu for it.
     
  18. macrumors newbie

    Joined:
    Dec 3, 2007
    #18
    Did you try to follow all the procedures in my post? I found it worked very well on another 1.1.1.
     
  19. macrumors newbie

    Joined:
    Dec 10, 2007
    #19
    Yes. I tried everything, but the solution has been found and resolved.

    I was trying to send sms's to a sony ericcson, and changing the 'reply to service sender was not an option available. Instead, i found that "request reply" was on. After turning this off i could send to the sony ericsson with ease!

    Thanks again Amar, you da man
     
  20. macrumors newbie

    Joined:
    Dec 3, 2007
    #20
    You're welcome! Glad to be of assistance. Cheers!
     
  21. macrumors newbie

    Joined:
    Dec 13, 2007
    #21
    AHHHH its worse now


    I followed the step and used rogers message center number and now i can't send a SMS message to anyone of my contacts... i was doing this originally beacuse one of my contacts was usesing a pearl blackberry and i got "error sending message" and so i tried the instuctions and now i'm fuct....

    Please anyone any help would be greatly apriciated!!!
     
  22. macrumors newbie

    Joined:
    Jun 30, 2007
    #22
    I get this when the connection is down or isn't strong, such as a weak signal area. It could just be that your connections aren't strong enough to transmit data...I get dropped data a lot in particular areas of my house, etc.
     
  23. macrumors newbie

    Joined:
    Dec 3, 2007
    #23
    Hi there! What was the exact number you input as your message center number?
     
  24. macrumors newbie

    Joined:
    Dec 13, 2007
    #24
    the exact number is...

    17057969300

    *5005*7672*17057969300#

    did i use the wrong number??

    Rogers Canada

    Thanks for any help!
     
  25. macrumors newbie

    Joined:
    Dec 3, 2007
    #25
    Hi! You're mising the '+' sign before the country code. It should read:

    *5005*7672*+17057969300#

    Cheers!
     

Share This Page