iPhone SMS shows 1 unread text.. but there is none

Discussion in 'iPhone' started by unlimitedx, Jun 28, 2010.

  1. macrumors 6502a

    Joined:
    Jun 15, 2010
    #1
    how do i change it?? it is annoying :( it shows a popup of 1 message unread but all are read :confused:
     
  2. macrumors newbie

    Joined:
    Jun 23, 2010
    #2
    happens occasionally to me.

    try restarting the phone, thats always worked for me.
     
  3. macrumors 6502a

    Joined:
    Jun 20, 2010
    #3
    Restart the phone?
     
  4. macrumors 6502a

    mloffa

    Joined:
    Jul 13, 2009
    Location:
    New York
    #4
    ^ if that doesn't work.

    Press and hold both the Home and Sleep/Wake button for about 10 secs.
     
  5. macrumors member

    Joined:
    Apr 18, 2009
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A293 Safari/6531.22.7)

    Mines been doing the same. Sometimes I get a text and it don't show in the SMS app unless I use the search option. I'm thinking because i restored from a backup onto the i4 and had quickreply on my 3GS originally.
     
  6. macrumors newbie

    Joined:
    Jun 29, 2010
    #6
    This has been happening to me as well. It'll even add a number to the alert "bubble" when I send a message sometimes. I called Apple™ support yesterday and both 1st and 2nd level techs had no idea what was causing it. They advised that I restore the phone as new, which I'd rather not do. I too restored from backup from my 3G, but I wasn't jailbroken and I wasn't using any non-standard apps. More specifically, I wasn't using quickreply. I'd love to figure out how to get this fixed.
     
  7. macrumors 65816

    Knowimagination

    Joined:
    Apr 6, 2010
    #7
    This must be an ios4 bug because I have had it on my 3GS since I updated. Normally a restart fixes it for me
     
  8. macrumors 6502

    Joined:
    Sep 6, 2007
    Location:
    SOUTH
    #8
    I've always had this problem on all of my iphones...

    usually goes away on its own
     
  9. macrumors 6502

    jrcsh6

    Joined:
    Jul 1, 2008
    #9
    i've had it. it seems to go away with a little time. i've not had to restart. just ignore for a bit. it goes away.
     
  10. macrumors 6502

    jrcsh6

    Joined:
    Jul 1, 2008
    #10
    i've had it. it seems to go away with a little time. i've not had to restart. just ignore for a bit. it goes away.
     
  11. macrumors newbie

    Joined:
    Jun 29, 2010
    #11
    So has anyone had any solution on this problem? I still haven't been able to get it working properly.
     
  12. macrumors 68000

    STEVESKI07

    Joined:
    Jan 6, 2009
    Location:
    Washington, DC
    #12
    Besides the 6-7 people above you that say restarting it fixes it, no.
     
  13. macrumors regular

    Joined:
    Oct 14, 2009
    #13
    or quit the SMS app in the task manager >fixed :D
     
  14. macrumors regular

    Joined:
    Jul 12, 2010
    #14
    Send yourself a text, and it should go away then.

    Works for me every time
     
  15. macrumors regular

    Joined:
    Jun 8, 2010
    #15
    Never seen this problem on any iPhone generation, and I have owned them all.
     
  16. macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #16
    I just buy a new iPhone when this happens to me.
     
  17. macrumors 65816

    WhySoSerious

    Joined:
    Jun 30, 2007
    Location:
    Dallas, TX
    #17
    that sh** seriously make me laugh out loud for some reason. :D
     
  18. macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #18
    Just doing my job. :)
     
  19. macrumors 65816

    SAD*FACED*CLOWN

    Joined:
    Apr 5, 2010
    Location:
    Houston, TX
    #19
    yep...there are other bugs in the SMS app as well
     
  20. macrumors 6502

    Joined:
    Jun 18, 2010
    Location:
    Rip City
    #20
    I've had this problem in 3.0 as well, so it's not an iOS4 exclusive problem.
     
  21. macrumors member

    Joined:
    Apr 18, 2009
    #21
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A293 Safari/6531.22.7)

    Restoring mines fixed the problem. I set it up as new. Then used google to sync my contacts back. Haven't had that problem again.
     
  22. macrumors 68040

    Roessnakhan

    Joined:
    Sep 16, 2007
    Location:
    Albuquerque, USA
    #22
    If I exit the app and also close it in the taskbar it seems to fix it.
     
  23. macrumors 6502a

    Joined:
    Jun 15, 2010
    #23
    This has happened with every OS. It's completely normal...as in a annoying and should be fixed normal.

    Not a big deal though, you can wait until someone texts you or even restart your phone if it bothers you that much.
     
  24. macrumors newbie

    Joined:
    Jan 7, 2012
    #24
    I was able to fix this when it happened to me. It turns out that a message in a 'Group' (SMS w/ multiple people) was unread.

    I found this by pulling down on the screen from top to bottom and the notification summary dashboard listed the 'unread message.' After selecting the message, I was directed to te mystery unread message.

    Now I don't have the badge (1 new message) alert anymore.

    Hope it works for you guys too!!
     
  25. Coda70, Mar 20, 2012
    Last edited: Mar 21, 2012

    macrumors newbie

    Joined:
    Mar 20, 2012
    #25
    Fixed it

    I tried all the suggestions here and nothing worked.

    It turned out I needed to open each SMS conversation and scroll through to the top to find the unread message. That fixed it.

    We all have that one friend who is always texting us cute little inspirational sayings that we usually ignore, right? Well, it turns out they will haunt you with a little red bubble with the number 1 in it unless we at least pretend to read them!

    Thank you for letting me be of service.
     

Share This Page