iPhone stuck in recovery mode & won't restore in iTunes

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rmd717, Jun 27, 2009.

  1. macrumors newbie

    Joined:
    Jun 27, 2009
    #1
    Desperately need help!

    I have a hacked 1st generation iPhone. I've successfully hacked for two separate software upgrades in the past. Unfortunately for this current 3.0 update I'm not as lucky.

    Here's what happened:
    2 weeks ago my iPhone was acting up... applications would quit on me and then finally the phone went into recovery mode, requesting I connect to iTunes. I was able to find sites that provided steps allowing me to upgrade to 3.0 and rehack my phone.... so I attempted it.

    I attempted to restore and update in iTunes... but different errors kept popping up bringing my iPhone back to recovery mode. Finally after the 4th or 5th attempt I was successful. My phone was unlocked and jailbroken... I resumed and followed through to sync my iPhone with iTunes. In the middle of the sync... another error comes up and puts my iPhone back into recovery mode.

    Since that last attempt... I can only turn off my iPhone with a hard reset (holding home & sleep/wake button). And when I turn it back on it flashes back-and-forth slowly from the apple logo to the recovery mode screen. iTunes recognizes the device in recovery mode... but when I try to restore it I keep on getting "error 28". I can't seem to find out ANYWHERE what "error 28" means. I've even attempted uninstalling and reinstalling iTunes. I'm worried my iPhone is completely dead.

    Can someone please help me?!!! Trust me, I hate that I have to hack the iPhone... but I'm happy with my T-mobile plan and can't afford AT&T's overpriced plans! I'm a Mac user and I LOVE my iPhone and I'm going crazy without it!!!

    I'm on a MacBook Pro OSX 10.4.11
    Running the latest iTunes 8.2
    I've tried both Pwnage 3.0 and Redsnow 0.7.2

    I'd appreciate any constructive feedback... THANK YOU =D
     
  2. macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    1. Get your phone into DFU mode and reload the 3.0 firmware cleanly through iTunes

    This clip shows you how to get into DFU: http://www.youtube.com/watch?v=ofpinyGlQ8I, you will not see the recovery mode screen when you are in DFU.

    2. Put the phone back into DFU and run RedSn0w including the unlock

    3. Restore from your backup if you need to
     
  3. thread starter macrumors newbie

    Joined:
    Jun 27, 2009
    #3
    Hi Moi!

    Thanks for the assistance!... but I've tried many times to restore my iPhone in DFU mode and I still get the "error 28".

    I get the error message during restore whether I'm in DFU mode or not... that's what's soooooo frustrating! And I know I'm putting it into DFU mode correctly because I've hacked my phone twice before after updating to past firmwares.

    A friend told me I need to figure out how to "fully" restore my iPhone into disk recovery mode. But when I google "restore my iPhone into disk recovery mode"... I get the same instructions about putting my iPhone into DFU mode and connecting to iTunes.
     
  4. macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #4
    Just a thought that it may be your version of OS X that is the problem, are you able to try it on an up to date version? Or on a Windows machine?
     
  5. thread starter macrumors newbie

    Joined:
    Jun 27, 2009
    #5
    I wish it was my computer... I even tried restoring on my boyfriend's PC and I got the same "error 28" on his iTunes.
     
  6. macrumors newbie

    Joined:
    Oct 9, 2009
    #6
    I am having the same problem, is always giving the error 28 when I want to restore
     
  7. macrumors newbie

    Joined:
    Oct 9, 2009
    #7
    For those(like me) who have the Error 28, the problem is a bad dock connector on the iPhone.
    You Must replace it.
    Nicolai
     
  8. macrumors 6502a

    DEE9299

    Joined:
    Oct 3, 2009
    Location:
    Boston Mass.
    #8
    did you replace it because my dock connector is broken but i still got the error 28 message and if it fixed yours maybe it will fix mine
     
  9. macrumors newbie

    Joined:
    Oct 9, 2009
    #9
    @DEE9299

    I sent it to the repair shop(not Apple), I noticed when is repair


    Nicolai
     
  10. macrumors 6502a

    DEE9299

    Joined:
    Oct 3, 2009
    Location:
    Boston Mass.
    #10
    ok i am gonna swap mine out today my connector is broke too and i got that error 28 message as well
     
  11. macrumors newbie

    Joined:
    Oct 9, 2009
    #11
    Very careful! is a tricky job!


    Nicolai
     
  12. macrumors 6502a

    DEE9299

    Joined:
    Oct 3, 2009
    Location:
    Boston Mass.
    #12
    i know i am swapping the complete assembly so there is no soldering involved
     

Share This Page