iPhone "unknown" caller ID...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by currahee2100, Feb 9, 2009.

  1. macrumors member

    Joined:
    Feb 9, 2009
    #1
    Hey guys first timer here ! ;)
    I just began to have this really weird problem on my iPhone and I'm wondering if you guys have seen anything like it.

    Basically I can make/recieve calls fine. However if I recieve a call it will show up as "unknown".... no numbers will show up. It's just unknown. This goes for everyone on my contacts list.

    However it has NO TROUBLE at all in identifying texts that I recieve. I dialed up AT&T, they wanna do a reset but I need another phone which I don't have... and the nearest AT&T store to me is 30m away, and the nearest apple store is 50m away...
     
  2. macrumors 68040

    Joined:
    Feb 14, 2008
    #2
    Restore. It fixes most software glitches (what this sounds like).
     
  3. thread starter macrumors member

    Joined:
    Feb 9, 2009
    #3
    I've done two restores already... (thanks for the response btw)... no go.
    One without the carrier update for AT&T, and that obviously failed and one normal restore without restoring a backup... still does the same thing.

    Could it be a hardware issue do you think? :(
     
  4. macrumors 68040

    Joined:
    Feb 14, 2008
    #4
    I can't think of any way this would be hardware related...

    I'm not sure where you're located but if you're in a country where country codes are used, you may need to enter them in the phonebook exactly as they show up on the caller id (check another phone). I know some places actually insert characters in front of numbers. I've even seen it in the US (ex. +17205454874).
     
  5. macrumors 6502

    Joined:
    Oct 25, 2007
    Location:
    Ontario, Canada
    #5
    bumping... I have the same issue, I'm in Canada and all calls show up as unknown regardless if they're in my address book or not.
     
  6. macrumors 68040

    Joined:
    Feb 14, 2008
    #6
    Then your phone is not working as it should. Take it to Apple and get a new one.
     
  7. macrumors 6502

    Joined:
    Oct 25, 2007
    Location:
    Ontario, Canada
    #7
    Apparently on Rogers you have to pay for Caller ID, even if the number is in your contact list it's going to show up as Unknown if you don't have a caller id plan. So stupid... :mad:
     
  8. macrumors newbie

    Joined:
    May 17, 2010
    #8
    Was searching for an answer to this problem. Found the answer so though I might close the loop for future travellers...

    First point to note is that this is nothing to do with handset settings on functionality. There is no switch on or off for caller ID for incoming calls on iphone -- the caller ID setting in your phone setting is only for whether you want to show your number to people you call. I spoke to the help desk at apple, they walked me through this and said there is really nothing you can do on the iphone that could solve this and recommended I not try a system restore as that would just be a headache for me getting everything back how I wanted it. Its a carrier issue - no question.

    I phoned my carrier and spoke to the mobile tech support people. They said the caller ID service was not showing on the account. They said it is usually there and they could try a few things to get it back, with the last resort being to escalate the query to another level of tech support. The guy then proceeded to try a simple "refresh", of the account services. That didn't work and then he found that someone had put a code on the account to block caller ID (go figure??) so he deleted that and refreshed and then called my iPhone from another line to confirm it was working. So I had the service working correctly before I hung up from my landline.
     
  9. macrumors newbie

    Joined:
    Jan 1, 2011
    #9
    It's a software problem

    It should be a software problem because I use to be able to see the details of the person calling me and then I update to iOS 4.2 (or whatever the recent one was) and then the callers came unknown. I've been to apple and they said just deal with it until the next update.
     
  10. macrumors regular

    Vick84

    Joined:
    Sep 6, 2010
    #10
    did you notice the date of this thread before you replied?
     
  11. macrumors G5

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #11
    And you replied to the post in questions 4 hours after? Sorta self serving your own post.
     
  12. macrumors regular

    Vick84

    Joined:
    Sep 6, 2010
    #12
    yup, thats one way to look at it :p
     
  13. macrumors member

    Joined:
    Sep 13, 2010
    #13
    I think you are doing something wrong when you restore. It can't be a hardware problem, it is a software problem. So, when you restore, it should go to normal. Take it to Apple, they will know what to do:confused:

    Uupss... To late! I thought it's recent. Never mind, if someone has this problem, he knows now how to solve it.
     
  14. macrumors regular

    codyst

    Joined:
    Nov 18, 2008
    Location:
    Austin, TX
    #14
    Wirelessly posted (iPhone 4: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Children children... Wooo-sahhh!
     
  15. macrumors newbie

    Joined:
    Nov 30, 2011
    #15
    Similar issue but not exactly

    I have not exactly the same problem but in one similar and probably you could have an idea: when I receive an incoming call, the dislay shows only the called party number and not the name, even for contacts existing already in my IPhone 4.
    Thanks in advance.
     
  16. macrumors newbie

    Joined:
    Nov 24, 2011
    #16
    i have that problem on my 4S too. most of callers from my contact list are show correct, few of them only show numbers with missing country codes.
    it suppose to show: +1 (555) 123 4567, but only show: +5 (551) 23-45-67. sometime show like: +5 551 234567
    i tried switching in Settings>General>International>Region Format to US then back to Canada, still not help :confused:
     
  17. macrumors newbie

    Joined:
    Dec 30, 2011
    #17
    "unknown"???

    anybody find the fix yet?

    i've had this prob since i got the phone in sept and have tried everything at every forum i could find with no avail.
     

Share This Page